Skip to content
Snippets Groups Projects
Commit c7309282 authored by KristofRobot's avatar KristofRobot
Browse files

Merge pull request #238 from bulwahn/updates

recipe updates to keep in-sync with the hydro distribution
parents 8cf69899 db1da76e
No related branches found
No related tags found
No related merge requests found
Showing
with 8 additions and 203 deletions
......@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "8b7c9efe41b85314ed098e80173cfe33"
SRC_URI[sha256sum] = "47ffa94191393c7e57c9320b65b1f7bf8a50061d6ef7f536535fe912fa42d8ac"
SRC_URI[md5sum] = "fa8af05872962d3b0df9492df5fd63af"
SRC_URI[sha256sum] = "a6e26e1285c881fbf51ddb67a76a59302d2e78cfd6d380b99908110f2411f1df"
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
......
DESCRIPTION = "\
The class_loader package is a ROS-independent package for loading plugins \
DESCRIPTION = "The class_loader package is a ROS-independent package for loading plugins \
during runtime and the foundation of the higher level ROS "pluginlib" library. \
class_loader utilizes the host operating system's runtime loader to open \
runtime libraries (e.g. .so/.dll files), introspect the library for exported \
plugin classes, and allows users to instantiate objects of said exported \
classes without the explicit declaration (i.e. header file) for those classes.\
"
classes without the explicit declaration (i.e. header file) for those classes."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
......@@ -13,8 +11,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "console-bridge libpoco"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "fd24802f3cf2e9167561a89be25c24e5"
SRC_URI[sha256sum] = "7279ffe4e7481e71e9c0b6f0dc42e9c6b991100c5d1e7c6034cf28443846de83"
SRC_URI[md5sum] = "cb3a369025092087d5c47dbfbb8e9439"
SRC_URI[sha256sum] = "84fc8e32648fb8c76a58d4e116884b9c6f28470c60d9508d4aeb18d407f42940"
S = "${WORKDIR}/${ROS_SP}"
......
From 3d0a814884fdf638f8f8f11078113c0568e120bb Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 18:13:01 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
base_local_planner/CMakeLists.txt | 30 ++++++++++++++++--------------
base_local_planner/package.xml | 2 +-
2 files changed, 17 insertions(+), 15 deletions(-)
diff --git a/base_local_planner/CMakeLists.txt b/base_local_planner/CMakeLists.txt
index a924092..6637ee7 100644
--- a/base_local_planner/CMakeLists.txt
+++ b/base_local_planner/CMakeLists.txt
@@ -125,17 +125,19 @@ install(DIRECTORY include/${PROJECT_NAME}/
PATTERN ".svn" EXCLUDE
)
-catkin_add_gtest(base_local_planner_utest
- test/gtest_main.cpp
- test/utest.cpp
- test/velocity_iterator_test.cpp
- test/footprint_helper_test.cpp
- test/trajectory_generator_test.cpp
- test/map_grid_test.cpp)
-target_link_libraries(base_local_planner_utest
- base_local_planner trajectory_planner_ros
- )
-
-
-catkin_add_gtest(line_iterator
- test/line_iterator_test.cpp)
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(base_local_planner_utest
+ test/gtest_main.cpp
+ test/utest.cpp
+ test/velocity_iterator_test.cpp
+ test/footprint_helper_test.cpp
+ test/trajectory_generator_test.cpp
+ test/map_grid_test.cpp)
+ target_link_libraries(base_local_planner_utest
+ base_local_planner trajectory_planner_ros
+ )
+
+
+ catkin_add_gtest(line_iterator
+ test/line_iterator_test.cpp)
+endif()
diff --git a/base_local_planner/package.xml b/base_local_planner/package.xml
index d9f1de2..3420396 100644
--- a/base_local_planner/package.xml
+++ b/base_local_planner/package.xml
@@ -13,7 +13,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/base_local_planner</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>std_msgs</build_depend>
<build_depend>nav_msgs</build_depend>
--
1.8.1.2
......@@ -8,5 +8,3 @@ DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-
voxel-grid visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
From 74a2a421f3802b5bddf8be794e16af9bef4ae1fc Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Mon, 14 Oct 2013 08:47:46 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
map_server/CMakeLists.txt | 39 +++++++++++++++++++++------------------
map_server/package.xml | 2 +-
2 files changed, 22 insertions(+), 19 deletions(-)
diff --git a/map_server/CMakeLists.txt b/map_server/CMakeLists.txt
index 09bef0f..3f41a21 100644
--- a/map_server/CMakeLists.txt
+++ b/map_server/CMakeLists.txt
@@ -32,6 +32,12 @@ target_link_libraries(map_server
${catkin_LIBRARIES}
)
+add_executable(map_server-map_saver src/map_saver.cpp)
+set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
+target_link_libraries(map_server-map_saver
+ ${catkin_LIBRARIES}
+ )
+
# copy test data to same place as tests are run
function(copy_test_data)
cmake_parse_arguments(PROJECT "" "" "FILES" ${ARGN})
@@ -40,26 +46,23 @@ function(copy_test_data)
endforeach()
endfunction()
-copy_test_data( FILES
- test/testmap.bmp
- test/testmap.png )
-catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
-target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
-
-add_executable(rtest test/rtest.cpp test/test_constants.cpp)
-target_link_libraries( rtest
- gtest
- ${catkin_LIBRARIES}
-)
-add_dependencies(rtest nav_msgs_gencpp)
+## Tests
+if(CATKIN_ENABLE_TESTING)
+ copy_test_data( FILES
+ test/testmap.bmp
+ test/testmap.png )
+ catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
+ target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
-add_executable(map_server-map_saver src/map_saver.cpp)
-set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
-target_link_libraries(map_server-map_saver
- ${catkin_LIBRARIES}
- )
+ add_executable(rtest test/rtest.cpp test/test_constants.cpp)
+ target_link_libraries( rtest
+ gtest
+ ${catkin_LIBRARIES}
+ )
+ add_dependencies(rtest nav_msgs_gencpp)
-add_rostest(test/rtest.xml)
+ add_rostest(test/rtest.xml)
+endif()
## Install executables and/or libraries
install(TARGETS map_server-map_saver map_server image_loader
diff --git a/map_server/package.xml b/map_server/package.xml
index 2b336de..811734a 100644
--- a/map_server/package.xml
+++ b/map_server/package.xml
@@ -12,7 +12,7 @@
<url>http://wiki.ros.org/map_server</url>
<license>BSD</license>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
<build_depend>rostest</build_depend>
--
1.8.1.2
......@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767cc
DEPENDS = "libsdl-image nav-msgs roscpp rostest tf yaml-cpp"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
From be3ed623e765267ad3a64088295bdb63781c535b Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 19:52:14 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
navfn/CMakeLists.txt | 4 +++-
navfn/package.xml | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/navfn/CMakeLists.txt b/navfn/CMakeLists.txt
index 005d7eb..2a29409 100644
--- a/navfn/CMakeLists.txt
+++ b/navfn/CMakeLists.txt
@@ -121,4 +121,6 @@ endif (NAVFN_HAVE_FLTK AND NAVFN_HAVE_NETPBM AND NOT APPLE)
# message (STATUS "pgm.h not found (optional)")
# endif (NAVFN_HAVE_NETPBM)
-add_subdirectory(test)
+if(CATKIN_ENABLE_TESTING)
+ add_subdirectory(test)
+endif()
diff --git a/navfn/package.xml b/navfn/package.xml
index bf44445..99e6589 100644
--- a/navfn/package.xml
+++ b/navfn/package.xml
@@ -13,7 +13,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/navfn</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>costmap_2d</build_depend>
<build_depend>geometry_msgs</build_depend>
--
1.8.1.2
......@@ -7,5 +7,3 @@ DEPENDS = "costmap-2d geometry-msgs nav-core nav-msgs pcl-conversions pcl-ros \
pluginlib rosconsole roscpp tf visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "cddadf97a28ccffe93c0d662639801d5"
SRC_URI[sha256sum] = "402f1800577d22a168882aa99754d99cfd0a54e9a02a1ec804c351cd327d7540"
SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8"
SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment