diff --git a/recipes-ros/catkin/catkin_0.5.85.bb b/recipes-ros/catkin/catkin_0.5.86.bb
similarity index 87%
rename from recipes-ros/catkin/catkin_0.5.85.bb
rename to recipes-ros/catkin/catkin_0.5.86.bb
index 3c6304d31eee85ba5defa675efbeaa151189c2d6..18724f7a185145843395788048ab05f30a615a7d 100644
--- a/recipes-ros/catkin/catkin_0.5.85.bb
+++ b/recipes-ros/catkin/catkin_0.5.86.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
 DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "8b7c9efe41b85314ed098e80173cfe33"
-SRC_URI[sha256sum] = "47ffa94191393c7e57c9320b65b1f7bf8a50061d6ef7f536535fe912fa42d8ac"
+SRC_URI[md5sum] = "fa8af05872962d3b0df9492df5fd63af"
+SRC_URI[sha256sum] = "a6e26e1285c881fbf51ddb67a76a59302d2e78cfd6d380b99908110f2411f1df"
 
 SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
 
diff --git a/recipes-ros/class-loader/class-loader_0.2.3.bb b/recipes-ros/class-loader/class-loader_0.2.5.bb
similarity index 73%
rename from recipes-ros/class-loader/class-loader_0.2.3.bb
rename to recipes-ros/class-loader/class-loader_0.2.5.bb
index fbc3dc703b872e4b1ef91a107f119724d98079f1..6c62a12ea9c9a9ae1ca19e4fbc1364abf99810d0 100644
--- a/recipes-ros/class-loader/class-loader_0.2.3.bb
+++ b/recipes-ros/class-loader/class-loader_0.2.5.bb
@@ -1,11 +1,9 @@
-DESCRIPTION = "\
-The class_loader package is a ROS-independent package for loading plugins \
+DESCRIPTION = "The class_loader package is a ROS-independent package for loading plugins \
 during runtime and the foundation of the higher level ROS "pluginlib" library. \
 class_loader utilizes the host operating system's runtime loader to open \
 runtime libraries (e.g. .so/.dll files), introspect the library for exported \
 plugin classes, and allows users to instantiate objects of said exported \
-classes without the explicit declaration (i.e. header file) for those classes.\
-"
+classes without the explicit declaration (i.e. header file) for those classes."
 SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
@@ -13,8 +11,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
 DEPENDS = "console-bridge libpoco"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "fd24802f3cf2e9167561a89be25c24e5"
-SRC_URI[sha256sum] = "7279ffe4e7481e71e9c0b6f0dc42e9c6b991100c5d1e7c6034cf28443846de83"
+SRC_URI[md5sum] = "cb3a369025092087d5c47dbfbb8e9439"
+SRC_URI[sha256sum] = "84fc8e32648fb8c76a58d4e116884b9c6f28470c60d9508d4aeb18d407f42940"
 
 S = "${WORKDIR}/${ROS_SP}"
 
diff --git a/recipes-ros/navigation/amcl_1.11.4.bb b/recipes-ros/navigation/amcl_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/amcl_1.11.4.bb
rename to recipes-ros/navigation/amcl_1.11.6.bb
diff --git a/recipes-ros/navigation/base-local-planner/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/navigation/base-local-planner/0001-check-for-CATKIN_ENABLE_TESTING.patch
deleted file mode 100644
index 25994e9e693405a4b40a542fdc460668205bb0af..0000000000000000000000000000000000000000
--- a/recipes-ros/navigation/base-local-planner/0001-check-for-CATKIN_ENABLE_TESTING.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 3d0a814884fdf638f8f8f11078113c0568e120bb Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Sun, 13 Oct 2013 18:13:01 +0200
-Subject: [PATCH] check for CATKIN_ENABLE_TESTING
-
----
- base_local_planner/CMakeLists.txt | 30 ++++++++++++++++--------------
- base_local_planner/package.xml    |  2 +-
- 2 files changed, 17 insertions(+), 15 deletions(-)
-
-diff --git a/base_local_planner/CMakeLists.txt b/base_local_planner/CMakeLists.txt
-index a924092..6637ee7 100644
---- a/base_local_planner/CMakeLists.txt
-+++ b/base_local_planner/CMakeLists.txt
-@@ -125,17 +125,19 @@ install(DIRECTORY include/${PROJECT_NAME}/
-   PATTERN ".svn" EXCLUDE
- )
- 
--catkin_add_gtest(base_local_planner_utest
--	test/gtest_main.cpp
--	test/utest.cpp
--	test/velocity_iterator_test.cpp
--	test/footprint_helper_test.cpp
--	test/trajectory_generator_test.cpp
--	test/map_grid_test.cpp)
--target_link_libraries(base_local_planner_utest
--    base_local_planner trajectory_planner_ros
--    )
--
--
--catkin_add_gtest(line_iterator
--    test/line_iterator_test.cpp)
-+if(CATKIN_ENABLE_TESTING)
-+  catkin_add_gtest(base_local_planner_utest
-+    test/gtest_main.cpp
-+    test/utest.cpp
-+    test/velocity_iterator_test.cpp
-+    test/footprint_helper_test.cpp
-+    test/trajectory_generator_test.cpp
-+    test/map_grid_test.cpp)
-+  target_link_libraries(base_local_planner_utest
-+      base_local_planner trajectory_planner_ros
-+      )
-+
-+
-+  catkin_add_gtest(line_iterator
-+      test/line_iterator_test.cpp)
-+endif()
-diff --git a/base_local_planner/package.xml b/base_local_planner/package.xml
-index d9f1de2..3420396 100644
---- a/base_local_planner/package.xml
-+++ b/base_local_planner/package.xml
-@@ -13,7 +13,7 @@
-     <license>BSD</license>
-     <url>http://wiki.ros.org/base_local_planner</url>
- 
--    <buildtool_depend>catkin</buildtool_depend>
-+    <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
- 
-     <build_depend>std_msgs</build_depend>
-     <build_depend>nav_msgs</build_depend>
--- 
-1.8.1.2
-
diff --git a/recipes-ros/navigation/base-local-planner_1.11.4.bb b/recipes-ros/navigation/base-local-planner_1.11.6.bb
similarity index 87%
rename from recipes-ros/navigation/base-local-planner_1.11.4.bb
rename to recipes-ros/navigation/base-local-planner_1.11.6.bb
index 05968049ac1bfa802ae4366eab46f857d8271013..695520df958faa98f4eaa766c193d7abe60d7cb5 100644
--- a/recipes-ros/navigation/base-local-planner_1.11.4.bb
+++ b/recipes-ros/navigation/base-local-planner_1.11.6.bb
@@ -8,5 +8,3 @@ DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-
   voxel-grid visualization-msgs"
 
 require navigation.inc
-
-SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
diff --git a/recipes-ros/navigation/carrot-planner_1.11.4.bb b/recipes-ros/navigation/carrot-planner_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/carrot-planner_1.11.4.bb
rename to recipes-ros/navigation/carrot-planner_1.11.6.bb
diff --git a/recipes-ros/navigation/clear-costmap-recovery_1.11.4.bb b/recipes-ros/navigation/clear-costmap-recovery_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/clear-costmap-recovery_1.11.4.bb
rename to recipes-ros/navigation/clear-costmap-recovery_1.11.6.bb
diff --git a/recipes-ros/navigation/costmap-2d_1.11.4.bb b/recipes-ros/navigation/costmap-2d_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/costmap-2d_1.11.4.bb
rename to recipes-ros/navigation/costmap-2d_1.11.6.bb
diff --git a/recipes-ros/navigation/dwa-local-planner_1.11.4.bb b/recipes-ros/navigation/dwa-local-planner_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/dwa-local-planner_1.11.4.bb
rename to recipes-ros/navigation/dwa-local-planner_1.11.6.bb
diff --git a/recipes-ros/navigation/fake-localization_1.11.4.bb b/recipes-ros/navigation/fake-localization_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/fake-localization_1.11.4.bb
rename to recipes-ros/navigation/fake-localization_1.11.6.bb
diff --git a/recipes-ros/navigation/global-planner_1.11.4.bb b/recipes-ros/navigation/global-planner_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/global-planner_1.11.4.bb
rename to recipes-ros/navigation/global-planner_1.11.6.bb
diff --git a/recipes-ros/navigation/map-server/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/navigation/map-server/0001-check-for-CATKIN_ENABLE_TESTING.patch
deleted file mode 100644
index 169f26cf3d99416dc0d531c7fa9ab365801db273..0000000000000000000000000000000000000000
--- a/recipes-ros/navigation/map-server/0001-check-for-CATKIN_ENABLE_TESTING.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 74a2a421f3802b5bddf8be794e16af9bef4ae1fc Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Mon, 14 Oct 2013 08:47:46 +0200
-Subject: [PATCH] check for CATKIN_ENABLE_TESTING
-
----
- map_server/CMakeLists.txt | 39 +++++++++++++++++++++------------------
- map_server/package.xml    |  2 +-
- 2 files changed, 22 insertions(+), 19 deletions(-)
-
-diff --git a/map_server/CMakeLists.txt b/map_server/CMakeLists.txt
-index 09bef0f..3f41a21 100644
---- a/map_server/CMakeLists.txt
-+++ b/map_server/CMakeLists.txt
-@@ -32,6 +32,12 @@ target_link_libraries(map_server
-     ${catkin_LIBRARIES}
- )
- 
-+add_executable(map_server-map_saver src/map_saver.cpp)
-+set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
-+target_link_libraries(map_server-map_saver
-+    ${catkin_LIBRARIES}
-+    )
-+
- # copy test data to same place as tests are run
- function(copy_test_data)
-     cmake_parse_arguments(PROJECT "" "" "FILES" ${ARGN})
-@@ -40,26 +46,23 @@ function(copy_test_data)
-     endforeach()
- endfunction()
- 
--copy_test_data( FILES
--    test/testmap.bmp
--    test/testmap.png )
--catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
--target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
--
--add_executable(rtest test/rtest.cpp test/test_constants.cpp)
--target_link_libraries( rtest
--    gtest
--    ${catkin_LIBRARIES}
--)
--add_dependencies(rtest nav_msgs_gencpp)
-+## Tests
-+if(CATKIN_ENABLE_TESTING)
-+  copy_test_data( FILES
-+      test/testmap.bmp
-+      test/testmap.png )
-+  catkin_add_gtest(${PROJECT_NAME}_utest test/utest.cpp test/test_constants.cpp)
-+  target_link_libraries(${PROJECT_NAME}_utest image_loader SDL SDL_image)
- 
--add_executable(map_server-map_saver src/map_saver.cpp)
--set_target_properties(map_server-map_saver PROPERTIES OUTPUT_NAME map_saver)
--target_link_libraries(map_server-map_saver
--    ${catkin_LIBRARIES}
--    )
-+  add_executable(rtest test/rtest.cpp test/test_constants.cpp)
-+  target_link_libraries( rtest
-+      gtest
-+      ${catkin_LIBRARIES}
-+  )
-+  add_dependencies(rtest nav_msgs_gencpp)
- 
--add_rostest(test/rtest.xml)
-+  add_rostest(test/rtest.xml)
-+endif()
- 
- ## Install executables and/or libraries
- install(TARGETS map_server-map_saver map_server image_loader
-diff --git a/map_server/package.xml b/map_server/package.xml
-index 2b336de..811734a 100644
---- a/map_server/package.xml
-+++ b/map_server/package.xml
-@@ -12,7 +12,7 @@
-     <url>http://wiki.ros.org/map_server</url>
-     <license>BSD</license>
- 
--    <buildtool_depend>catkin</buildtool_depend>
-+    <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
- 
-     <build_depend>roscpp</build_depend>
-     <build_depend>rostest</build_depend>
--- 
-1.8.1.2
-
diff --git a/recipes-ros/navigation/map-server_1.11.4.bb b/recipes-ros/navigation/map-server_1.11.6.bb
similarity index 80%
rename from recipes-ros/navigation/map-server_1.11.4.bb
rename to recipes-ros/navigation/map-server_1.11.6.bb
index 2fcca7c9295b7f9e0041e55fc49858ce9a35c978..9ff3272d2cc37001b28a49182bde3f7ec9528e6e 100644
--- a/recipes-ros/navigation/map-server_1.11.4.bb
+++ b/recipes-ros/navigation/map-server_1.11.6.bb
@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767cc
 DEPENDS = "libsdl-image nav-msgs roscpp rostest tf yaml-cpp"
 
 require navigation.inc
-
-SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
diff --git a/recipes-ros/navigation/move-base-msgs_1.11.4.bb b/recipes-ros/navigation/move-base-msgs_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/move-base-msgs_1.11.4.bb
rename to recipes-ros/navigation/move-base-msgs_1.11.6.bb
diff --git a/recipes-ros/navigation/move-base_1.11.4.bb b/recipes-ros/navigation/move-base_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/move-base_1.11.4.bb
rename to recipes-ros/navigation/move-base_1.11.6.bb
diff --git a/recipes-ros/navigation/move-slow-and-clear_1.11.4.bb b/recipes-ros/navigation/move-slow-and-clear_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/move-slow-and-clear_1.11.4.bb
rename to recipes-ros/navigation/move-slow-and-clear_1.11.6.bb
diff --git a/recipes-ros/navigation/nav-core_1.11.4.bb b/recipes-ros/navigation/nav-core_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/nav-core_1.11.4.bb
rename to recipes-ros/navigation/nav-core_1.11.6.bb
diff --git a/recipes-ros/navigation/navfn/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/navigation/navfn/0001-check-for-CATKIN_ENABLE_TESTING.patch
deleted file mode 100644
index 24261acabab9e4a89a72601cab4b0ff3b9fb6681..0000000000000000000000000000000000000000
--- a/recipes-ros/navigation/navfn/0001-check-for-CATKIN_ENABLE_TESTING.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From be3ed623e765267ad3a64088295bdb63781c535b Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Sun, 13 Oct 2013 19:52:14 +0200
-Subject: [PATCH] check for CATKIN_ENABLE_TESTING
-
----
- navfn/CMakeLists.txt | 4 +++-
- navfn/package.xml    | 2 +-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/navfn/CMakeLists.txt b/navfn/CMakeLists.txt
-index 005d7eb..2a29409 100644
---- a/navfn/CMakeLists.txt
-+++ b/navfn/CMakeLists.txt
-@@ -121,4 +121,6 @@ endif (NAVFN_HAVE_FLTK AND NAVFN_HAVE_NETPBM AND NOT APPLE)
- #   message (STATUS "pgm.h not found (optional)")
- # endif (NAVFN_HAVE_NETPBM)
- 
--add_subdirectory(test)
-+if(CATKIN_ENABLE_TESTING)
-+  add_subdirectory(test)
-+endif()
-diff --git a/navfn/package.xml b/navfn/package.xml
-index bf44445..99e6589 100644
---- a/navfn/package.xml
-+++ b/navfn/package.xml
-@@ -13,7 +13,7 @@
-     <license>BSD</license>
-     <url>http://wiki.ros.org/navfn</url>
- 
--    <buildtool_depend>catkin</buildtool_depend>
-+    <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
- 
-     <build_depend>costmap_2d</build_depend>
-     <build_depend>geometry_msgs</build_depend>
--- 
-1.8.1.2
-
diff --git a/recipes-ros/navigation/navfn_1.11.4.bb b/recipes-ros/navigation/navfn_1.11.6.bb
similarity index 84%
rename from recipes-ros/navigation/navfn_1.11.4.bb
rename to recipes-ros/navigation/navfn_1.11.6.bb
index b2378f2b8e9bb344315c64b2234205912960547e..4993a086c43dc4a465f59284c6672c903a9a6644 100644
--- a/recipes-ros/navigation/navfn_1.11.4.bb
+++ b/recipes-ros/navigation/navfn_1.11.6.bb
@@ -7,5 +7,3 @@ DEPENDS = "costmap-2d geometry-msgs nav-core nav-msgs pcl-conversions pcl-ros \
   pluginlib rosconsole roscpp tf visualization-msgs"
 
 require navigation.inc
-
-SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
diff --git a/recipes-ros/navigation/navigation.inc b/recipes-ros/navigation/navigation.inc
index 767832422e8ebd407cca0989b26267842cd74252..5fedbc08c82475d373508238f59fba96728a5896 100644
--- a/recipes-ros/navigation/navigation.inc
+++ b/recipes-ros/navigation/navigation.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "cddadf97a28ccffe93c0d662639801d5"
-SRC_URI[sha256sum] = "402f1800577d22a168882aa99754d99cfd0a54e9a02a1ec804c351cd327d7540"
+SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8"
+SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/navigation/robot-pose-ekf/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/navigation/robot-pose-ekf/0001-check-for-CATKIN_ENABLE_TESTING.patch
deleted file mode 100644
index 03314497cc3ab68a08422feb8c387b524dc60f4a..0000000000000000000000000000000000000000
--- a/recipes-ros/navigation/robot-pose-ekf/0001-check-for-CATKIN_ENABLE_TESTING.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/robot_pose_ekf/CMakeLists.txt	2014-02-26 22:23:47.631541505 +0100
-+++ b/robot_pose_ekf/CMakeLists.txt	2014-02-26 22:23:58.219541227 +0100
-@@ -77,6 +77,7 @@
- ## Tests are failing on OSX for an unknown reason
- include(CMakeDetermineSystem)
- if(CMAKE_SYSTEM_NAME MATCHES "Linux")
-+if(CATKIN_ENABLE_TESTING)
- 
- catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
- add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
-@@ -98,4 +99,5 @@
-     )
- add_rostest(${CMAKE_CURRENT_SOURCE_DIR}/test/test_robot_pose_ekf_zero_covariance.launch)
- 
-+endif(CATKIN_ENABLE_TESTING)
- endif(CMAKE_SYSTEM_NAME MATCHES "Linux")
diff --git a/recipes-ros/navigation/robot-pose-ekf_1.11.4.bb b/recipes-ros/navigation/robot-pose-ekf_1.11.6.bb
similarity index 89%
rename from recipes-ros/navigation/robot-pose-ekf_1.11.4.bb
rename to recipes-ros/navigation/robot-pose-ekf_1.11.6.bb
index 113c7c544a954cc4d08b099aec1278fe7e061951..2ab33928b6003dbaf5d493881bbcf575d29163bc 100644
--- a/recipes-ros/navigation/robot-pose-ekf_1.11.4.bb
+++ b/recipes-ros/navigation/robot-pose-ekf_1.11.6.bb
@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc
 DEPENDS = "roscpp bfl std-msgs geometry-msgs sensor-msgs nav-msgs tf"
 
 require navigation.inc
-
-SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
diff --git a/recipes-ros/navigation/rotate-recovery_1.11.4.bb b/recipes-ros/navigation/rotate-recovery_1.11.6.bb
similarity index 100%
rename from recipes-ros/navigation/rotate-recovery_1.11.4.bb
rename to recipes-ros/navigation/rotate-recovery_1.11.6.bb
diff --git a/recipes-ros/navigation/voxel-grid/0001-check-for-CATKIN_ENABLE_TESTING.patch b/recipes-ros/navigation/voxel-grid/0001-check-for-CATKIN_ENABLE_TESTING.patch
deleted file mode 100644
index 941f5573978075516bcb365e6384fa0d7b8c9857..0000000000000000000000000000000000000000
--- a/recipes-ros/navigation/voxel-grid/0001-check-for-CATKIN_ENABLE_TESTING.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 72fbc995dd302f356b891fb93e9d0cdc6416cdb8 Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Sun, 13 Oct 2013 14:11:47 +0200
-Subject: [PATCH] check for CATKIN_ENABLE_TESTING
-
----
- voxel_grid/CMakeLists.txt | 12 +++++++-----
- voxel_grid/package.xml    |  2 +-
- 2 files changed, 8 insertions(+), 6 deletions(-)
-
-diff --git a/voxel_grid/CMakeLists.txt b/voxel_grid/CMakeLists.txt
-index d8e0f54..767dd2e 100644
---- a/voxel_grid/CMakeLists.txt
-+++ b/voxel_grid/CMakeLists.txt
-@@ -35,8 +35,10 @@ install(DIRECTORY include/${PROJECT_NAME}/
-   PATTERN ".svn" EXCLUDE
- )
- 
--catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
--target_link_libraries(voxel_grid_tests
--    voxel_grid
--    ${catkin_LIBRARIES}
--    )
-+if(CATKIN_ENABLE_TESTING)
-+  catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
-+  target_link_libraries(voxel_grid_tests
-+      voxel_grid
-+      ${catkin_LIBRARIES}
-+      )
-+endif()
-diff --git a/voxel_grid/package.xml b/voxel_grid/package.xml
-index 8a4ec86..459bcb3 100644
---- a/voxel_grid/package.xml
-+++ b/voxel_grid/package.xml
-@@ -12,7 +12,7 @@
-     <license>BSD</license>
-     <url>http://wiki.ros.org/voxel_grid</url>
- 
--    <buildtool_depend>catkin</buildtool_depend>
-+    <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
- 
-     <build_depend>roscpp</build_depend>
- 
--- 
-1.8.1.2
-
diff --git a/recipes-ros/navigation/voxel-grid_1.11.4.bb b/recipes-ros/navigation/voxel-grid_1.11.6.bb
similarity index 77%
rename from recipes-ros/navigation/voxel-grid_1.11.4.bb
rename to recipes-ros/navigation/voxel-grid_1.11.6.bb
index 18ca16c619e14a0bdd3b100dd7e0755456cb0ca5..0572899764fbfb1d29a814db40818133008e4592 100644
--- a/recipes-ros/navigation/voxel-grid_1.11.4.bb
+++ b/recipes-ros/navigation/voxel-grid_1.11.6.bb
@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc
 DEPENDS = "roscpp"
 
 require navigation.inc
-
-SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
diff --git a/recipes-ros/pluginlib/pluginlib_1.9.23.bb b/recipes-ros/pluginlib/pluginlib_1.9.23.bb
deleted file mode 100644
index cdf87dc7c9727bd029d8a85fc0de07867f09e8e5..0000000000000000000000000000000000000000
--- a/recipes-ros/pluginlib/pluginlib_1.9.23.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "\
-The pluginlib package provides tools for writing and dynamically loading plugins using the ROS build infrastructure.\
-To work, these tools require plugin providers to register their plugins in the package.xml of their package.\
-"
-SECTION = "devel"
-LICENSE = "BSD & BSL-1.0"
-LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=10;md5=bbbb6ab628b1f3daee74dd9c62bee312"
-
-SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "0d7ff6323e6d2122a624463aac94d5d5"
-SRC_URI[sha256sum] = "eea71175bce307c495717ff51b793a189b5d19d7be8c564bf2ba6989dbc2c619"
-
-DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
-
-inherit catkin
diff --git a/recipes-ros/pluginlib/pluginlib_1.9.24.bb b/recipes-ros/pluginlib/pluginlib_1.9.24.bb
new file mode 100644
index 0000000000000000000000000000000000000000..cb0f72a85346baf499cad437c895c5e3548e36fb
--- /dev/null
+++ b/recipes-ros/pluginlib/pluginlib_1.9.24.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "The pluginlib package provides tools for writing and dynamically \
+  loading plugins using the ROS build infrastructure."
+SECTION = "devel"
+LICENSE = "BSD & BSL-1.0"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=10;md5=bbbb6ab628b1f3daee74dd9c62bee312"
+
+SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "681c98bb532cbd663f56f59590dcdae5"
+SRC_URI[sha256sum] = "096112e2e5063bfca583bfa4ba3e3f47b51befd5e4b6c3edcc8311986b39a70f"
+
+DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
+
+inherit catkin
diff --git a/recipes-ros/ros-comm/message-filters_1.10.1.bb b/recipes-ros/ros-comm/message-filters_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/message-filters_1.10.1.bb
rename to recipes-ros/ros-comm/message-filters_1.10.2.bb
diff --git a/recipes-ros/ros-comm/ros-comm.inc b/recipes-ros/ros-comm/ros-comm.inc
index 886e91903c17f373991d6f47ad270029b6270b94..c38701bf0cd3ad7668d37f5f334c49a27e35ef4d 100644
--- a/recipes-ros/ros-comm/ros-comm.inc
+++ b/recipes-ros/ros-comm/ros-comm.inc
@@ -1,10 +1,8 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "f4e7a8d3f5bae348a52363ac269ebb6c"
-SRC_URI[sha256sum] = "dbfe0bef76549d8615ea1e224ae471390ab88cddf7e78c41a38598e86194a302"
+SRC_URI[md5sum] = "f561ebda19fa6e737d5f06e49e925be4"
+SRC_URI[sha256sum] = "3572418e3149b54493770695e5241584f5daf9e849ab70007b16d4ce848d7e12"
 
 SRC_URI += "file://0001-rostest-is-optional.patch;patchdir=../.."
-SRC_URI[md5sum] = "c6ae46a570278bde790c5a5b951e12e5"
-SRC_URI[sha256sum] = "8303c26f2a5c7926dc1fc181a4e67868109c6379037135c21aa15f9be0cd0229"
 
 ROS_PKG_SUBDIR ?= ""
 S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
diff --git a/recipes-ros/ros-comm/rosbag-storage_1.10.1.bb b/recipes-ros/ros-comm/rosbag-storage_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosbag-storage_1.10.1.bb
rename to recipes-ros/ros-comm/rosbag-storage_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosbag_1.10.1.bb b/recipes-ros/ros-comm/rosbag_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosbag_1.10.1.bb
rename to recipes-ros/ros-comm/rosbag_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosconsole_1.10.1.bb b/recipes-ros/ros-comm/rosconsole_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosconsole_1.10.1.bb
rename to recipes-ros/ros-comm/rosconsole_1.10.2.bb
diff --git a/recipes-ros/ros-comm/roscpp_1.10.1.bb b/recipes-ros/ros-comm/roscpp_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/roscpp_1.10.1.bb
rename to recipes-ros/ros-comm/roscpp_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosgraph-msgs_1.10.1.bb b/recipes-ros/ros-comm/rosgraph-msgs_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosgraph-msgs_1.10.1.bb
rename to recipes-ros/ros-comm/rosgraph-msgs_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosgraph_1.10.1.bb b/recipes-ros/ros-comm/rosgraph_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosgraph_1.10.1.bb
rename to recipes-ros/ros-comm/rosgraph_1.10.2.bb
diff --git a/recipes-ros/ros-comm/roslaunch_1.10.1.bb b/recipes-ros/ros-comm/roslaunch_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/roslaunch_1.10.1.bb
rename to recipes-ros/ros-comm/roslaunch_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosmaster_1.10.1.bb b/recipes-ros/ros-comm/rosmaster_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosmaster_1.10.1.bb
rename to recipes-ros/ros-comm/rosmaster_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosmsg_1.10.1.bb b/recipes-ros/ros-comm/rosmsg_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosmsg_1.10.1.bb
rename to recipes-ros/ros-comm/rosmsg_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosnode_1.10.1.bb b/recipes-ros/ros-comm/rosnode_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosnode_1.10.1.bb
rename to recipes-ros/ros-comm/rosnode_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosout_1.10.1.bb b/recipes-ros/ros-comm/rosout_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosout_1.10.1.bb
rename to recipes-ros/ros-comm/rosout_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosparam_1.10.1.bb b/recipes-ros/ros-comm/rosparam_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosparam_1.10.1.bb
rename to recipes-ros/ros-comm/rosparam_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rospy_1.10.1.bb b/recipes-ros/ros-comm/rospy_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rospy_1.10.1.bb
rename to recipes-ros/ros-comm/rospy_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rosservice_1.10.1.bb b/recipes-ros/ros-comm/rosservice_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rosservice_1.10.1.bb
rename to recipes-ros/ros-comm/rosservice_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rostest_1.10.1.bb b/recipes-ros/ros-comm/rostest_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rostest_1.10.1.bb
rename to recipes-ros/ros-comm/rostest_1.10.2.bb
diff --git a/recipes-ros/ros-comm/rostopic_1.10.1.bb b/recipes-ros/ros-comm/rostopic_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/rostopic_1.10.1.bb
rename to recipes-ros/ros-comm/rostopic_1.10.2.bb
diff --git a/recipes-ros/ros-comm/roswtf_1.10.1.bb b/recipes-ros/ros-comm/roswtf_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/roswtf_1.10.1.bb
rename to recipes-ros/ros-comm/roswtf_1.10.2.bb
diff --git a/recipes-ros/ros-comm/std-srvs_1.10.1.bb b/recipes-ros/ros-comm/std-srvs_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/std-srvs_1.10.1.bb
rename to recipes-ros/ros-comm/std-srvs_1.10.2.bb
diff --git a/recipes-ros/ros-comm/topic-tools_1.10.1.bb b/recipes-ros/ros-comm/topic-tools_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/topic-tools_1.10.1.bb
rename to recipes-ros/ros-comm/topic-tools_1.10.2.bb
diff --git a/recipes-ros/ros-comm/xmlrpcpp_1.10.1.bb b/recipes-ros/ros-comm/xmlrpcpp_1.10.2.bb
similarity index 100%
rename from recipes-ros/ros-comm/xmlrpcpp_1.10.1.bb
rename to recipes-ros/ros-comm/xmlrpcpp_1.10.2.bb
diff --git a/recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.3.bb b/recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.4.bb
similarity index 75%
rename from recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.3.bb
rename to recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.4.bb
index 8403cab73a3cd5b12d04078d6b56fa3da43999a0..88c2e30e355159c8f494d502e041958d7c54ffdd 100644
--- a/recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.3.bb
+++ b/recipes-ros/rosconsole-bridge/rosconsole-bridge_0.3.4.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
 DEPENDS = "rosconsole console-bridge"
 
 SRC_URI ="https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "baee1ae9061c360b0b68d550c0f345bb"
-SRC_URI[sha256sum] = "30f69f79fbedd121263dc61825f799e13536b031872146dce653d0d4af42abd4"
+SRC_URI[md5sum] = "d847f18aa69b913f52489bb238281ee0"
+SRC_URI[sha256sum] = "3fc09e575f41d33ee31e1e4392ed09b8fed549634478e5d7176818479e9216dc"
 
 S = "${WORKDIR}/${ROS_SP}"