Skip to content
Snippets Groups Projects
Commit 1d7e90b0 authored by KristofRobot's avatar KristofRobot
Browse files

Merge pull request #330 from bulwahn/indigo-updates

Updating to ROS Indigo Distribution
parents 20d4c5f0 0a2747ae
No related branches found
No related tags found
No related merge requests found
Showing
with 9 additions and 62 deletions
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "ded8d0f0eda389413a5fea470cc81ae2"
SRC_URI[sha256sum] = "b261fd559749135e7a3ce3d6a33e700a3631e2dc100456a6f66541ad3d6956ed"
SRC_URI[md5sum] = "65e20a0b03e89c48d2de4625d8a40581"
SRC_URI[sha256sum] = "da6fddad4ebaff99d37bf7746bed9b8ea3e5ab5ce8af6bcc4faa22cbc68641d5"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
......@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
DEPENDS = "angles filters laser-geometry message-filters pluginlib roscpp sensor-msgs tf"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "4ca45f1df93c382ceaf86646940380bc"
SRC_URI[sha256sum] = "cd8c3fe908956677998061f6b3f812c5a5efa508c88064385ec6fe87cb041aec"
SRC_URI[md5sum] = "e2d4af91ee2472b76a3a805d6db35998"
SRC_URI[sha256sum] = "a6dff576ea05fb165b7c85cd5eab65970abbd6bb84339f41bad37a89c439492f"
S = "${WORKDIR}/${ROS_SP}"
......
......@@ -3,13 +3,13 @@ sensor_msgs/LaserScan into a point cloud as defined by sensor_msgs/PointCloud \
or sensor_msgs/PointCloud2."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "angles boost libeigen sensor-msgs roscpp tf"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "7ce41e57b1fdedee4bb4d181e7dd150b"
SRC_URI[sha256sum] = "7f3a8a9c2ebf0d93014ff62fc1dd38999945ea1bffb5fe30c7622e8765ea3e5d"
SRC_URI[md5sum] = "1ee7479b8c5914b4ffae996945121441"
SRC_URI[sha256sum] = "8daf8b8b571ca915d8ccbe517af5e6e69a2083a663c5ba4e89a29aa92a58abdb"
S = "${WORKDIR}/${ROS_SP}"
......
From 2cb85fa4b189ea62bc918a5fc54bb6ba73a6e125 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 19 Feb 2015 08:18:03 +0100
Subject: [PATCH] link only libraries found with find_package
When cross-compiling dwa_local_planner with the OpenEmbedded layer
for ROS, meta-ros [1], I stumbled over the following issue. During
'Linking CXX shared library devel/lib/libdwa_local_planner.so', the
g++ call for this linking step includes amongst many other arguments
these two arguments in this order:
-lbase_local_planner /[...]/sysroots/qemux86/opt/ros/hydro/lib/libbase_local_planner.so
In the meta-ros setup, the linker aborts with:
.../sysroots/x86_64-linux/usr/libexec/i586-oe-linux/gcc/i586-oe-linux/4.9.1/ld: cannot find -lbase_local_planner
The linking fails, because in the cross-compiling scenario,
-lbase_local_planner is not resolved. However, cmake and the
find_package command is set up such that the pathes are resolved
correctly in this setting. To use these correct pathes, the
link_target_libraries should not hard-code the library name, but
only use the libraries found with find_package.
Probably, this has not been noticed before, as in the common setup,
find_package resolved to the hard-coded value.
[1] https://github.com/bmwcarit/meta-ros/
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Upstream-Status: Accepted [in indigo-devel branch]
---
dwa_local_planner/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dwa_local_planner/CMakeLists.txt b/dwa_local_planner/CMakeLists.txt
index e68286e..6e9a11a 100644
--- a/dwa_local_planner/CMakeLists.txt
+++ b/dwa_local_planner/CMakeLists.txt
@@ -42,7 +42,7 @@ catkin_package(
)
add_library(dwa_local_planner src/dwa_planner.cpp src/dwa_planner_ros.cpp)
-target_link_libraries(dwa_local_planner base_local_planner ${catkin_LIBRARIES})
+target_link_libraries(dwa_local_planner ${catkin_LIBRARIES})
add_dependencies(dwa_local_planner dwa_local_planner_gencfg)
add_dependencies(dwa_local_planner nav_msgs_gencpp)
--
1.8.3.2
......@@ -8,5 +8,3 @@ DEPENDS = "base-local-planner costmap-2d dynamic-reconfigure libeigen nav-core \
nav-msgs pluginlib pcl-conversions roscpp tf"
require navigation.inc
SRC_URI += "file://0001-link-only-libraries-found-with-find_package.patch;striplevel=2"
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "06ff1b7ec7cf4d0a7292f7ceec1a923b"
SRC_URI[sha256sum] = "df843e2b2d9515c8615d04450a5f238e8aeecc9ab3de2b095cbe4314ae8f6408"
SRC_URI[md5sum] = "43ca2b86d3617ead29bd1c4f1c8d496d"
SRC_URI[sha256sum] = "dfe0e512714d3b42c1d1e0f5b1389c8b77d7abfcea0f87a701753bbe2f917bbc"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment