Skip to content
Snippets Groups Projects
Commit 1d7e90b0 authored by KristofRobot's avatar KristofRobot
Browse files

Merge pull request #330 from bulwahn/indigo-updates

Updating to ROS Indigo Distribution
parents 20d4c5f0 0a2747ae
No related branches found
No related tags found
No related merge requests found
Showing
with 64 additions and 56 deletions
......@@ -7,7 +7,7 @@ Currently, this layer is still under continuous development.
* Source Code Repository: https://github.com/bmwcarit/meta-ros.git
* Issue Tracker: https://github.com/bmwcarit/meta-ros/issues
* Mailing List: https://groups.google.com/forum/#!forum/meta-ros
* Installation Guide: http://wiki.ros.org/hydro/Installation/OpenEmbedded
* Installation Guide: http://wiki.ros.org/indigo/Installation/OpenEmbedded
* Development Guides:
* https://github.com/bmwcarit/meta-ros/wiki/Guidelines-for-ROS-recipes
* https://github.com/bmwcarit/meta-ros/wiki/Developer-Guidelines
......@@ -153,13 +153,13 @@ Currently, this layer is still under continuous development.
to the /etc/hosts file, and set up the environment with
export ROS_ROOT=/opt/ros/hydro
export PATH=$PATH:/opt/ros/hydro/bin
export LD_LIBRARY_PATH=/opt/ros/hydro/lib
export PYTHONPATH=/opt/ros/hydro/lib/python2.7/site-packages
export ROS_ROOT=/opt/ros/indigo
export PATH=$PATH:/opt/ros/indigo/bin
export LD_LIBRARY_PATH=/opt/ros/indigo/lib
export PYTHONPATH=/opt/ros/indigo/lib/python2.7/site-packages
export ROS_MASTER_URI=http://localhost:11311
export CMAKE_PREFIX_PATH=/opt/ros/hydro
touch /opt/ros/hydro/.catkin
export CMAKE_PREFIX_PATH=/opt/ros/indigo
touch /opt/ros/indigo/.catkin
Finally, you can start roscore with
......
......@@ -10,4 +10,4 @@ BBFILE_PRIORITY_ros-layer = "7"
LICENSE_PATH += "${LAYERDIR}/licenses"
ROSDISTRO := "hydro"
ROSDISTRO := "indigo"
DESCRIPTION = "A high-level cross-protocol url-grabber"
SECTION = "devel/python"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=68ad62c64cc6c620126241fd429e68fe"
SRCNAME = "urlgrabber"
DEPENDS = "python-pycurl-native python-pycurl"
SRC_URI = "https://pypi.python.org/packages/source/u/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
SRC_URI[md5sum] = "00c8359bf71062d0946bacea521f80b4"
SRC_URI[sha256sum] = "4437076c8708e5754ea04540e46c7f4f233734ee3590bb8a96389264fb0650d0"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
......@@ -5,11 +5,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
DEPENDS = "cppunit boost"
SRC_URI = "https://github.com/ros-gbp/${PN}-release/archive/release/hydro/${PN}/${PV}.tar.gz"
SRC_URI[md5sum] = "0ef8a8dd76d7ecc78cd8f9aab80ba5a5"
SRC_URI[sha256sum] = "ecc97e979e47eefeade93c6e3905420b3e780ea434247cd2171a5f4d731352f9"
SRC_URI = "https://github.com/ros-gbp/${PN}-release/archive/release/indigo/${PN}/${PV}.tar.gz"
SRC_URI[md5sum] = "8140555e28ddea22a10a9ec59d96a4a0"
SRC_URI[sha256sum] = "296bec7f11430dd99a9617333d91c5c94ccf96ef6a4aa242917cc19480169740"
S = "${WORKDIR}/bfl-release-release-hydro-${P}"
S = "${WORKDIR}/bfl-release-release-indigo-${P}"
inherit cmake faulty-solibs
......
From ee8607f48165af73c23b1210179a88ff1d08e5bf Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:00:25 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Backport [Accepted in indigo-devel branch]
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a3652f..16adefe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 2.8.3)
project(actionlib)
-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rosunit std_msgs)
find_package(Boost REQUIRED COMPONENTS thread)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -34,5 +34,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
FILES_MATCHING PATTERN "*.h")
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_subdirectory(test)
endif()
--
1.8.3.2
......@@ -7,9 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
DEPENDS = "actionlib-msgs roscpp"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
SRC_URI[md5sum] = "d7b1b2b5cac0e1177171a56cc1e7187a"
SRC_URI[sha256sum] = "69f12ecb01b33a992d343c6fb306d678ea61bffda796e0648cd72085793ded32"
inherit catkin
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation geometry-msgs std-msgs"
SRC_URI = "https://github.com/sniekum/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "c82bf63ab8ab5630fedc29e872138fc9"
SRC_URI[sha256sum] = "27e4ebed675c79b41a545614f5a95798c1740e487b65fc45ac356c7298330a80"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
DESCRIPTION = "This package is a ROS wrapper for Alvar, an open source AR tag tracking library."
SECTION = "devel"
LICENSE = "BSD"
LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=f62de161dc7a8f859a0502707b17209e"
DEPENDS = "cmake-modules cv-bridge image-transport libtinyxml pcl-ros resource-retriever roscpp tf visualization-msgs"
DEPENDS = "ar-track-alvar-msgs cmake-modules cv-bridge image-transport libtinyxml pcl-ros resource-retriever roscpp tf visualization-msgs"
SRC_URI = "git://github.com/sniekum/${ROS_SPN}.git;protocol=https;branch=hydro-devel"
# commit df56a7429 is intended to be version 0.4.2
SRCREV = "df56a742976712a1de7212039de8056c93b39375"
SRC_URI = "https://github.com/sniekum/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "5d55aaf9098c1b803f9ed93e3c5fbacd"
SRC_URI[sha256sum] = "b8c1c28afaf16c03f37067ae2653f5df7d0a15fdb75a27c0a2f4da9c2f89d92e"
S = "${WORKDIR}/git"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
......@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "a0dd74c4a665a56b02af9f8c873c451d"
SRC_URI[sha256sum] = "71441206945e8d77dace831375effde5b5f54b95e3a054106848432eceec58c0"
SRC_URI[md5sum] = "e6d1090589026746c94d8fae78015167"
SRC_URI[sha256sum] = "0ca265803be8a2c1b6036d67ed63505551f4bbc02fa6cb8180dc3167b9f3afc9"
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch\
file://0002-PKG_CONFIG_LIB_PATHS-use-cmake-root-path.patch"
......
......@@ -8,11 +8,11 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "console-bridge libpoco"
DEPENDS = "cmake-modules console-bridge libpoco"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "cb3a369025092087d5c47dbfbb8e9439"
SRC_URI[sha256sum] = "84fc8e32648fb8c76a58d4e116884b9c6f28470c60d9508d4aeb18d407f42940"
SRC_URI[md5sum] = "6919e079a0be77e9a3199ac97fa2751e"
SRC_URI[sha256sum] = "f48bad942d7feda76925bb8529c97f8ca8ffb8d45a04de3232650b4d4acaa821"
S = "${WORKDIR}/${ROS_SP}"
......
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1ed0d70623bd8c744ab366e12ec21d43"
SRC_URI[sha256sum] = "a13245a1de4c9cb87b88b99938279181d324cf885026008d36fa70e7bc231227"
SRC_URI[md5sum] = "755ed777cf76844952a4cb896a1b5b05"
SRC_URI[sha256sum] = "b0f5a18f09ae6ccbb7cdaed9bebcbdde4dcfa09792c79f81a9afeb9be342b2c9"
DEPENDS += "cpp-common roscpp-serialization message-generation message-runtime std-msgs"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment