Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
0482cca1
Commit
0482cca1
authored
11 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
actionlib: replacing patch by patch provided upstream
parent
0738b901
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/actionlib/actionlib/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
+32
-0
32 additions, 0 deletions
...ake-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
recipes-ros/actionlib/actionlib_1.10.3.bb
+1
-1
1 addition, 1 deletion
recipes-ros/actionlib/actionlib_1.10.3.bb
with
33 additions
and
1 deletion
recipes-ros/actionlib/actionlib/0001-rostest-i
s-optional
.patch
→
recipes-ros/actionlib/actionlib/0001-
make-
rostest-i
n-CMakeLists-optional-ros-rosdistro-30
.patch
+
32
−
0
View file @
0482cca1
From
9a6b0ed481e8585d5a042f69c8cdaf39b783fc9a
Mon Sep 17 00:00:00 2001
From
ee8607f48165af73c23b1210179a88ff1d08e5bf
Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date:
Sat, 21 Sep
201
3
1
5:41:34
+0
2
00
Subject: [PATCH] rostest i
s optional
Date:
Tue, 4 Feb
201
4
1
6:00:25
+0
1
00
Subject: [PATCH]
make
rostest i
n CMakeLists optional (ros/rosdistro#3010)
---
CMakeLists.txt |
6 +++
++-
1 file changed,
5
insertions(+), 1 deletion(-)
CMakeLists.txt |
3
++-
1 file changed,
2
insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a3652f..
ab0226c
100644
index 9a3652f..
16adefe
100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,
11
@@
@@ -1,7 +1,
7
@@
cmake_minimum_required(VERSION 2.8.3)
project(actionlib)
-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
+else()
+ find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp std_msgs)
+endif()
+find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rosunit std_msgs)
find_package(Boost REQUIRED COMPONENTS thread)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -34,5 +34,6 @@
install(DIRECTORY include/${PROJECT_NAME}/
FILES_MATCHING PATTERN "*.h")
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_subdirectory(test)
endif()
--
1.
7.10.4
1.
8.3.2
This diff is collapsed.
Click to expand it.
recipes-ros/actionlib/actionlib_1.10.3.bb
+
1
−
1
View file @
0482cca1
...
...
@@ -10,6 +10,6 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
SRC_URI += "file://0001-rostest-i
s-optional
.patch"
SRC_URI += "file://0001-
make-
rostest-i
n-CMakeLists-optional-ros-rosdistro-30
.patch"
inherit catkin
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment