diff --git a/recipes-ros/actionlib/actionlib/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch b/recipes-ros/actionlib/actionlib/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
new file mode 100644
index 0000000000000000000000000000000000000000..2d7346e33dfb4bfe5519f99f3592406018009350
--- /dev/null
+++ b/recipes-ros/actionlib/actionlib/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
@@ -0,0 +1,32 @@
+From ee8607f48165af73c23b1210179a88ff1d08e5bf Mon Sep 17 00:00:00 2001
+From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Tue, 4 Feb 2014 16:00:25 +0100
+Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
+
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9a3652f..16adefe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 2.8.3)
+ project(actionlib)
+ 
+-find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
++find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rosunit std_msgs)
+ find_package(Boost REQUIRED COMPONENTS thread)
+ 
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+@@ -34,5 +34,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
+   FILES_MATCHING PATTERN "*.h")
+ 
+ if(CATKIN_ENABLE_TESTING)
++  find_package(rostest)
+   add_subdirectory(test)
+ endif()
+-- 
+1.8.3.2
+
diff --git a/recipes-ros/actionlib/actionlib/0001-rostest-is-optional.patch b/recipes-ros/actionlib/actionlib/0001-rostest-is-optional.patch
deleted file mode 100644
index 39db81974f520441841f5c0688474d457eeda4af..0000000000000000000000000000000000000000
--- a/recipes-ros/actionlib/actionlib/0001-rostest-is-optional.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 9a6b0ed481e8585d5a042f69c8cdaf39b783fc9a Mon Sep 17 00:00:00 2001
-From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Sat, 21 Sep 2013 15:41:34 +0200
-Subject: [PATCH] rostest is optional
-
----
- CMakeLists.txt |    6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9a3652f..ab0226c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,7 +1,11 @@
- cmake_minimum_required(VERSION 2.8.3)
- project(actionlib)
- 
--find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
-+if(CATKIN_ENABLE_TESTING)
-+  find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp rostest rosunit std_msgs)
-+else()
-+  find_package(catkin REQUIRED COMPONENTS actionlib_msgs message_generation roscpp std_msgs)
-+endif()
- find_package(Boost REQUIRED COMPONENTS thread)
- 
- include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
--- 
-1.7.10.4
-
diff --git a/recipes-ros/actionlib/actionlib_1.10.3.bb b/recipes-ros/actionlib/actionlib_1.10.3.bb
index 9b90610a3519c8f4aed77009b1a2bd6ad91e47d8..04e7c24153f111c58699386e666e67ce0d5d26b0 100644
--- a/recipes-ros/actionlib/actionlib_1.10.3.bb
+++ b/recipes-ros/actionlib/actionlib_1.10.3.bb
@@ -10,6 +10,6 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
 SRC_URI[md5sum] = "2e13067c3c85e81a3ab4b603ff15e45b"
 SRC_URI[sha256sum] = "f71df286552e6bf3a03ef83635342d3bdd6eef836e7b0565dccd2d341dbeaa11"
 
-SRC_URI += "file://0001-rostest-is-optional.patch"
+SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
 
 inherit catkin