Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
0738b901
Commit
0738b901
authored
11 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
ros-comm: replacing patch by patch provided upstream
parent
97c43ed5
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/ros-comm/files/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
+88
-0
88 additions, 0 deletions
...ake-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
recipes-ros/ros-comm/ros-comm.inc
+1
-1
1 addition, 1 deletion
recipes-ros/ros-comm/ros-comm.inc
with
89 additions
and
1 deletion
recipes-ros/ros-comm/files/0001-rostest-i
s-optional
.patch
→
recipes-ros/ros-comm/files/0001-
make-
rostest-i
n-CMakeLists-optional-ros-rosdistro-30
.patch
+
88
−
0
View file @
0738b901
From
0f16232f1bac7d03cce598bd305bcdd4c456f4ed
Mon Sep 17 00:00:00 2001
From
560ce8a8855a43565d1798af19cc943c61a72e7f
Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date:
Sat, 21 Sep
201
3
1
5:20:11
+0
2
00
Subject: [PATCH] rostest i
s optional
Date:
Tue, 4 Feb
201
4
1
2:57:23
+0
1
00
Subject: [PATCH]
make
rostest i
n CMakeLists optional (ros/rosdistro#3010)
---
tools/rosnode/CMakeLists.txt | 6 +++++-
tools/rostopic/CMakeLists.txt | 6 +++++-
utilities/roswtf/CMakeLists.txt | 6 +++++-
3 files changed, 15 insertions(+), 3 deletions(-)
tools/rosnode/CMakeLists.txt | 3 ++-
tools/rostopic/CMakeLists.txt | 3 ++-
tools/topic_tools/CMakeLists.txt | 3 ++-
utilities/roswtf/CMakeLists.txt | 3 ++-
4 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
index a7347b4..
b397106
100644
index a7347b4..
f305890
100644
--- a/tools/rosnode/CMakeLists.txt
+++ b/tools/rosnode/CMakeLists.txt
@@ -1,
6
+1,1
0
@@
@@ -1,
10
+1,1
1
@@
cmake_minimum_required(VERSION 2.8.3)
project(rosnode)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rosnode.test)
endif()
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
index 0551583..
24fbed0
100644
index 0551583..
db7917b
100644
--- a/tools/rostopic/CMakeLists.txt
+++ b/tools/rostopic/CMakeLists.txt
@@ -1,6 +1,
10
@@
@@ -1,6 +1,
6
@@
cmake_minimum_required(VERSION 2.8.3)
project(rostopic)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
@@ -9,5 +9,6 @@
install(PROGRAMS scripts/rostopic
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rostopic.test)
endif()
diff --git a/tools/topic_tools/CMakeLists.txt b/tools/topic_tools/CMakeLists.txt
index e441b9a..2d52451 100644
--- a/tools/topic_tools/CMakeLists.txt
+++ b/tools/topic_tools/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.3)
project(topic_tools)
-find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostest rostime rosunit std_msgs xmlrpcpp)
+find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostime std_msgs xmlrpcpp)
include_directories(include)
include_directories(${catkin_INCLUDE_DIRS})
@@ -62,6 +62,7 @@
install(PROGRAMS
#Testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest rosunit)
catkin_add_gtest(${PROJECT_NAME}-utest test/utest.cpp)
if(TARGET ${PROJECT_NAME}-utest)
target_link_libraries(${PROJECT_NAME}-utest topic_tools)
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
index dccb342..
cfd0c11
100644
index dccb342..
97a34ff
100644
--- a/utilities/roswtf/CMakeLists.txt
+++ b/utilities/roswtf/CMakeLists.txt
@@ -1,
6
+1,1
0
@@
@@ -1,
10
+1,1
1
@@
cmake_minimum_required(VERSION 2.8.3)
project(roswtf)
-find_package(catkin REQUIRED COMPONENTS rostest)
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED COMPONENTS rostest)
+else()
+ find_package(catkin REQUIRED)
+endif()
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/roswtf.test)
catkin_add_nosetests(test)
endif()
--
1.
7.10.4
1.
8.3.2
This diff is collapsed.
Click to expand it.
recipes-ros/ros-comm/ros-comm.inc
+
1
−
1
View file @
0738b901
...
...
@@ -2,7 +2,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
SRC_URI
[
md5sum
]
=
"f561ebda19fa6e737d5f06e49e925be4"
SRC_URI
[
sha256sum
]
=
"3572418e3149b54493770695e5241584f5daf9e849ab70007b16d4ce848d7e12"
SRC_URI
+=
"file://0001-rostest-i
s-optional
.patch;patchdir=../.."
SRC_URI
+=
"file://0001-
make-
rostest-i
n-CMakeLists-optional-ros-rosdistro-30
.patch;patchdir=../.."
ROS_PKG_SUBDIR
?=
""
S
=
"${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment