Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
93b03b62
Commit
93b03b62
authored
12 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
experimenting to install the correct easy_install.pth automagically
parent
56116c32
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
meta/recipes-core/images/core-image-bmw.bb
+2
-8
2 additions, 8 deletions
meta/recipes-core/images/core-image-bmw.bb
meta/recipes-devtools/python/python-rospkg_1.0.15.bb
+18
-0
18 additions, 0 deletions
meta/recipes-devtools/python/python-rospkg_1.0.15.bb
with
20 additions
and
8 deletions
meta/recipes-core/images/core-image-bmw.bb
+
2
−
8
View file @
93b03b62
...
...
@@ -17,17 +17,11 @@ augment_hosts_setting_file () {
# installs the easy_install_pth_file that we need
create_python_easy_install_pth_file () {
cat > ${IMAGE_ROOTFS}/usr/lib/python2.7/site-packages/easy-install.pth << EOF
import sys; sys.__plen = len(sys.path)
./setuptools-0.6c11-py2.7.egg
./rospkg-1.0.15-py2.7.egg
import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:]; p=getattr(sys,'__egginsert',0); sys.path[p:p]=new; sys.__egginsert = p+len(new)
EOF
:
}
# remove not needed ipkg informations
# create a custom hosts file
ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; create_python_easy_install_pth_file ; "
IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev
ros
"
IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev"
This diff is collapsed.
Click to expand it.
meta/recipes-devtools/python/python-rospkg_1.0.15.bb
+
18
−
0
View file @
93b03b62
...
...
@@ -11,3 +11,21 @@ SRC_URI[sha256sum] = "f8be5a9d74f7e656d38b2c3b44b7e367fce4001d613ca3fbfcbb87c493
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
# Must inherit package first before changing PACKAGEFUNCS
inherit package
PACKAGEFUNCS += "add_easyinstall_pth"
add_easyinstall_pth () {
echo "rospkg add_easyinstall_pth..."
}
pkg_postinst_python-rospkg () {
if test -e ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth; then
echo insert >> ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
else
echo create >> ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
fi
}
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment