Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
56116c32
Commit
56116c32
authored
12 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
using cmake class for ros
parent
15041711
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
meta/recipes-extended/ros/ros.bb
+5
-41
5 additions, 41 deletions
meta/recipes-extended/ros/ros.bb
with
5 additions
and
41 deletions
meta/recipes-extended/ros/ros.bb
+
5
−
41
View file @
56116c32
...
...
@@ -4,7 +4,7 @@ HOMEPAGE = "http://ros.org"
LICENSE = "CLOSED"
# LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
DEPENDS = "python-empy-native python-rospkg-native python-native python-pyyaml-native python-nose-native"
DEPENDS = "python-empy-native python-rospkg-native python-native python-pyyaml-native python-nose-native
eglibc
"
PR = "r0"
...
...
@@ -13,8 +13,10 @@ SRC_URI = "file://ros_server.tar.gz \
S = "${WORKDIR}"
OECMAKE_SOURCEPATH = "${WORKDIR}/ros-underlay"
EXTRA_OECMAKE = "-DSETUPTOOLS_DEB_LAYOUT=OFF"
inherit pythonnative cmake
do_configure_prepend () {
cat > /home/lukas/af_yocto/build/tmp/sysroots/x86_64-linux/usr/lib/python2.7/site-packages/easy-install.pth << EOF
...
...
@@ -25,49 +27,11 @@ import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:]; p=getattr(sys,
EOF
}
DEPENDS += " cmake-native "
# We need to unset CCACHE otherwise cmake gets too confused
CCACHE = ""
# We want the staging and installing functions from autotools
inherit autotools
# Use in-tree builds by default but allow this to be changed
# since some packages do not support them (e.g. llvm 2.5).
OECMAKE_SOURCEPATH ?= "."
# If declaring this, make sure you also set EXTRA_OEMAKE to
# "-C ${OECMAKE_BUILDPATH}". So it will run the right makefiles.
OECMAKE_BUILDPATH ?= ""
# C/C++ Compiler (without cpu arch/tune arguments)
OECMAKE_C_COMPILER ?= "`echo ${CC} | sed 's/^\([^ ]*\).*/\1/'`"
OECMAKE_CXX_COMPILER ?= "`echo ${CXX} | sed 's/^\([^ ]*\).*/\1/'`"
# Compiler flags
OECMAKE_C_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CPPFLAGS}"
OECMAKE_CXX_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CXXFLAGS} -fpermissive"
OECMAKE_C_FLAGS_RELEASE ?= "${SELECTED_OPTIMIZATION} ${CPPFLAGS} -DNDEBUG"
OECMAKE_CXX_FLAGS_RELEASE ?= "${SELECTED_OPTIMIZATION} ${CXXFLAGS} -DNDEBUG"
OECMAKE_C_LINK_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CPPFLAGS} ${LDFLAGS}"
OECMAKE_CXX_LINK_FLAGS ?= "${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} ${CXXFLAGS} ${LDFLAGS}"
OECMAKE_RPATH ?= ""
OECMAKE_PERLNATIVE_DIR ??= ""
OECMAKE_EXTRA_ROOT_PATH ?= ""
do_install () {
do_rosinstall () {
echo "Installing ros"
mkdir -p ./ros-underlay
rosinstall --catkin ./ros-underlay fuerte-ros-base.rosinstall
cd ./ros-underlay
mkdir -p build
cd ./build
cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
}
inherit pythonnative
addtask rosinstall after do_patch before generate_toolchain_file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment