diff --git a/meta/recipes-core/images/core-image-bmw.bb b/meta/recipes-core/images/core-image-bmw.bb
index c85c9eafe82fca1e8bc4bcabaf615ad77d86dade..16532d49a26fe26e81fa6e2fd974f6aef2fd3fd6 100644
--- a/meta/recipes-core/images/core-image-bmw.bb
+++ b/meta/recipes-core/images/core-image-bmw.bb
@@ -17,17 +17,11 @@ augment_hosts_setting_file () {
 
 # installs the easy_install_pth_file that we need
 create_python_easy_install_pth_file () {
-	cat > ${IMAGE_ROOTFS}/usr/lib/python2.7/site-packages/easy-install.pth << EOF
-import sys; sys.__plen = len(sys.path)
-./setuptools-0.6c11-py2.7.egg
-./rospkg-1.0.15-py2.7.egg
-import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:]; p=getattr(sys,'__egginsert',0); sys.path[p:p]=new; sys.__egginsert = p+len(new)
-EOF
-
+	:
 }
 
 # remove not needed ipkg informations
 # create a custom hosts file
 ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; create_python_easy_install_pth_file ; "
 
-IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev ros"
+IMAGE_INSTALL += "boost boost-dev packagegroup-core-ssh-openssh dhcp-client file ldd python-modules python-setuptools python-rospkg python-rosinstall git cmake python-empy python-pyyaml python-nose log4cxx log4cxx-dev libbz2-dev"
diff --git a/meta/recipes-devtools/python/python-rospkg_1.0.15.bb b/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
index 476e1176b71625b7cbe92d19213ce00dea00ae32..aa57f4b5f1e8228d075f662ec4f879d94c288de8 100644
--- a/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
+++ b/meta/recipes-devtools/python/python-rospkg_1.0.15.bb
@@ -11,3 +11,21 @@ SRC_URI[sha256sum] = "f8be5a9d74f7e656d38b2c3b44b7e367fce4001d613ca3fbfcbb87c493
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 inherit distutils
+
+# Must inherit package first before changing PACKAGEFUNCS
+inherit package
+PACKAGEFUNCS += "add_easyinstall_pth"
+
+add_easyinstall_pth () {
+	echo "rospkg add_easyinstall_pth..."
+}
+
+
+pkg_postinst_python-rospkg () {
+	if test -e ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth; then
+            echo insert >> ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
+        else
+            echo create >> ${PYTHON_SITEPACKAGES_DIR}/easy-install.pth
+        fi
+
+}
\ No newline at end of file