Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
b4a902e8
Commit
b4a902e8
authored
11 years ago
by
Kristof Robot
Browse files
Options
Downloads
Patches
Plain Diff
python-orocos-kdl: initial commit (resolves #203)
parent
b3b478c4
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-extended/kdl/python-orocos-kdl/0001-findSIP-fix.patch
+34
-0
34 additions, 0 deletions
...pes-extended/kdl/python-orocos-kdl/0001-findSIP-fix.patch
recipes-extended/kdl/python-orocos-kdl_1.1.102-1.bb
+18
-0
18 additions, 0 deletions
recipes-extended/kdl/python-orocos-kdl_1.1.102-1.bb
with
52 additions
and
0 deletions
recipes-extended/kdl/python-orocos-kdl/0001-findSIP-fix.patch
0 → 100644
+
34
−
0
View file @
b4a902e8
diff --git a/cmake/FindSIP.cmake b/cmake/FindSIP.cmake
index 53e2888..8f94cf5 100644
--- a/cmake/FindSIP.cmake
+++ b/cmake/FindSIP.cmake
@@ -31,17 +31,26 @@
IF(SIP_VERSION)
SET(SIP_FOUND TRUE)
ELSE(SIP_VERSION)
- FIND_FILE(_find_sip_py FindSIP.py PATHS ${CMAKE_MODULE_PATH})
+ FIND_FILE(_find_sip_py FindSIP.py PATHS ${CMAKE_MODULE_PATH} NO_CMAKE_FIND_ROOT_PATH)
EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} ${_find_sip_py} OUTPUT_VARIABLE sip_config)
IF(sip_config)
STRING(REGEX REPLACE "^sip_version:([^\n]+).*$" "\\1" SIP_VERSION ${sip_config})
STRING(REGEX REPLACE ".*\nsip_version_str:([^\n]+).*$" "\\1" SIP_VERSION_STR ${sip_config})
- STRING(REGEX REPLACE ".*\nsip_bin:([^\n]+).*$" "\\1" SIP_EXECUTABLE ${sip_config})
IF(NOT SIP_DEFAULT_SIP_DIR)
STRING(REGEX REPLACE ".*\ndefault_sip_dir:([^\n]+).*$" "\\1" SIP_DEFAULT_SIP_DIR ${sip_config})
ENDIF(NOT SIP_DEFAULT_SIP_DIR)
- STRING(REGEX REPLACE ".*\nsip_inc_dir:([^\n]+).*$" "\\1" SIP_INCLUDE_DIR ${sip_config})
+
+ IF(CMAKE_CROSSCOMPILING)
+ FIND_PROGRAM(SIP_EXECUTABLE sip)
+ STRING(REGEX REPLACE ".*\nsip_inc_dir:([^\n]+).*$" "\\1" SIP_INCLUDE_DIR ${sip_config})
+ LIST(GET CMAKE_FIND_ROOT_PATH 0 SIP_SYSROOT)
+ SET(SIP_INCLUDE_DIR "${SIP_SYSROOT}${SIP_INCLUDE_DIR}")
+ ELSE(CMAKE_CROSSCOMPILING)
+ STRING(REGEX REPLACE ".*\nsip_bin:([^\n]+).*$" "\\1" SIP_EXECUTABLE ${sip_config})
+ STRING(REGEX REPLACE ".*\nsip_inc_dir:([^\n]+).*$" "\\1" SIP_INCLUDE_DIR ${sip_config})
+ ENDIF(CMAKE_CROSSCOMPILING)
+
SET(SIP_FOUND TRUE)
ENDIF(sip_config)
This diff is collapsed.
Click to expand it.
recipes-extended/kdl/python-orocos-kdl_1.1.102-1.bb
0 → 100644
+
18
−
0
View file @
b4a902e8
DESCRIPTION = "This package contains the python bindings PyKDL for the Kinematics and Dynamics Library (KDL), distributed by the Orocos Project."
SECTION = "devel"
LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=46ee8693f40a89a31023e97ae17ecf19"
DEPENDS = "sip-native python-sip orocos-kdl"
require kdl.inc
SRC_URI += "file://0001-findSIP-fix.patch"
inherit pythonnative
FILES_${PN} += "${libdir}/python*/dist-packages/PyKDL.so"
FILES_${PN}-dev += "${datadir}/python_orocos_kdl/*"
FILES_${PN}-dbg += "${libdir}/python*/dist-packages/.debug/*"
RDEPENDS_{PN} = "python-sip"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment