Skip to content
Snippets Groups Projects
Commit aeec518f authored by vmayoral's avatar vmayoral
Browse files

robot-model: recipes added.

robot_model contains packages for modeling various aspects of robot
information, specified in the Xml Robot Description Format (URDF). The core
package of this stack is urdf, which parses URDF files, and constructs an
object model (C++) of the robot.

-----------------------
RECIPES collada-urdf AND kdl-parser
OF THE ROBOT-MODEL PACKAGE HAVE NOT BEEN ADDED YET.
-----------------------
parent 0f0e8148
No related branches found
No related tags found
No related merge requests found
DESCRIPTION = " This package contains a C++ parser for the Collada robot \
description format. The parser reads a Collada XML robot description, and \
creates a C++ URDF model. Although it is possible to directly use this \
parser when working with Collada robot descriptions, the preferred user \
API is found in the urdf package."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "collada-dom roscpp urdfdom-headers urdf-parser-plugin class-loader"
require robot-model.inc
DESCRIPTION = "This package contains a tool for setting and publishing \
joint state values for a given URDF."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rospy wxpython sensor-msgs"
require robot-model.inc
From dcc52b56eaade728f92356dd96f7d4cd2c95057e Mon Sep 17 00:00:00 2001
From: vmayoral <v.mayoralv@gmail.com>
Date: Fri, 9 Aug 2013 17:57:43 +0200
Subject: [PATCH] resource_retriever test/CMakeLists.txt fix
---
resource_retriever/test/CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/resource_retriever/test/CMakeLists.txt b/resource_retriever/test/CMakeLists.txt
index f133bf6..5e0ce18 100644
--- a/resource_retriever/test/CMakeLists.txt
+++ b/resource_retriever/test/CMakeLists.txt
@@ -1,4 +1,6 @@
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR})
-catkin_add_gtest(${PROJECT_NAME}_utest test.cpp)
-target_link_libraries(${PROJECT_NAME}_utest ${PROJECT_NAME})
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(${PROJECT_NAME}_utest test.cpp)
+ target_link_libraries(${PROJECT_NAME}_utest ${PROJECT_NAME})
+endif()
--
1.7.9.5
DESCRIPTION = "This package retrieves data from url-format files such as http://, ftp://, package:// file://, etc., and loads the data into memory. The package:// url for ros packages is translated into a local file:// url. The resourse retriever was initially designed to load mesh files into memory, but it can be used for any type of data. The resource retriever is based on the the libcurl library."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "curl rosconsole roslib"
require robot-model.inc
SRC_URI += "file://0001-resource_retriever-test-CMakeLists.txt-fix.patch;striplevel=2"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "8408e5b990d157d1d30e56cc0a1ec28c"
SRC_URI[sha256sum] = "72374d3c43a2715a743365be186fddd23f016889430b5da1209f5bcaba08d141"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "robot_model"
DESCRIPTION = "This package contains a C++ base class for URDF parsers"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "urdfdom-headers"
require robot-model.inc
From 5a06a8525da6c0721f9a356ac631bc527b591f12 Mon Sep 17 00:00:00 2001
From: vmayoral <v.mayoralv@gmail.com>
Date: Fri, 9 Aug 2013 17:46:44 +0200
Subject: [PATCH] urdf CMakeLists fix
---
urdf/CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/urdf/CMakeLists.txt b/urdf/CMakeLists.txt
index 0afcb03..3448c05 100644
--- a/urdf/CMakeLists.txt
+++ b/urdf/CMakeLists.txt
@@ -29,8 +29,10 @@ if(APPLE)
set_target_properties(${PROJECT_NAME} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
endif(APPLE)
-catkin_add_gtest(test_parser EXCLUDE_FROM_ALL test/test_robot_model_parser.cpp)
-target_link_libraries(test_parser ${PROJECT_NAME})
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(test_parser EXCLUDE_FROM_ALL test/test_robot_model_parser.cpp)
+ target_link_libraries(test_parser ${PROJECT_NAME})
+endif()
# no idea how CATKIN does this
# rosbuild_add_rostest(${PROJECT_SOURCE_DIR}/test/test_robot_model_parser.launch)
--
1.7.9.5
DESCRIPTION = "This package contains a C++ parser for the Unified Robot Description Format (URDF), which is an XML format for representing a robot model. The code API of the parser has been through our review process and will remain backwards compatible in future releases."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rosconsole-bridge roscpp urdfdom-headers urdf-parser-plugin pluginlib urdfdom cmake-modules libtinyxml"
require robot-model.inc
SRC_URI += "file://0001-urdf-CMakeLists-fix.patch;striplevel=2"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment