Skip to content
Snippets Groups Projects
Commit 0f3a0283 authored by vmayoral's avatar vmayoral
Browse files

control-toolbox: recipe added.

The control toolbox contains modules that are useful
across all controllers.
parent aeb9ac25
No related branches found
No related tags found
No related merge requests found
From 9de24db0b59a56dcb2ce0dc224a49315a6ada4c8 Mon Sep 17 00:00:00 2001
From: vmayoral <v.mayoralv@gmail.com>
Date: Thu, 8 Aug 2013 17:03:16 +0200
Subject: [PATCH] crosscompile CATKIN_ENABLE_TESTING fix
---
CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90f44e1..405c905 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,8 +87,10 @@ else()
add_dependencies(${PROJECT_NAME} ${PROJECT_NAME}_gencpp) # wait for msgs
# Tests
- catkin_add_gtest(pid_tests test/pid_tests.cpp)
- target_link_libraries(pid_tests ${catkin_LIBRARIES} ${PROJECT_NAME})
+ if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(pid_tests test/pid_tests.cpp)
+ target_link_libraries(pid_tests ${catkin_LIBRARIES} ${PROJECT_NAME})
+ endif()
# add_executable(test_linear test/linear.cpp)
--
1.7.9.5
DESCRIPTION = "The control toolbox contains modules that are useful \
across all controllers."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rosconsole tf roscpp angles message-generation \
dynamic-reconfigure libtinyxml realtime-tools message-filters"
SRC_URI = "https://github.com/ros-controls/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "73ceaadbbcf2b8aa11aaaea7512bfeed"
SRC_URI[sha256sum] = "cbdb189d12f0907e846f774d81e234ce61492ee9df386dde98948ef29c8e1974"
SRC_URI += "file://0001-crosscompile-CATKIN_ENABLE_TESTING-fix.patch;striplevel=1;name=patch"
SRC_URI[patch.md5sum] = "d6dcf1b9cd992658ebdd33f162540faa"
SRC_URI[patch.sha256sum] = "90f388cac2832ff3fdb1bd162eadf01deb8ca062636d22c8507d8d43066827d6"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment