Skip to content
Snippets Groups Projects
Commit 0d816939 authored by herbrechtsmeier's avatar herbrechtsmeier
Browse files

Merge pull request #191 from bulwahn/collada-urdf

recipes for collada-urdf
parents 86bc7904 97dfb6f7
No related branches found
No related tags found
No related merge requests found
From 597828ebc85f552fd38537664cbe72c1c775049b Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 05:41:53 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
CMakeLists.txt | 6 ++++--
package.xml | 2 +-
2 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b41961..821f929 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,8 +64,10 @@ add_library(${PROJECT_NAME}
target_link_libraries(${PROJECT_NAME} ${ASSIMP_LIBRARIES} ${QHULL_LIBRARIES} ${catkin_LIBRARIES} ${Boost_LIBRARIES})
-# Unit tests
-add_subdirectory(test)
+if(CATKIN_ENABLE_TESTING)
+ # Unit tests
+ add_subdirectory(test)
+endif()
install(TARGETS ${PROJECT_NAME}
ARCHIVE DESTINATION lib
diff --git a/package.xml b/package.xml
index 4001019..4dbd6d1 100644
--- a/package.xml
+++ b/package.xml
@@ -8,7 +8,7 @@
<license>BSD</license>
<url>http://ros.org/wiki/geometric_shapes</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>boost</build_depend>
<build_depend>shape_msgs</build_depend>
--
1.8.1.2
DESCRIPTION = "This package contains generic definitions of geometric shapes and bodies."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=5ee5b8b046ae48ad94a2037ca953a67b"
DEPENDS = "boost shape-msgs shape-tools octomap assimp libeigen qhull console-bridge random-numbers eigen-stl-containers resource-retriever"
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "7b7b803890baf1a5f27264a2906e3d9c"
SRC_URI[sha256sum] = "a26443007e39c7c6355c83d703df04969e8b60b7e44d851f44df026e168243c7"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=1"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
SRC_URI = "https://github.com/OctoMap/${ROS_SPN}/archive/v${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "b4ea2f354e286c48263543dac42cf555"
SRC_URI[sha256sum] = "c68b75913ea5ebeb5459eaf2114801477aeaa2a584b018b8816f8a510150e76e"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit cmake ros
ROS_SPN = "octomap"
DESCRIPTION = "The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9b0e1f01a68f441eeaf7b5e18812d3c8"
require octomap.inc
DESCRIPTION = "This package contains a tool to convert Unified Robot Description Format (URDF) documents into COLLAborative Design Activity (COLLADA) documents."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "angles assimp resource-retriever collada-dom collada-parser roscpp urdf geometric-shapes"
require robot-model.inc
do_configure_append() {
for f in collada_urdf.dir urdf_to_collada.dir
do
sed -i -e 's: /usr/lib/liboctomap.so: ${STAGING_LIBDIR}/liboctomap.so:g' \
-e 's: /usr/lib/liboctomath.so: ${STAGING_LIBDIR}/liboctomath.so:g' \
${S}/build/CMakeFiles/$f/build.make
done
}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment