Skip to content
Snippets Groups Projects
Commit fef582cf authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

ros-tutorials: updating to 0.3.13

The ros-tutorials recipes were updated to 0.3.13 to be in line with
https://github.com/ros/rosdistro/blob/4551e7c32d1b34984410b79bc0ec36afe3d3d245/hydro/release.yaml.
The previously applied patch has been included in 0.3.13 and is
removed from the recipe and this repository.
parent bd5265bb
No related branches found
No related tags found
No related merge requests found
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "e1763e2ccc91976ac98b07d3f423478d"
SRC_URI[sha256sum] = "827622a42eb14119c3303665c91635fd4c1eb401e1585a9f1fde819f7651bdbf"
SRC_URI[md5sum] = "482f5caa0af3cd843a5a187c4fc88729"
SRC_URI[sha256sum] = "449ab91f02ce63ac8f3c3c809f6c18a044e8a549d396a0a64b3f592e33b8622f"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
From 1e559b3f811a6cf3daac59088d6d86ca1d31b261 Mon Sep 17 00:00:00 2001
From: Dirk Thomas <dthomas@osrfoundation.org>
Date: Wed, 3 Jul 2013 11:22:45 -0700
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
rospy_tutorials/CMakeLists.txt | 24 +++++++++++++-----------
rospy_tutorials/package.xml | 2 +-
2 files changed, 14 insertions(+), 12 deletions(-)
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
index bcd4ddd..b588dfc 100644
--- a/rospy_tutorials/CMakeLists.txt
+++ b/rospy_tutorials/CMakeLists.txt
@@ -10,17 +10,6 @@ generate_messages(DEPENDENCIES std_msgs)
catkin_package(CATKIN_DEPENDS message_runtime std_msgs)
-foreach(T
- test/test-add-two-ints.launch
- test/test-peer-subscribe-notify.launch
- test/test-add-two-ints-with-roscpp-server.launch
- test/test-talker-listener.launch
- test/test-talker-listener-with-roscpp.launch
- test/test-on-shutdown.launch
- test/test-connection-header.launch)
- add_rostest(${T})
-endforeach()
-
# do not wildcard install files since the root folder of the package will contain a debian folder for releasing
foreach(T
001_talker_listener
@@ -36,3 +25,16 @@ foreach(T
DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION}
USE_SOURCE_PERMISSIONS)
endforeach()
+
+if(CATKIN_ENABLE_TESTING)
+ foreach(T
+ test/test-add-two-ints.launch
+ test/test-peer-subscribe-notify.launch
+ test/test-add-two-ints-with-roscpp-server.launch
+ test/test-talker-listener.launch
+ test/test-talker-listener-with-roscpp.launch
+ test/test-on-shutdown.launch
+ test/test-connection-header.launch)
+ add_rostest(${T})
+ endforeach()
+endif()
diff --git a/rospy_tutorials/package.xml b/rospy_tutorials/package.xml
index 1be85c0..f7517e8 100644
--- a/rospy_tutorials/package.xml
+++ b/rospy_tutorials/package.xml
@@ -14,7 +14,7 @@
<url type="repository">https://github.com/ros/ros_tutorials</url>
<author>Ken Conley</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>message_generation</build_depend>
<build_depend>rostest</build_depend>
--
1.8.1.6
......@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
DEPENDS = "message-generation rostest std-msgs cpp-common roscpp-serialization"
require ros-tutorials.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment