Skip to content
Snippets Groups Projects
Commit f6ba8312 authored by KristofRobot's avatar KristofRobot
Browse files

Merge pull request #287 from bulwahn/master-next

updates and minor tuning at the end of July 2014
parents 2cd802c5 0569363c
No related branches found
No related tags found
No related merge requests found
Showing
with 52 additions and 58 deletions
......@@ -4,7 +4,7 @@ COLLADA XML instance document."
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://License_Folder/license_e.txt;md5=33ea5b7341abf67bd9055a229646feae"
DEPENDS = "boost libxml2"
DEPENDS = "boost libxml2 libpcre"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tgz"
SRC_URI[md5sum] = "20399de4206eab850c32e65c04e907cb"
......
......@@ -22,7 +22,7 @@ SRC_URI[kallpc16k.sha256sum] = "7a357c34086fbba8b813f9750f6b5ba13e2a00478a0a2e78
S = "${WORKDIR}/${PN}"
inherit autotools
inherit autotools-brokensep
#disable parallel make (make -j), as festival cannot handle that
PARALLEL_MAKE = ""
......@@ -55,7 +55,7 @@ do_install() {
install -m 0755 ${S}/bin/text2wave ${D}${bindir}
install -m 0755 -d ${D}${libdir}
install -m 0644 ${S}/lib/etc/unknown_DebianGNULinux/audsp ${D}${libdir}
install -m 0644 ${S}/lib/etc/unknown_*/audsp ${D}${libdir}
install -m 0755 -d ${D}${datadir}/festival
install -m 0644 ${S}/lib/*scm ${D}${datadir}/festival
......
SRC_URI = "https://github.com/orocos/${SPN}/archive/v${PV}.tar.gz;downloadfilename=${SPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "710b6ab202cc062d1ad08afde9c9b21a"
SRC_URI[sha256sum] = "b35c3264ccbbde5b5dbb562cbca6cab5b69f30ebfb8d347314d844e084d037ef"
SRC_URI[md5sum] = "dc927de422cf6afe716ec7b12c0eed11"
SRC_URI[sha256sum] = "7be2dd5e4f4c1ceac2cdf1f4fae3d94d4ffd9fc1af8d483c05f04e80ef84b3f9"
S = "${WORKDIR}/${SPN}-${PV}/${@d.getVar('BPN', True).replace('-', '_')}"
......
From ee7e02737b599d90f628252202e5a9969d050f5e Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 1 Mar 2014 16:32:32 +0100
Subject: [PATCH] correct path for CONFIGURE_FILE in CMakeLists.txt
If CMAKE_MODULE_PATH is empty before appending
'${CMAKE_CURRENT_SOURCE_DIR}/cmake' to it (CMakeLists.txt:27),
CONFIGURE_FILE (CMakeLists.txt:182) works as intended.
However, when CMAKE_MODULE_PATH is not empty, e.g., because of
further tool-chain settings, CONFIGURE_FILE fails with:
CMake Error: File <SOME-OTHER-PATH>;<POCO-SRC-PATH>/cmake/cmake_uninstall.cmake.in does not exist.
| CMake Error at CMakeLists.txt:182 (CONFIGURE_FILE):
| configure_file Problem configuring file
This commit addresses this problem by only using
'${CMAKE_CURRENT_SOURCE_DIR}/cmake' in CONFIGURE_FILE.
The problem was discovered in the meta-ros layer project
(http://github.com/bmwcarit/meta-ros) when creating a libpoco
bitbake recipe, which uses poco's cmake installation scripts.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d02f13..1c9f523 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,7 +180,7 @@ endif(APRUTIL_FOUND AND APACHE_FOUND)
#############################################################
# Uninstall stuff see: http://www.vtk.org/Wiki/CMake_FAQ
CONFIGURE_FILE(
- "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
IMMEDIATE @ONLY)
--
1.8.3.1
DESCRIPTION = "POCO C++ Libraries"
HOMEPAGE = "http://pocoproject.org"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc"
DEPENDS = "expat zlib libpcre openssl"
SRC_URI = "https://github.com/pocoproject/poco/archive/poco-${PV}-release.tar.gz"
SRC_URI[md5sum] = "4ed751311fe4eb437a485139fcfdf558"
SRC_URI[sha256sum] = "315f0947b3494172cb2833d7c978fc24f16f6f10dd1a5299e83b81fee7b62f27"
SRC_URI += "file://0001-correct-path-for-CONFIGURE_FILE-in-CMakeLists.txt.patch"
SRC_URI[md5sum] = "4636d84055a434fde3a67396bf15924a"
SRC_URI[sha256sum] = "f26bbd7879ad79b45630f8efa20b1c65f0ddf81dc44f169245d512d208c71e53"
S = "${WORKDIR}/poco-poco-${PV}-release"
......
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "26b6b9f852b0e20017c51fc98e229282"
SRC_URI[sha256sum] = "a41c52b337d1117bdcaa60a8a092629f07da9135c8df42954eb2e225a4ad307a"
SRC_URI[md5sum] = "7610358ec0e87b37321e0391e351f487"
SRC_URI[sha256sum] = "bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
......@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9de
DEPENDS = "rospy sensor-msgs"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${ROS_SP}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "9d1ead73e678fa2f51a70a933b0bf017"
SRC_URI[sha256sum] = "0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5"
SRC_URI[md5sum] = "eb12065f8e6b9d06a489f89f19dcc41e"
SRC_URI[sha256sum] = "d1ae6229c9a55e8d6fa89b5d051b86605fca0b02ff2e344c76c44d7642eb88c6"
S = "${WORKDIR}/${ROS_SPN}-${ROS_SP}"
......
......@@ -4,6 +4,6 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=26;endline=26;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf tf-conversions eigen-conversions"
DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf tf-conversions eigen-conversions nodelet"
require image-pipeline.inc
From a4404ea5ee0f4fb192c5765ee4dce6a265a70ec9 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 27 Jul 2014 09:58:36 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted
---
CMakeLists.txt | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ad9dbc..7309f3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,8 +10,7 @@ tf sensor_msgs message_filters roscpp laser_geometry filters)
find_package(catkin REQUIRED COMPONENTS
${THIS_PACKAGE_ROS_DEPS}
- message_generation
- rostest)
+ message_generation)
find_package(Boost REQUIRED COMPONENTS system signals)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -68,6 +67,8 @@ add_dependencies(point_cloud2_assembler ${PROJECT_NAME}_gencpp)
## unit testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
add_executable(periodic_snapshotter examples/periodic_snapshotter.cpp)
target_link_libraries(periodic_snapshotter ${catkin_LIBRARIES} ${Boost_LIBRARIES})
add_dependencies(periodic_snapshotter ${PROJECT_NAME}_gencpp)
--
1.9.1
......@@ -3,12 +3,14 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation sensor-msgs message-filters tf roscpp rostest filters laser-geometry pluginlib"
DEPENDS = "message-generation sensor-msgs message-filters tf roscpp filters laser-geometry pluginlib"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1e0fe2d0b5fb26eca1e9137d64767419"
SRC_URI[sha256sum] = "de6637a229d84d6215dc0176ea05bc40c2eb2d8dec8ca520c4a29822f089e74a"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment