Skip to content
Snippets Groups Projects
Commit f69c6192 authored by herbrechtsmeier's avatar herbrechtsmeier
Browse files

Merge pull request #75 from bulwahn/stable

redistribution of eigen and minor tuning
parents 5b9b69f5 0d07506b
No related branches found
No related tags found
No related merge requests found
......@@ -10,6 +10,7 @@ CONTRIBUTORS
Lukas Bulwahn, BMW Car IT GmbH <lukas.bulwahn@oss.bmw-carit.de>
Stefan Herbrechtsmeier, Bielefeld University <stefan@herbrechtsmeier.net>
Tobias Weigl, BMW Car IT GmbH <tobias.weigl@bmw-carit.de>
Kartik Mohta <kartikmohta@gmail.com>
HOW TO CONTRIBUTE
......@@ -92,8 +93,11 @@ REDISTRIBUTIONS
The log4cxx recipe originated from the recipe in the OpenEmbedded (Classic) Development
(cf. http://cgit.openembedded.org/openembedded/tree/recipes/log4cxx)
licensed with the MIT License.
The eigen recipe originated from the recipe in Kartik Mohta's OpenEmbedded layer
(cf. https://github.com/kartikmohta/meta-km/tree/master/recipes-extended/eigen)
licensed with the MIT License.
The core-image-ros-* recipes originated from the core-image-minimal recipe in OpenEmbedded Core
(cf. http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/images/core-image-minimal.bb)
licensed with the MIT License.
The modified files are redistributed here under the same MIT License.
The original or modified files are redistributed here under the same MIT License.
......@@ -31,7 +31,7 @@ FILES_SOLIBSDEV = ""
FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
ROS_BPN = "${@d.getVar('BPN', True).replace('-', '_')}"
ROS_BP = "${BPN}-${PV}"
ROS_BP = "${ROS_BPN}-${PV}"
FILES_${PN} += "\
${prefix}/etc \
......
DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms."
AUTHOR = "Benoît Jacob and Gaël Guennebaud and others"
HOMEPAGE = "http://eigen.tuxfamily.org/"
LICENSE = "MPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad"
PR = "r0"
SRC_URI = "http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2"
inherit cmake
OECMAKE_SOURCEPATH = ".."
OECMAKE_BUILDPATH = "build"
EXTRA_OECMAKE += "-Dpkg_config_libdir=${libdir}"
FILES_${PN} = "${includedir} ${libdir}"
# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
RDEPENDS_${PN}-dev = ""
RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
require eigen.inc
PR = "r0"
SRC_URI += "file://eigen-disable-tests.patch"
SRC_URI[md5sum] = "43eee0e9252a77149d6b65e93e73b79d"
SRC_URI[sha256sum] = "1a443145f321dd47a5ca11f176e7319056198a6124a7577723d92e3c3cd59ece"
S = "${WORKDIR}/eigen-eigen-2249f9c22fe8"
eigen: don't try building tests
While configuring, if the tests are enabled, it checks some machine specific
stuff which we don't want to do while cross-compiling.
Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Kartik Mohta <kartikmohta@gmail.com>
--- a/CMakeLists.txt~ 2012-07-02 20:33:20.330773075 -0400
+++ b/CMakeLists.txt 2012-07-02 20:34:23.515778505 -0400
@@ -307,24 +307,24 @@
add_subdirectory(doc EXCLUDE_FROM_ALL)
-include(EigenConfigureTesting)
+#include(EigenConfigureTesting)
# fixme, not sure this line is still needed:
-enable_testing() # must be called from the root CMakeLists, see man page
+#enable_testing() # must be called from the root CMakeLists, see man page
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
-else()
- add_subdirectory(test EXCLUDE_FROM_ALL)
-endif()
-
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(blas)
- add_subdirectory(lapack)
-else()
- add_subdirectory(blas EXCLUDE_FROM_ALL)
- add_subdirectory(lapack EXCLUDE_FROM_ALL)
-endif()
+#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+# add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+#else()
+# add_subdirectory(test EXCLUDE_FROM_ALL)
+#endif()
+
+#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+# add_subdirectory(blas)
+# add_subdirectory(lapack)
+#else()
+# add_subdirectory(blas EXCLUDE_FROM_ALL)
+# add_subdirectory(lapack EXCLUDE_FROM_ALL)
+#endif()
add_subdirectory(unsupported)
@@ -342,7 +342,7 @@
add_subdirectory(bench/spbench EXCLUDE_FROM_ALL)
endif(NOT WIN32)
-ei_testing_print_summary()
+#ei_testing_print_summary()
message(STATUS "")
message(STATUS "Configured Eigen ${EIGEN_VERSION_NUMBER}")
--- a/unsupported/CMakeLists.txt~ 2012-07-02 20:33:58.775385403 -0400
+++ b/unsupported/CMakeLists.txt 2012-07-02 20:34:06.495509672 -0400
@@ -1,7 +1,7 @@
add_subdirectory(Eigen)
add_subdirectory(doc EXCLUDE_FROM_ALL)
-if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
- add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
-else()
- add_subdirectory(test EXCLUDE_FROM_ALL)
-endif()
+#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET)
+# add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest
+#else()
+# add_subdirectory(test EXCLUDE_FROM_ALL)
+#endif()
......@@ -15,4 +15,4 @@ RDEPENDS_${PN}_class-native = ""
SRC_URI[md5sum] = "de385f1796bf025915ed7b20e1e1acc4"
SRC_URI[sha256sum] = "e510caa7692a4b0a0948688b9d2d8f6ff2f329980d7f78787276afec030806b7"
inherit catkin
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment