Skip to content
Snippets Groups Projects
Commit d63e4fee authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

ar-track-alvar: updating to 0.4.2


With the poky-dizzy distribution, the do_rootfs task for
core-image-ros-world fails with:

  ERROR: Unable to install packages. Command '/[...]/build/tmp/sysroots/x86_64-linux/usr/bin/smart --quiet --data-dir=/[...]/core-image-ros-world/1.0-r0/rootfs/var/lib/smart install -y run-postinsts@all packagegroup-core-boot@beaglebone packagegroup-ros-world@all' returned 1:
  error: Can't install ar-track-alvar-0.4.1-r0@cortexa8hf_vfp_neon: no package provides libmedianFilter.so

Build Configuration: poky 1.7.1;
  poky: "dizzy:ec75238f6cc2d2d8d40e0268f6d2acc070cbe9a4";
  meta-openembedded: "dizzy:9efaed99125b1c4324663d9a1b2d3319c74e7278"

To resolve this problem, this commit updates ar-track-alvar to the
latest Hydro version 0.4.2. Unfortunately, there is no archive file
for version 0.4.2, so the recipe uses the git repository with the
commit intended to mark version 0.4.2 to fetch the source code.
Due to the update, this commit also removes the upstream-accepted
patch file from this repository here.

Signed-off-by: default avatarLukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
parent 312e6c4d
No related branches found
No related tags found
No related merge requests found
From 3f0419f9d890e8c0ffe745bfd1e0290911598645 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 15 May 2014 07:55:45 +0200
Subject: [PATCH] used cmake_modules to find TinyXML
This commit follows the pattern from the ROS core developers to
use cmake_modules to find TinyXML. E.g., This pattern is found in
the pluginlib package, commit 2e0860ca [1], and this commit here
bluntly copies the steps of that commit.
This commit is needed to find tinyxml when cross-compiling
the ar_track_alvar package with the OpenEmbedded/Yocto build
environment and the ROS layer for OpenEmbedded [2].
[1] https://github.com/ros/pluginlib/commit/2e0860ca42138f837b2e34921a207d40a095d996
[2] https://github.com/bmwcarit/meta-ros
Upstream-Status: Accepted
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
CMakeLists.txt | 10 ++++------
package.xml | 1 +
2 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 933f57a..6986a0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,13 +20,12 @@ find_package(catkin COMPONENTS
message_generation
${MSG_DEPS}
dynamic_reconfigure
+ cmake_modules
REQUIRED)
find_package(Eigen REQUIRED)
find_package(OpenCV REQUIRED)
-
-find_package(PkgConfig)
-pkg_check_modules(PC_TINYXML REQUIRED tinyxml)
+find_package(TinyXML REQUIRED)
# generate messages
set(MSG_FILES AlvarMarker.msg AlvarMarkers.msg)
@@ -57,10 +56,9 @@ catkin_package(
)
include_directories(include
- ${PC_TINYXML_INCLUDE_DIRS}
${catkin_INCLUDE_DIRS}
${OpenCV_INCLUDE_DIRS}
- ${PC_TINYXML_INCLUDE_DIRS}
+ ${TinyXML_INCLUDE_DIRS}
)
@@ -97,7 +95,7 @@ add_library(ar_track_alvar
src/MultiMarker.cpp
src/MultiMarkerBundle.cpp
src/MultiMarkerInitializer.cpp)
-target_link_libraries(ar_track_alvar ${OpenCV_LIBS} tinyxml ${catkin_LIBRARIES})
+target_link_libraries(ar_track_alvar ${OpenCV_LIBS} ${TinyXML_LIBRARIES} ${catkin_LIBRARIES})
add_dependencies(ar_track_alvar ${GENCPP_DEPS})
# Kinect filtering code
diff --git a/package.xml b/package.xml
index ed9a560..a18ec5c 100644
--- a/package.xml
+++ b/package.xml
@@ -10,6 +10,7 @@ This package is a ROS wrapper for Alvar, an open source AR tag tracking library.
<buildtool_depend>catkin</buildtool_depend>
+ <build_depend>cmake_modules</build_depend>
<build_depend>cv_bridge</build_depend>
<build_depend>geometry_msgs</build_depend>
<build_depend>image_transport</build_depend>
--
1.8.5.3
......@@ -5,12 +5,10 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=f62de161dc7a8f8
DEPENDS = "cmake-modules cv-bridge image-transport libtinyxml pcl-ros resource-retriever roscpp tf visualization-msgs"
SRC_URI = "https://github.com/sniekum/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "2786829c43437da2aa93eff77a4c862f"
SRC_URI[sha256sum] = "f87759a0a4decbf0da3ff9341e1aa6fcfdcaf302f0844d6ace371c7e5dc9e53e"
SRC_URI = "git://github.com/sniekum/${ROS_SPN}.git;protocol=https;branch=hydro-devel"
# commit df56a7429 is intended to be version 0.4.2
SRCREV = "df56a742976712a1de7212039de8056c93b39375"
SRC_URI += "file://0001-used-cmake_modules-to-find-TinyXML.patch"
S = "${WORKDIR}/${ROS_SP}"
S = "${WORKDIR}/git"
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment