Skip to content
Snippets Groups Projects
Commit bcc28108 authored by herbrechtsmeier's avatar herbrechtsmeier
Browse files

Merge pull request #127 from bulwahn/update-to-hydro

Updating to hydro release version
parents c94e6cb9 e230277b
No related branches found
No related tags found
No related merge requests found
Showing
with 49 additions and 9 deletions
......@@ -7,13 +7,9 @@ SECTION = "devel"
LICENSE = "BSD & BSL-1.0"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=10;md5=bbbb6ab628b1f3daee74dd9c62bee312"
SRC_URI = "https://github.com/ros/${PN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz;name=archive"
SRC_URI[archive.md5sum] = "64682c8e49434c333915fd0906fb4d84"
SRC_URI[archive.sha256sum] = "532d9358a8559effb3fabe57ac97ced8b5a61226251973f08f8901709d9591f7"
SRC_URI += "https://github.com/ros/pluginlib/commit/e71b89e00fbf56813266552b4d75fefe95e048f8.patch;name=patch"
SRC_URI[patch.md5sum] = "b9dcbfd4883edb947112b3a184c7a49b"
SRC_URI[patch.sha256sum] = "19c3d35de402309ed23b252db8493fb8a6d6abb34be6d88cbfd28b0e3e171016"
SRC_URI = "https://github.com/ros/${PN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
SRC_URI[md5sum] = "c506945693bc53e60600a849275e4a98"
SRC_URI[sha256sum] = "a8c5aa266a27810c39a2ced76d531358880c7728a948f7e7a8972b70ed42a425"
DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
......
SRC_URI = "https://github.com/ros/ros_comm/archive/${PV}.tar.gz;downloadfilename=ros_comm-${PV}.tar.gz"
SRC_URI[md5sum] = "80b68959b8e6d5162c50a361a55d9b1a"
SRC_URI[sha256sum] = "b0422f914ca27f928e5acacf25353cb44bd7e3be8ba8942253013fe85cc355f8"
SRC_URI[md5sum] = "2d4b8083abc6598857e01b698f4b0d20"
SRC_URI[sha256sum] = "44c5a076a604134e44d044e08b2c15b185aefac277b8632b5ca2d011ec8d3da6"
inherit catkin
From a392a5e614883c18bf64568b1ebffe95d7efcf15 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 23 Jul 2013 15:18:07 +0200
Subject: [PATCH] roscpp: do not try to find pthread by own methods
This commit partially reverts c5dfa6305e883f76dc2aa52d27d2977e3d66ea2e
in the ros/ros_comm repository.
---
clients/roscpp/CMakeLists.txt | 15 +--------------
1 file changed, 1 insertion(+), 14 deletions(-)
diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
index 4545073..872f3f6 100644
--- a/clients/roscpp/CMakeLists.txt
+++ b/clients/roscpp/CMakeLists.txt
@@ -34,22 +34,9 @@ add_service_files(
generate_messages()
-set(PTHREAD_LIB "")
-find_package(Threads)
-if(CMAKE_THREAD_LIBS_INIT)
- string(LENGTH ${CMAKE_THREAD_LIBS_INIT} _length)
- if(_length GREATER 2)
- string(SUBSTRING ${CMAKE_THREAD_LIBS_INIT} 0 2 _prefix)
- if(${_prefix} STREQUAL "-l")
- math(EXPR _rest_len "${_length} - 2")
- string(SUBSTRING ${CMAKE_THREAD_LIBS_INIT} 2 ${_rest_len} PTHREAD_LIB)
- endif()
- endif()
-endif()
-
catkin_package(
INCLUDE_DIRS include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros
- LIBRARIES roscpp ${PTHREAD_LIB}
+ LIBRARIES roscpp
CATKIN_DEPENDS cpp_common message_runtime rosconsole roscpp_serialization roscpp_traits rosgraph_msgs rostime std_msgs xmlrpcpp
DEPENDS Boost
)
--
1.7.9.5
......@@ -13,6 +13,8 @@ DEPENDS = "\
require ros-comm.inc
SRC_URI += "file://0001-roscpp-do-not-try-to-find-pthread-by-own-methods.patch;striplevel=3"
S = "${WORKDIR}/ros_comm-${PV}/clients/${BPN}"
CXXFLAGS_append = " -I${OECMAKE_BUILDPATH}/devel/include"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment