Skip to content
Snippets Groups Projects
Commit b2a3a257 authored by KristofRobot's avatar KristofRobot Committed by GitHub
Browse files

Merge pull request #427 from bulwahn/indigo-updates

adjusting to recent updates in ROS indigo distribution
parents 0e98c6fa 8d923c7a
No related branches found
No related tags found
No related merge requests found
Showing
with 14 additions and 61 deletions
......@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
DEPENDS = "actionlib-msgs roscpp"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "71c889328d63fa50c14c6fd0fe998447"
SRC_URI[sha256sum] = "697fb750b3494fcf28da7cc55ea8428bfd803d3faeac18f0296f1b5fa4d7920c"
SRC_URI[md5sum] = "27f247adad8441c2ac2316cfc4ce4427"
SRC_URI[sha256sum] = "e849e30363b7df0a92ec9179b9ff9833a72581003da9eb880fc3e21ef1f4667e"
inherit catkin
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "35f122a7a9ba3d1e7c4addfe01ffcad6"
SRC_URI[sha256sum] = "41e511233510b6d8c73f354c2198c4ff5e82bafa47120fb3ffcb6704a2d7f1a6"
SRC_URI[md5sum] = "7832ec9a9e467e60747a886361624fb7"
SRC_URI[sha256sum] = "cdcad6a9a311bbe2f8f05ece55f595c0443b3a99e1c9ebd7b1c50ff05d6de123"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
......@@ -11,8 +11,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "cmake-modules console-bridge poco"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "3fb8bbc0273a613fcc519bdf549fcab6"
SRC_URI[sha256sum] = "34f7be503c333b45b5d006125b1d3b850dd2702e31c6a1e0d3b7535a0c553452"
SRC_URI[md5sum] = "faa7b419ba0ea1714f71404c2e76af0a"
SRC_URI[sha256sum] = "4413ea6492bc75a197fa2f219f59e46f70a33dc740aef0fba4f583c3de7bbbc3"
S = "${WORKDIR}/${ROS_SP}"
......
From b2f10174c48333f7a0ce8c01b86536f959d92348 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Wed, 21 Sep 2016 13:16:07 +0200
Subject: [PATCH] address gcc6 build error
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
This commit addresses this issue for this package in the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Upstream-Status: Accepted [https://github.com/ros/dynamic_reconfigure/commit/b2f10174c48333f7a0ce8c01b86536f959d92348]
This patch has been generated with:
`git format-patch -1 b2f10174c48333f7a0ce8c01b86536f959d92348`
in the dynamic_reconfigure repository.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
CMakeLists.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce896b9..60c6333 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,8 +4,7 @@ project(dynamic_reconfigure)
find_package(catkin REQUIRED COMPONENTS message_generation roscpp std_msgs)
find_package(Boost REQUIRED COMPONENTS system thread)
-include_directories(include ${catkin_INCLUDE_DIRS})
-include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
+include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
catkin_python_setup()
--
2.5.5
......@@ -7,10 +7,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "roscpp std-msgs roslib"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "5728cc591b90e7ddd42b936e74e3062c"
SRC_URI[sha256sum] = "f1b073c36fd937bd8697bc92ec38926f9194069e6e8d80ab70eb09610720ee7f"
SRC_URI += "file://0001-address-gcc6-build-error.patch"
SRC_URI[md5sum] = "368adb420f761be39cc0b9840237d599"
SRC_URI[sha256sum] = "409807fea59061a3d5788e6fa8c46ed2e2198cb1a8d59c66a417049b8e9cf754"
S = "${WORKDIR}/${ROS_SP}"
......
......@@ -4,8 +4,8 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "6ceee153cf07b27c94cbadfab0a08c3e"
SRC_URI[sha256sum] = "7ae3464121d1e6da8cc2829fad78b39687f75905cb7b56ff8d9f967cacb09a7f"
SRC_URI[md5sum] = "fcc3fdda4010f92aa68f926cd3b8bdd0"
SRC_URI[sha256sum] = "24d614921c4ec97f1d5c7905f5e896f1665b2e796c547b4a21504176b4680e47"
S = "${WORKDIR}/${ROS_SP}"
......
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "83719b720e925860d0804978fdb75eac"
SRC_URI[sha256sum] = "9432422b56a586828e75ec038f5400c3a92b0b108dd42bc331d8160972df012c"
SRC_URI[md5sum] = "5f69378e8a187e6b5694d7d4582662c1"
SRC_URI[sha256sum] = "45f6382112bb8b5bad47ce18e12a95018a53e9cc3b08b5daad232f089569f8eb"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
......@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "boost class-loader rosconsole roslib libtinyxml"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "6fb641ba2a31737e38d1535bbdf37a07"
SRC_URI[sha256sum] = "fca9f2f449ac7fea4eb4597d5ac8ac77d572f18f890333abd4cd2bbc0249f117"
SRC_URI[md5sum] = "60b02ed04b105e1fee0c536fe4612183"
SRC_URI[sha256sum] = "9a8a81d39472bda8cc8a9b189b9dc8f602b13b97a132a153144785d9fc5b68b2"
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment