Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
b1f9e2af
Commit
b1f9e2af
authored
8 years ago
by
Dmitry Rozhkov
Browse files
Options
Downloads
Patches
Plain Diff
laser-filters: backport fix for missing std namespace
Signed-off-by:
Dmitry Rozhkov
<
dmitry.rozhkov@linux.intel.com
>
parent
995fe068
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/laser-filters/laser-filters/0001-Use-std-namespace-for-c-11-compat.patch
+45
-0
45 additions, 0 deletions
...aser-filters/0001-Use-std-namespace-for-c-11-compat.patch
recipes-ros/laser-filters/laser-filters_1.8.3.bb
+3
-1
3 additions, 1 deletion
recipes-ros/laser-filters/laser-filters_1.8.3.bb
with
48 additions
and
1 deletion
recipes-ros/laser-filters/laser-filters/0001-Use-std-namespace-for-c-11-compat.patch
0 → 100644
+
45
−
0
View file @
b1f9e2af
From 9631aaabd65e10615baebd30273b57677ba4d49c Mon Sep 17 00:00:00 2001
From: Mike Purvis <mpurvis@clearpathrobotics.com>
Date: Fri, 15 Jul 2016 23:47:45 -0400
Subject: [PATCH] Use std:: namespace for c++11 compat.
Upstream-Status: Backported
---
include/laser_filters/intensity_filter.h | 4 ++--
test/test_scan_filter_chain.cpp | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/laser_filters/intensity_filter.h b/include/laser_filters/intensity_filter.h
index 3f175a0..4c9cfbc 100644
--- a/include/laser_filters/intensity_filter.h
+++ b/include/laser_filters/intensity_filter.h
@@ -99,8 +99,8 @@
public:
// Calculate histogram
if (disp_hist_enabled_){
// If intensity value is inf or NaN, skip voting histogram
- if( isinf((double)filtered_scan.intensities[i]) ||
- isnan((double)filtered_scan.intensities[i]) )
+ if( std::isinf((double)filtered_scan.intensities[i]) ||
+ std::isnan((double)filtered_scan.intensities[i]) )
continue;
// Choose bucket to vote on histogram,
diff --git a/test/test_scan_filter_chain.cpp b/test/test_scan_filter_chain.cpp
index b661f5f..139da60 100644
--- a/test/test_scan_filter_chain.cpp
+++ b/test/test_scan_filter_chain.cpp
@@ -60,8 +60,8 @@
sensor_msgs::LaserScan gen_msg(){
*/
void expect_ranges_eq(const std::vector<float> &a, const std::vector<float> &b) {
for( int i=0; i<10; i++) {
- if(isnan(a[i])) {
- EXPECT_TRUE(isnan(a[i]));
+ if(std::isnan(a[i])) {
+ EXPECT_TRUE(std::isnan(a[i]));
}
else {
EXPECT_NEAR(a[i], b[i], 1e-6);
--
2.7.4
This diff is collapsed.
Click to expand it.
recipes-ros/laser-filters/laser-filters_1.8.3.bb
+
3
−
1
View file @
b1f9e2af
...
...
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
DEPENDS = "angles filters laser-geometry message-filters pluginlib roscpp sensor-msgs tf"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz \
file://0001-Use-std-namespace-for-c-11-compat.patch \
"
SRC_URI[md5sum] = "566b4a51d0d11522d7528ca437c42b0f"
SRC_URI[sha256sum] = "3e124b474c0c0da419366fa21a101874cc7e4c83b352a2da5a21e1967c68555f"
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment