Skip to content
Snippets Groups Projects
Commit ae0c8988 authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

image-common: updating to 1.11.3

The previously applied patch has been included in 1.11.3 and is
removed from the recipe and this repository.
parent eceac35e
No related branches found
No related tags found
No related merge requests found
From 29f5630047052c24f1b506bdb743ebd53358686d Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:04:23 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Accepted
---
camera_info_manager/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/camera_info_manager/CMakeLists.txt b/camera_info_manager/CMakeLists.txt
index f220861..8b83216 100644
--- a/camera_info_manager/CMakeLists.txt
+++ b/camera_info_manager/CMakeLists.txt
@@ -10,7 +10,7 @@ catkin_package(INCLUDE_DIRS include
DEPENDS Boost roscpp sensor_msgs
)
-find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib rostest)
+find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib)
include_directories(SYSTEM ${camera_calibration_parsers_INCLUDE_DIRS}
${image_transport_INCLUDE_DIRS}
@@ -34,6 +34,7 @@ install(DIRECTORY include/${PROJECT_NAME}/
)
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
# Unit test uses gtest, but needs rostest to create a ROS environment.
# Hence, it must be created as a normal executable, not using
# catkin_add_gtest() which runs an additional test without rostest.
--
1.8.3.2
......@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9de
DEPENDS = "boost camera-calibration-parsers image-transport roscpp roslib sensor-msgs"
require image-common.inc
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "4339a2bc7a7fca8dad6b6c0d7796204d"
SRC_URI[sha256sum] = "bcce381f5525fe4185b08c23cbf4f1ddf2bc86263cdb53a7938c6dbf596d8ecc"
SRC_URI[md5sum] = "1e747f99e7bae7a49cb387ac02133534"
SRC_URI[sha256sum] = "03417c24017e912a683f2e6034624673e011de0843a61905b1f8dc7c2745d21e"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment