Skip to content
Snippets Groups Projects
Commit 9db849de authored by herbrechtsmeier's avatar herbrechtsmeier
Browse files

Merge pull request #219 from bulwahn/master

some minor tuning
parents fa12dfce ed42a957
No related branches found
No related tags found
No related merge requests found
File mode changed from 100755 to 100644
File mode changed from 100755 to 100644
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${PV}.tar.gz" SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "14841630d9d28e1b20c82993c59951ac" SRC_URI[md5sum] = "14841630d9d28e1b20c82993c59951ac"
SRC_URI[sha256sum] = "c921ed369a3ef47ccb6e72ddbdfb3188020adecaa94ad77d28bd58086bf6614c" SRC_URI[sha256sum] = "c921ed369a3ef47ccb6e72ddbdfb3188020adecaa94ad77d28bd58086bf6614c"
......
From f4130241042b2c19dda7b6d3a22e822585b4901a Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmwcarit.de>
Date: Tue, 31 Dec 2013 16:20:04 +0100
Subject: [PATCH] image_view must explicitly require OpenCV's core component
---
image_view/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/image_view/CMakeLists.txt b/image_view/CMakeLists.txt
index d72e992..e5b7790 100644
--- a/image_view/CMakeLists.txt
+++ b/image_view/CMakeLists.txt
@@ -6,7 +6,7 @@ catkin_package()
find_package(Boost REQUIRED COMPONENTS signals thread)
find_package(GTK2)
-find_package(OpenCV REQUIRED highgui)
+find_package(OpenCV REQUIRED core highgui)
find_package(catkin REQUIRED camera_calibration_parsers cv_bridge image_transport message_filters nodelet rosconsole roscpp)
include_directories(SYSTEM ${Boost_INCLUDE_DIRS}
${catkin_INCLUDE_DIRS}
--
1.8.1.4
...@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de ...@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
DEPENDS = "camera-calibration-parsers cv-bridge image-transport message-filters nodelet opencv rosconsole roscpp sensor-msgs std-srvs stereo-msgs" DEPENDS = "camera-calibration-parsers cv-bridge image-transport message-filters nodelet opencv rosconsole roscpp sensor-msgs std-srvs stereo-msgs"
require image-pipeline.inc require image-pipeline.inc
SRC_URI += "file://0001-image_view-must-explicitly-require-OpenCV-s-core-com.patch;striplevel=2"
...@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=5ee5b8b046ae4 ...@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=5ee5b8b046ae4
DEPENDS = "libeigen kdl-parser rosconsole roscpp rostime sensor-msgs tf tf-conversions" DEPENDS = "libeigen kdl-parser rosconsole roscpp rostime sensor-msgs tf tf-conversions"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "2315f637a70871bb460d6365a240741f" SRC_URI[md5sum] = "69fd00d92a1fe6928d30cd49f3e41fbd"
SRC_URI[sha256sum] = "7b1321f8e26352c0fc8558ddabfc86897613ac16834fb83d8696ff7d6dd973b5" SRC_URI[sha256sum] = "b2ee50c242508d78685e17819c3bafe22cdd667e9519c5f107169a9e1507a501"
S = "${WORKDIR}/${ROS_SP}" S = "${WORKDIR}/${ROS_SP}"
......
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${PV}.tar.gz" SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "8258067f0097e5a4355eda1b1cbaff04" SRC_URI[md5sum] = "8258067f0097e5a4355eda1b1cbaff04"
SRC_URI[sha256sum] = "e84a03be89650ed9e376b7e09ffe27cf7d1670e93e0e60cc2b59659a4aac7b20" SRC_URI[sha256sum] = "e84a03be89650ed9e376b7e09ffe27cf7d1670e93e0e60cc2b59659a4aac7b20"
......
File mode changed from 100755 to 100644
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment