Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
75f1c5f5
Commit
75f1c5f5
authored
11 years ago
by
Stefan Herbrechtsmeier
Committed by
Lukas Bulwahn
11 years ago
Browse files
Options
Downloads
Patches
Plain Diff
genlisp: Backport relocation changes
Signed-off-by:
Stefan Herbrechtsmeier
<
stefan@herbrechtsmeier.net
>
parent
26d93b34
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/genlisp/genlisp/0001-resolve-genlisp-path-in-installspace-at-runtime.patch
+28
-0
28 additions, 0 deletions
...001-resolve-genlisp-path-in-installspace-at-runtime.patch
recipes-ros/genlisp/genlisp_0.4.11.bb
+2
-2
2 additions, 2 deletions
recipes-ros/genlisp/genlisp_0.4.11.bb
with
30 additions
and
2 deletions
recipes-ros/genlisp/genlisp/0001-
genlisp-extras.cmake.em-Use-find_program-for-GENLISP
.patch
→
recipes-ros/genlisp/genlisp/0001-
resolve-genlisp-path-in-installspace-at-runtime
.patch
+
28
−
0
View file @
75f1c5f5
From 4efc32314f5ee02e5be759ea288e11b6de64f1a1 Mon Sep 17 00:00:00 2001
From: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
Date: Tue, 4 Jun 2013 17:58:41 +0200
Subject: [PATCH] genlisp-extras.cmake.em: Use find_program for GENLISP_BIN
From 42458c1d0a4ca1d3e78b8b1b2cac5e8fb2169a60 Mon Sep 17 00:00:00 2001
From: Dirk Thomas <dthomas@osrfoundation.org>
Date: Fri, 26 Jul 2013 13:34:11 -0700
Subject: [PATCH] resolve genlisp path in installspace at runtime
(ros/catkin#490)
Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
---
cmake/genlisp-extras.cmake.em |
10 +++++++-
--
1 file
s
changed,
7
insertions(+),
3
deletions(-)
cmake/genlisp-extras.cmake.em |
4 ++
--
1 file changed,
2
insertions(+),
2
deletions(-)
diff --git a/cmake/genlisp-extras.cmake.em b/cmake/genlisp-extras.cmake.em
index
0d135d0..db52d54
100644
index
a8dec4b..c62037d
100644
--- a/cmake/genlisp-extras.cmake.em
+++ b/cmake/genlisp-extras.cmake.em
@@ -1,13 +1,17 @@
@[if DEVELSPACE]@
# bin and template dir variables in develspace
-set(GENLISP_BIN "@(CMAKE_CURRENT_SOURCE_DIR)/scripts/gen_lisp.py")
+set(GENLISP_BIN_DIR "@(CMAKE_CURRENT_SOURCE_DIR)/scripts/gen_lisp.py")
@@ -4,8 +4,8 @@
set(GENLISP_BIN "@(CMAKE_CURRENT_SOURCE_DIR)/scripts/gen_lisp.py")
set(GENLISP_TEMPLATE_DIR "@(CMAKE_CURRENT_SOURCE_DIR)/scripts")
+set(CATKIN_FIND_ROOT_PATH_MODE NO_CMAKE_FIND_ROOT_PATH)
@[else]@
# bin and template dir variables in installspace
-set(GENLISP_BIN "@(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_BIN_DESTINATION)/gen_lisp.py")
-set(GENLISP_TEMPLATE_DIR "@(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_SHARE_DESTINATION)")
+set(GENLISP_BIN_DIR "@(CMAKE_INSTALL_PREFIX)/@(CATKIN_PACKAGE_BIN_DESTINATION)/")
+set(GENLISP_TEMPLATE_DIR "${CMAKE_CURRENT_LIST_DIR}/..")
+set(CATKIN_FIND_ROOT_PATH_MODE "")
+set(GENLISP_BIN "${genlisp_DIR}/../../../@(CATKIN_PACKAGE_BIN_DESTINATION)/gen_lisp.py")
+set(GENLISP_TEMPLATE_DIR "${genlisp_DIR}/..")
@[end if]@
+find_program(GENLISP_BIN gen_lisp.py PATHS ${GENLISP_BIN_DIR} NO_DEFAULT_PATH ${CATKIN_FIND_ROOT_PATH_MODE})
+
# Generate .msg or .srv -> .lisp
# The generated .lisp files should be added ALL_GEN_OUTPUT_FILES_lisp
macro(_generate_lisp ARG_PKG ARG_MSG ARG_IFLAGS ARG_MSG_DEPS ARG_GEN_OUTPUT_DIR)
--
1.
7.0.4
1.
8.1.6
This diff is collapsed.
Click to expand it.
recipes-ros/genlisp/genlisp_0.4.11.bb
+
2
−
2
View file @
75f1c5f5
...
...
@@ -5,12 +5,12 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "genmsg-native"
PR = "r
1
"
PR = "r
2
"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "b9be0a57abf76187a1057fb62cdc31e1"
SRC_URI[sha256sum] = "cc373440fcbf57cafb758795cb50045fdd96de717b93d3d5956b7a1a2af4d3e2"
SRC_URI += "file://0001-
genlisp-extras.cmake.em-Use-find_program-for-GENLISP
.patch"
SRC_URI += "file://0001-
resolve-genlisp-path-in-installspace-at-runtime
.patch"
inherit catkin
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment