Skip to content
Snippets Groups Projects
Commit 723caecd authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

libpoco: adding a patch to link correctly with pcre

The error message when compiling nodelet, which links the poco library, is:

| Linking CXX executable devel/lib/nodelet/nodelet
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/x86_64-linux/usr/bin/cmake -E cmake_link_script CMakeFiles/nodelet.dir/link.txt --verbose=1
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/x86_64-linux/usr/bin/armv5te-oe-linux-gnueabi/arm-oe-linux-gnueabi-g++    -march=armv5te -marm -mthumb-interwork  --sysroot=/home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm  -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -fpermissive  -march=armv5te -marm -mthumb-interwork  --sysroot=/home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm  -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed  -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed CMakeFiles/nodelet.dir/src/nodelet.cpp.o  -o devel/lib/nodelet/nodelet -rdynamic devel/lib/libnodeletlib.so -luuid -lbondcpp -luuid -lcpp_common -lroscpp_serialization -lrostime -lboost_date_time-mt -lboost_system-mt -lboost_thread-mt -lroscpp -lboost_signals-mt -lboost_filesystem-mt -lrosconsole -lboost_regex-mt -llog4cxx -lxmlrpcpp -ltinyxml -lclass_loader -lPocoFoundation -ldl -lconsole_bridge -lroslib -Wl,-rpath,/home/lukas/oe-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/nodelet/1.8.0-r0/nodelet_core-1.8.0/nodelet/build/devel/lib:
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm/usr/lib/libPocoFoundation.so: undefined reference to `_pcre_ucd_stage1'
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm/usr/lib/libPocoFoundation.so: undefined reference to `_pcre_ucd_records'
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm/usr/lib/libPocoFoundation.so: undefined reference to `_pcre_ucp_gentype'
| /home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm/usr/lib/libPocoFoundation.so: undefined reference to `_pcre_ucd_stage2'
| collect2: error: ld returned 1 exit status
| make[2]: *** [devel/lib/nodelet/nodelet] Error 1
parent 9ee34799
No related branches found
No related tags found
No related merge requests found
diff -Naur a/Foundation/Makefile b/Foundation/Makefile
--- a/Foundation/Makefile 2013-07-26 13:16:29.590566734 +0200
+++ b/Foundation/Makefile 2013-07-26 13:19:34.138559575 +0200
@@ -44,6 +44,7 @@
ifdef POCO_UNBUNDLED
SYSLIBS += -lpcre -lz
+ objects += $(pcre_utf8_objects)
else
objects += $(zlib_objects) $(pcre_objects) $(pcre_utf8_objects)
endif
......@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
DEPENDS = "expat zlib libpcre"
SRC_URI = "${SOURCEFORGE_MIRROR}/poco/poco-${PV}-all.tar.bz2 \
file://OE"
file://OE \
file://add_pcre_utf8_objects.patch"
SRC_URI[md5sum] = "2598b53d481e2bd3fb92bd23172abe53"
SRC_URI[sha256sum] = "95af0382257614c70841629c928184cddc228831a8bfc4c57399931bed8a16f8"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment