Skip to content
Snippets Groups Projects
Commit 6c5b8c8c authored by Murilo Belluzzo's avatar Murilo Belluzzo
Browse files

realsense_camera: Add patch to correct link the node...


... when the system library is used.

Signed-off-by: default avatarMurilo Belluzzo <murilo.belluzzo@intel.com>
parent 0a28ea09
No related branches found
No related tags found
No related merge requests found
From fb74e5eec2368f20c4b43cf9224519b29aee35ad Mon Sep 17 00:00:00 2001
From: Murilo Belluzzo <murilo.belluzzo@intel.com>
Date: Wed, 5 Apr 2017 17:06:44 -0700
Subject: [PATCH 3/3] librealsense: Fix link when the system library is used
Otherwise librealsense won't be listed as a dependency for the nodelet
that will fail to load due to undefined symbols.
Signed-off-by: Murilo Belluzzo <murilo.belluzzo@intel.com>
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1ec2f6..926992a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -106,6 +106,12 @@ add_library(${PROJECT_NAME}_nodelet src/base_nodelet.cpp src/r200_nodelet.cpp sr
target_link_libraries(${PROJECT_NAME}_nodelet
${catkin_LIBRARIES}
)
+if(USE_SYSTEM_LIBREALSENSE)
+ target_link_libraries(${PROJECT_NAME}_nodelet
+ ${realsense_LIBRARY}
+ )
+endif()
+
add_dependencies(${PROJECT_NAME}_nodelet ${PROJECT_NAME}_generate_messages_cpp ${PROJECT_NAME}_gencfg)
add_dependencies(${PROJECT_NAME}_nodelet ${catkin_EXPORTED_TARGETS})
--
2.12.2
......@@ -7,6 +7,7 @@ DEPENDS = "librealsense cv-bridge camera-info-manager pcl-ros roscpp"
SRC_URI = "https://github.com/intel-ros/realsense/archive/${PV}.tar.gz \
file://0001-Add-option-to-link-against-non-catkin-librealsense.patch \
file://0002-Enable-roslint-when-CATKIN_ENABLE_TESTING-is-True.patch \
file://0003-librealsense-Fix-link-when-the-system-library-is-use.patch \
"
SRC_URI[md5sum] = "aaa0d0ddaaee210e2a2529767ba45a4b"
SRC_URI[sha256sum] = "65c6c4a0b6bd0214dffa8528033f03c0fbc4be00e52e058cfbd96b4f7d733b10"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment