Skip to content
Snippets Groups Projects
Commit 5def5ef7 authored by herbrechtsmeier's avatar herbrechtsmeier
Browse files

Merge pull request #155 from bulwahn/update-versions

Updating versions to current hydro release versions
parents 9337818a fdfc4319
No related branches found
Tags v0.1rc2
No related merge requests found
Showing
with 10 additions and 568 deletions
From f066ff531ecdea3b859881aa1f4b4b34cba910c1 Mon Sep 17 00:00:00 2001
From: Dirk Thomas <dthomas@osrfoundation.org>
Date: Wed, 3 Jul 2013 11:30:06 -0700
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
CMakeLists.txt | 4 +++-
package.xml | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a51426..20421f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,4 +32,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
FILES_MATCHING PATTERN "*.h")
-add_subdirectory(test)
+if(CATKIN_ENABLE_TESTING)
+ add_subdirectory(test)
+endif()
diff --git a/package.xml b/package.xml
index 4d692ee..e45d984 100644
--- a/package.xml
+++ b/package.xml
@@ -14,7 +14,7 @@
<author>Eitan Marder-Eppstein</author>
<author>Vijay Pradeep</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>actionlib_msgs</build_depend>
<build_depend>boost</build_depend>
--
1.8.1.6
......@@ -7,9 +7,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
DEPENDS = "actionlib-msgs roscpp rostest"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "8da88314483b1330906b0ecf89c33494"
SRC_URI[sha256sum] = "c76317f60afec9e4cdcce28e0b88b9aef7e355ba8295228e759aa914ed10aae4"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
SRC_URI[md5sum] = "d16d2369554d8060beb4369b61d3cc68"
SRC_URI[sha256sum] = "d0a5eac521832cf09ddff833d7c7965874e3a0bf837d9464c344f71147dabb4b"
inherit catkin
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1bb6c5dd1148c67d2759e665d7ae75b3"
SRC_URI[sha256sum] = "1145db3800591e585325131cb6322366e82e634c97dd3cbb4ab43e1c1f4ec415"
SRC_URI[md5sum] = "9af26ae006a7111f8f546a5067d38f42"
SRC_URI[sha256sum] = "345e945c5401c494006885373c7658bed1f25bf4047838f4eb82dcda04b18bf2"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
......
......@@ -3,15 +3,12 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
PR = "r1"
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1c30ac4fcc82ce2aedf610ea972ab4d2"
SRC_URI[sha256sum] = "2494dbe3446fe94a55f57c74260e072f97d72944d89610fe4994dbc79cf1a561"
SRC_URI[md5sum] = "ea720dbabb693235f7377165aec55381"
SRC_URI[sha256sum] = "7f45a2889c80754f60995225f0378733bfc013a0549f25c98415b475eba560ae"
SRC_URI += "file://0001-modify-logic-of-sourcing-env-hooks-to-provide-contex.patch"
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
inherit catkin
......
......@@ -13,8 +13,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "console-bridge libpoco"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "c3bbc15c580dbf3b814b8af84218a777"
SRC_URI[sha256sum] = "afaa155be9e34d905396c96eac040007e23b4ba90d2b2677ab67a1b32086fe13"
SRC_URI[md5sum] = "fd24802f3cf2e9167561a89be25c24e5"
SRC_URI[sha256sum] = "7279ffe4e7481e71e9c0b6f0dc42e9c6b991100c5d1e7c6034cf28443846de83"
S = "${WORKDIR}/${ROS_SP}"
......
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "6259ec362103ed96abbcf7d67703aed5"
SRC_URI[sha256sum] = "54864270e973cec64f9315aed9e07f8d3837c409602dd18653c843c7a35690d0"
SRC_URI[md5sum] = "49856e2d0e1006fb86822bedcc397af4"
SRC_URI[sha256sum] = "191eddac2aea2d8b6d5e5939d11b58972bb0e4ddfeca8d3e0938c156d1447c52"
DEPENDS += "cpp-common roscpp-serialization message-generation-native message-runtime-native std-msgs"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment