Skip to content
Snippets Groups Projects
Commit 49dc096c authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

depthimage-to-laserscan: updating to 1.0.7

The patch provided upstream is part of 1.0.7 and hence is removed.
parent 0b9579de
No related branches found
No related tags found
No related merge requests found
From f953151cce932ffa8e0d14fc12b512d8e7d448fe Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Wed, 22 Jan 2014 11:18:25 +0100
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
Upstream-Status: Accepted
---
CMakeLists.txt | 8 +++++---
package.xml | 2 +-
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdf4a9f..a76b054 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,9 +30,11 @@ target_link_libraries(DepthImageToLaserScanNodelet DepthImageToLaserScanROS ${ca
add_executable(depthimage_to_laserscan src/depthimage_to_laserscan.cpp)
target_link_libraries(depthimage_to_laserscan DepthImageToLaserScanROS ${catkin_LIBRARIES})
-# Test the library
-catkin_add_gtest(libtest test/DepthImageToLaserScanTest.cpp)
-target_link_libraries(libtest DepthImageToLaserScan ${catkin_LIBRARIES})
+if(CATKIN_ENABLE_TESTING)
+ # Test the library
+ catkin_add_gtest(libtest test/DepthImageToLaserScanTest.cpp)
+ target_link_libraries(libtest DepthImageToLaserScan ${catkin_LIBRARIES})
+endif()
# add the test executable, keep it from being built by "make all"
add_executable(test_dtl EXCLUDE_FROM_ALL test/depthimage_to_laserscan_rostest.cpp)
diff --git a/package.xml b/package.xml
index 86f182a..d5ecc06 100644
--- a/package.xml
+++ b/package.xml
@@ -12,7 +12,7 @@
<author>Chad Rockey</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
<build_depend>gtest</build_depend>
--
1.8.5.1
......@@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
DEPENDS = "roscpp sensor-msgs nodelet image-transport image-geometry dynamic-reconfigure"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "ae007125db0a6586c176e0b111ae62c1"
SRC_URI[sha256sum] = "ae5ee31fc7cb9cd35dd3dd1b36ae00f084f874131d474466791bdb050cd7340f"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
SRC_URI[md5sum] = "b8fb5b855be4f7a8d22377d5d866bb47"
SRC_URI[sha256sum] = "3aa236f81cfd26e55718edfb50ef837a59b57169cb20a5b24f9a4e99602a09e8"
S = "${WORKDIR}/${ROS_SP}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment