Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
490a4088
Commit
490a4088
authored
8 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
cv-bridge: patch CMake script to compile with gcc6 (#392)
parent
dfb9a2a6
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/vision-opencv/cv-bridge/0001-address-gcc6-build-error-in-cv_bridge-and-tune.patch
+65
-0
65 additions, 0 deletions
...0001-address-gcc6-build-error-in-cv_bridge-and-tune.patch
recipes-ros/vision-opencv/cv-bridge_1.11.14.bb
+2
-0
2 additions, 0 deletions
recipes-ros/vision-opencv/cv-bridge_1.11.14.bb
with
67 additions
and
0 deletions
recipes-ros/vision-opencv/cv-bridge/0001-address-gcc6-build-error-in-cv_bridge-and-tune.patch
0 → 100644
+
65
−
0
View file @
490a4088
From aaf08c721c35a654c0ef0ac013e18db1b111bfdc Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Wed, 21 Sep 2016 11:27:28 +0200
Subject: [PATCH] address gcc6 build error in cv_bridge and tune
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
This commit addresses this issue for cv_bridge in the same way
it was done in the commit ead421b8 [1] for image_geometry.
This issue was also addressed in various other ROS packages.
A list of related commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
[1] https://github.com/ros-perception/vision_opencv/commit/ead421b85eeb750cbf7988657015296ed6789bcf
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Upstream-Status: Accepted [https://github.com/ros-perception/vision_opencv/commit/aaf08c721c35a654c0ef0ac013e18db1b111bfdc]
This patch has been generated with:
`git format-patch -1 aaf08c721c35a654c0ef0ac013e18db1b111bfdc`
in the vision_opencv repository.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
cv_bridge/CMakeLists.txt | 3 +--
cv_bridge/src/CMakeLists.txt | 5 +----
2 files changed, 2 insertions(+), 6 deletions(-)
diff --git a/cv_bridge/CMakeLists.txt b/cv_bridge/CMakeLists.txt
index 075fbbd..cce8af7 100644
--- a/cv_bridge/CMakeLists.txt
+++ b/cv_bridge/CMakeLists.txt
@@ -19,8 +19,7 @@
catkin_package(
catkin_python_setup()
-include_directories(SYSTEM ${Boost_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
-include_directories(include ${catkin_INCLUDE_DIRS})
+include_directories(include ${Boost_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS})
if(NOT ANDROID)
add_subdirectory(python)
diff --git a/cv_bridge/src/CMakeLists.txt b/cv_bridge/src/CMakeLists.txt
index 8ec321c..37ba30e 100644
--- a/cv_bridge/src/CMakeLists.txt
+++ b/cv_bridge/src/CMakeLists.txt
@@ -26,10 +26,7 @@
if(NOT PYTHON_NUMPY_INCLUDE_DIR)
endif(PYTHON_NUMPY_PROCESS EQUAL 0)
endif(NOT PYTHON_NUMPY_INCLUDE_DIR)
-include_directories(SYSTEM ${PYTHON_INCLUDE_PATH}
- ${Boost_INCLUDE_DIRS}
- ${PYTHON_NUMPY_INCLUDE_DIR} # cv_bridge module uses NumPy functions
-)
+include_directories(${PYTHON_INCLUDE_PATH} ${Boost_INCLUDE_DIRS} ${PYTHON_NUMPY_INCLUDE_DIR})
if (PYTHON_VERSION_MAJOR VERSION_EQUAL 3)
add_definitions(-DPYTHON3)
--
2.5.5
This diff is collapsed.
Click to expand it.
recipes-ros/vision-opencv/cv-bridge_1.11.14.bb
+
2
−
0
View file @
490a4088
...
...
@@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9de
DEPENDS = "boost opencv rosconsole sensor-msgs python-numpy-native"
require vision-opencv.inc
SRC_URI += "file://0001-address-gcc6-build-error-in-cv_bridge-and-tune.patch;striplevel=2"
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment