Skip to content
Snippets Groups Projects
Commit 48112b82 authored by Stefan Herbrechtsmeier's avatar Stefan Herbrechtsmeier Committed by Lukas Bulwahn
Browse files

actionlib: Include patch in our repository (resolves #146)

parent c19a3f17
No related branches found
No related tags found
No related merge requests found
From f066ff531ecdea3b859881aa1f4b4b34cba910c1 Mon Sep 17 00:00:00 2001
From: Dirk Thomas <dthomas@osrfoundation.org>
Date: Wed, 3 Jul 2013 11:30:06 -0700
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
CMakeLists.txt | 4 +++-
package.xml | 2 +-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a51426..20421f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,4 +32,6 @@ install(DIRECTORY include/${PROJECT_NAME}/
DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
FILES_MATCHING PATTERN "*.h")
-add_subdirectory(test)
+if(CATKIN_ENABLE_TESTING)
+ add_subdirectory(test)
+endif()
diff --git a/package.xml b/package.xml
index 4d692ee..e45d984 100644
--- a/package.xml
+++ b/package.xml
@@ -14,7 +14,7 @@
<author>Eitan Marder-Eppstein</author>
<author>Vijay Pradeep</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>actionlib_msgs</build_depend>
<build_depend>boost</build_depend>
--
1.8.1.6
......@@ -10,8 +10,6 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
SRC_URI[md5sum] = "8da88314483b1330906b0ecf89c33494"
SRC_URI[sha256sum] = "c76317f60afec9e4cdcce28e0b88b9aef7e355ba8295228e759aa914ed10aae4"
SRC_URI += "https://github.com/ros/${ROS_SPN}/commit/f066ff531ecdea3b859881aa1f4b4b34cba910c1.patch;name=patch"
SRC_URI[patch.md5sum] = "ba32239ddb0c6837a4296119dda5f08a"
SRC_URI[patch.sha256sum] = "d07e4cd0982fee417f574acac4e2e2a0387188bf254c6f49f7ab0f8c206082b8"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
inherit catkin
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment