Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Ros
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
uav-hds
intel-aero
Meta Ros
Commits
02049510
Commit
02049510
authored
11 years ago
by
Lukas Bulwahn
Browse files
Options
Downloads
Patches
Plain Diff
filters: removing rostest dependency
parent
10675b2b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
recipes-ros/filters/filters/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
+33
-0
33 additions, 0 deletions
...ake-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
recipes-ros/filters/filters_1.7.4.bb
+3
-2
3 additions, 2 deletions
recipes-ros/filters/filters_1.7.4.bb
with
36 additions
and
2 deletions
recipes-ros/filters/filters/0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch
0 → 100644
+
33
−
0
View file @
02049510
From 5aef0d6619394df17bffe743071295ad041b5794 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:02:09 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccb54f9..97eea51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@
project(filters)
# Find dependencies
##############################################################################
-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
+find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
find_package(Boost COMPONENTS system filesystem thread REQUIRED)
include_directories(
@@ -41,6 +41,7 @@
add_library(transfer_function src/transfer_function.cpp)
target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
# Test median filter
add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
--
1.8.3.2
This diff is collapsed.
Click to expand it.
recipes-ros/filters/filters_1.7.4.bb
+
3
−
2
View file @
02049510
...
...
@@ -3,12 +3,13 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roslib rosconsole roscpp pluginlib
rostest
"
DEPENDS = "roslib rosconsole roscpp pluginlib"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1"
SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch; \
file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
inherit catkin
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment