Skip to content
Snippets Groups Projects
  • Lukas Bulwahn's avatar
    9faf9c52
    libpoco: openssl required for libpoco when compiling pcl-ros · 9faf9c52
    Lukas Bulwahn authored
    When compiling pcl-ros, bitbake aborts because for compiling the
    Crypto library in libpoco, it needs the openssl headers.
    
    The condensed error output is
    
    ** Compiling src/CipherKeyImpl.cpp (debug, shared)
    arm-oe-linux-gnueabi-g++  -march=armv5te -marm -mthumb-interwork
    -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed
    --sysroot=/home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm
    -I ... -DPOCO_BUILD_HOST=host -DPOCO_NO_WSTRING -DPOCO_UNBUNDLED
    -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_REENTRANT -D_THREAD_SAFE
    -DPOCO_NO_FPENVIRONMENT  -g -D_DEBUG -fPIC -c src/CipherKeyImpl.cpp
    -o ...
    In file included from include/Poco/Crypto/CipherKeyImpl.h:44:0,
                     from include/Poco/Crypto/CipherKey.h:44,
                     from src/CipherKey.cpp:37:
    include/Poco/Crypto/OpenSSLInitializer.h:45:33: fatal error: openssl/opensslconf.h: No such file or directory
     #include <openssl/opensslconf.h>
                                     ^
    compilation terminated.
    In file included from include/Poco/Crypto/CipherKeyImpl.h:44:0,
                     from src/CipherKeyImpl.cpp:37:
    include/Poco/Crypto/OpenSSLInitializer.h:45:33: fatal error: openssl/opensslconf.h: No such file or directory
     #include <openssl/opensslconf.h>
                                     ^
    compilation terminated.
    make[1]: *** [.../tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Crypto/obj/Linux/armv5te/debug_shared/CipherKey.o] Error 1
    make[1]: *** Waiting for unfinished jobs....
    make -C /home/lukas/oe-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Util
    make[1]: *** [.../tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Crypto/obj/Linux/armv5te/debug_shared/CipherKeyImpl.o] Error 1
    make[1]: Entering directory `/home/lukas/oe-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Util'
    9faf9c52
    History
    libpoco: openssl required for libpoco when compiling pcl-ros
    Lukas Bulwahn authored
    When compiling pcl-ros, bitbake aborts because for compiling the
    Crypto library in libpoco, it needs the openssl headers.
    
    The condensed error output is
    
    ** Compiling src/CipherKeyImpl.cpp (debug, shared)
    arm-oe-linux-gnueabi-g++  -march=armv5te -marm -mthumb-interwork
    -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed
    --sysroot=/home/lukas/oe-core/build/tmp-eglibc/sysroots/qemuarm
    -I ... -DPOCO_BUILD_HOST=host -DPOCO_NO_WSTRING -DPOCO_UNBUNDLED
    -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_REENTRANT -D_THREAD_SAFE
    -DPOCO_NO_FPENVIRONMENT  -g -D_DEBUG -fPIC -c src/CipherKeyImpl.cpp
    -o ...
    In file included from include/Poco/Crypto/CipherKeyImpl.h:44:0,
                     from include/Poco/Crypto/CipherKey.h:44,
                     from src/CipherKey.cpp:37:
    include/Poco/Crypto/OpenSSLInitializer.h:45:33: fatal error: openssl/opensslconf.h: No such file or directory
     #include <openssl/opensslconf.h>
                                     ^
    compilation terminated.
    In file included from include/Poco/Crypto/CipherKeyImpl.h:44:0,
                     from src/CipherKeyImpl.cpp:37:
    include/Poco/Crypto/OpenSSLInitializer.h:45:33: fatal error: openssl/opensslconf.h: No such file or directory
     #include <openssl/opensslconf.h>
                                     ^
    compilation terminated.
    make[1]: *** [.../tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Crypto/obj/Linux/armv5te/debug_shared/CipherKey.o] Error 1
    make[1]: *** Waiting for unfinished jobs....
    make -C /home/lukas/oe-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Util
    make[1]: *** [.../tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Crypto/obj/Linux/armv5te/debug_shared/CipherKeyImpl.o] Error 1
    make[1]: Entering directory `/home/lukas/oe-core/build/tmp-eglibc/work/armv5te-oe-linux-gnueabi/libpoco/1.4.6p1-r0/poco-1.4.6p1-all/Util'