Skip to content
Snippets Groups Projects
  • Lukas Bulwahn's avatar
    0e0fc08e
    adjusting dependencies of native recipes · 0e0fc08e
    Lukas Bulwahn authored
    To compile nodelet-topic-tools, we must provide a working
    dynamic-reconfigure in the native sysroot. This requires
    some adjustments to the native versions of the required
    python modules.
    
    In particular, the following tasks ran successfully for this
    commit:
    
    This command tests compiling rospack-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake rospack-native
    
    This command tests compiling roslib-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake roslib-native
    
    As nodelet-topic-tools uses rospack-native and roslib-native to
    some extent (dependency: rospack-native -> roslib-native ->
    dynamic-reconfigure-native -> nodelet-topic-tools), this command
    tests running rospack-native and roslib-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake nodelet-topic-tools
    
    This command tests compiling rospack and roslib:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake rospack
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake roslib
    
    All these command run with this commit without errors, and
    future commits to these files should keep them run without
    errors or justify modifications with better tests.
    
    A minor open issue related to rospack is issue #116
    (cf. https://github.com/bmwcarit/meta-ros/issues/116).
    
    This commit incorporates feedback from Stefan Herbrechtsmeier.
    0e0fc08e
    History
    adjusting dependencies of native recipes
    Lukas Bulwahn authored
    To compile nodelet-topic-tools, we must provide a working
    dynamic-reconfigure in the native sysroot. This requires
    some adjustments to the native versions of the required
    python modules.
    
    In particular, the following tasks ran successfully for this
    commit:
    
    This command tests compiling rospack-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake rospack-native
    
    This command tests compiling roslib-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake roslib-native
    
    As nodelet-topic-tools uses rospack-native and roslib-native to
    some extent (dependency: rospack-native -> roslib-native ->
    dynamic-reconfigure-native -> nodelet-topic-tools), this command
    tests running rospack-native and roslib-native:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake nodelet-topic-tools
    
    This command tests compiling rospack and roslib:
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake rospack
    rm bitbake.lock cache/ sstate-cache/ tmp-eglibc/ -rf && bitbake roslib
    
    All these command run with this commit without errors, and
    future commits to these files should keep them run without
    errors or justify modifications with better tests.
    
    A minor open issue related to rospack is issue #116
    (cf. https://github.com/bmwcarit/meta-ros/issues/116).
    
    This commit incorporates feedback from Stefan Herbrechtsmeier.