diff --git a/recipes-core/images/core-image-ros-groovy-running-roscore.bb b/recipes-core/images/core-image-ros-groovy-running-roscore.bb
index d65e4a7c69c6068c661bf56e2cc800b3716fd153..52f9dbbead8411b56ff89d5592909e6a5e79dd42 100644
--- a/recipes-core/images/core-image-ros-groovy-running-roscore.bb
+++ b/recipes-core/images/core-image-ros-groovy-running-roscore.bb
@@ -10,8 +10,16 @@ inherit core-image
 
 IMAGE_ROOTFS_SIZE = "8192"
 
+# add own name to hosts
+# this is a simplistic setup for the qemu virtual machine with x86 architecture,
+# and not a general solution.
+augment_hosts_setting_file () {
+	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
+}
+
 # remove not needed ipkg informations
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "
+# create a custom hosts file
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
 
 IMAGE_INSTALL += "packagegroup-core-ssh-openssh \
   roslaunch \