From f6ce8dddab4e8c7bedf5adb31c541adbc3941f94 Mon Sep 17 00:00:00 2001
From: Jonas Sticha <jonas.sticha@bmw-carit.de>
Date: Mon, 2 Jun 2014 16:01:39 +0200
Subject: [PATCH] ros_realtime_tests: updating to 0.1.0

---
 .../communication-tests_0.1.0.bb                   |  8 ++++++++
 .../ros-realtime-tests/cyclic-timer-tests_0.1.0.bb |  8 ++++++++
 .../oneshot-timer-tests_0.1.0.bb                   |  8 ++++++++
 .../ros-realtime-tests/ros-realtime-tests.inc      |  9 +++++++++
 recipes-ros/ros-realtime-tests/timer-tests_git.bb  | 14 --------------
 5 files changed, 33 insertions(+), 14 deletions(-)
 create mode 100644 recipes-ros/ros-realtime-tests/communication-tests_0.1.0.bb
 create mode 100644 recipes-ros/ros-realtime-tests/cyclic-timer-tests_0.1.0.bb
 create mode 100644 recipes-ros/ros-realtime-tests/oneshot-timer-tests_0.1.0.bb
 create mode 100644 recipes-ros/ros-realtime-tests/ros-realtime-tests.inc
 delete mode 100644 recipes-ros/ros-realtime-tests/timer-tests_git.bb

diff --git a/recipes-ros/ros-realtime-tests/communication-tests_0.1.0.bb b/recipes-ros/ros-realtime-tests/communication-tests_0.1.0.bb
new file mode 100644
index 0000000..c3786af
--- /dev/null
+++ b/recipes-ros/ros-realtime-tests/communication-tests_0.1.0.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Tests for validating the real-time capabilities of the ROS publish subscribe communication mechanism"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
+
+DEPENDS = "roscpp message-generation message-runtime std-msgs"
+
+require ros-realtime-tests.inc
diff --git a/recipes-ros/ros-realtime-tests/cyclic-timer-tests_0.1.0.bb b/recipes-ros/ros-realtime-tests/cyclic-timer-tests_0.1.0.bb
new file mode 100644
index 0000000..2be2b3e
--- /dev/null
+++ b/recipes-ros/ros-realtime-tests/cyclic-timer-tests_0.1.0.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Tests for validating the real-time capabilities of the cyclic ROS timer function"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
+
+DEPENDS = "roscpp"
+
+require ros-realtime-tests.inc
diff --git a/recipes-ros/ros-realtime-tests/oneshot-timer-tests_0.1.0.bb b/recipes-ros/ros-realtime-tests/oneshot-timer-tests_0.1.0.bb
new file mode 100644
index 0000000..697f3d7
--- /dev/null
+++ b/recipes-ros/ros-realtime-tests/oneshot-timer-tests_0.1.0.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "Tests for validating the real-time capabilities of the ROS oneshot timer function"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
+
+DEPENDS = "roscpp"
+
+require ros-realtime-tests.inc
diff --git a/recipes-ros/ros-realtime-tests/ros-realtime-tests.inc b/recipes-ros/ros-realtime-tests/ros-realtime-tests.inc
new file mode 100644
index 0000000..6b9efe9
--- /dev/null
+++ b/recipes-ros/ros-realtime-tests/ros-realtime-tests.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "7bc5ff099f51dccae6a56c8b957152b6"
+SRC_URI[sha256sum] = "92f19fc3f591fee7d35a92d1e74a8755f4755452dd146f00c78e738b298cc1c9"
+
+S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
+
+inherit catkin
+
+ROS_SPN = "ros_realtime_tests"
diff --git a/recipes-ros/ros-realtime-tests/timer-tests_git.bb b/recipes-ros/ros-realtime-tests/timer-tests_git.bb
deleted file mode 100644
index 551b4da..0000000
--- a/recipes-ros/ros-realtime-tests/timer-tests_git.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "Tests for validating the real-time capabilities of the ROS middleware"
-SECTION = "devel"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=53d029b66e4cf837754fabf81702aad6"
-
-DEPENDS = "roscpp"
-
-SRC_URI = "git://github.com/bmwcarit/ros_realtime_tests.git"
-SRCREV = "11e234b4147d23136dd4f27e7c229872d795c610"
-PV = "0.0.1+git${SRCPV}"
-
-S = "${WORKDIR}/git/timer_tests"
-
-inherit catkin
-- 
GitLab