diff --git a/recipes-ros/executive-smach/executive-smach.inc b/recipes-ros/executive-smach/executive-smach.inc
new file mode 100644
index 0000000000000000000000000000000000000000..367cc9e0b19f21a37ad1fe94fe736c43c888f277
--- /dev/null
+++ b/recipes-ros/executive-smach/executive-smach.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "1a8ae6b09936f75bf2bdb8300b46fb2f"
+SRC_URI[sha256sum] = "12da6987a028b49dab269105519a4b23ce3a67cfeba475cd5b2b35ea8b23adf4"
+
+S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
+
+inherit catkin
+
+ROS_SPN = "executive_smach"
diff --git a/recipes-ros/executive-smach/smach-msgs_1.3.1.bb b/recipes-ros/executive-smach/smach-msgs_1.3.1.bb
new file mode 100644
index 0000000000000000000000000000000000000000..1be2aa402196fc4696ea505139ede25230fd81f4
--- /dev/null
+++ b/recipes-ros/executive-smach/smach-msgs_1.3.1.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "this package contains a set of messages that are used by the introspection interfaces for smach."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+DEPENDS = "message-generation std-msgs"
+
+require executive-smach.inc
diff --git a/recipes-ros/executive-smach/smach-ros_1.3.1.bb b/recipes-ros/executive-smach/smach-ros_1.3.1.bb
new file mode 100644
index 0000000000000000000000000000000000000000..a09b5a7ccf74eecde9871d0fa69ba9d841a92575
--- /dev/null
+++ b/recipes-ros/executive-smach/smach-ros_1.3.1.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "The smach_ros package contains extensions for the SMACH library to integrate it tightly with ROS."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require executive-smach.inc
diff --git a/recipes-ros/executive-smach/smach_1.3.1.bb b/recipes-ros/executive-smach/smach_1.3.1.bb
new file mode 100644
index 0000000000000000000000000000000000000000..4048a16ce4b973098eb422dbeb35cd335446e692
--- /dev/null
+++ b/recipes-ros/executive-smach/smach_1.3.1.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "SMACH is a task-level architecture for rapidly creating complex robot behavior."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require executive-smach.inc