From ed77625288e9bf65ef9050c19c7d31c1dc3f0203 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 1 Aug 2013 08:21:10 +0200
Subject: [PATCH] dynamic-reconfigure: adding patch to resolve path (resolving
 #126)

Before this commit, the following sequence of bitbake commands
failed because the path was set during compile time, and not at
runtime. After the patch from Dirk Thomas, the following sequence
now works.

bitbake nodelet-topic-tools -c cleansstate && \
bitbake dynamic-reconfigure && bitbake nodelet-topic-tools
---
 .../dynamic-reconfigure/dynamic-reconfigure_1.5.32.bb  | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

diff --git a/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.32.bb b/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.32.bb
index 1ba7673..dc2dc3a 100644
--- a/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.32.bb
+++ b/recipes-ros/dynamic-reconfigure/dynamic-reconfigure_1.5.32.bb
@@ -6,9 +6,13 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=5ee5b8b046ae48ad94a2037ca953a67b"
 
-SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz"
-SRC_URI[md5sum] = "9061fd30e5a04e8376eaddffaae86b07"
-SRC_URI[sha256sum] = "4203b0a8389d9ac3203110b507d23fa353262cf26253f40abece6418d6c2bdd4"
+SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz;name=archive"
+SRC_URI[archive.md5sum] = "9061fd30e5a04e8376eaddffaae86b07"
+SRC_URI[archive.sha256sum] = "4203b0a8389d9ac3203110b507d23fa353262cf26253f40abece6418d6c2bdd4"
+
+SRC_URI += "https://github.com/ros/dynamic_reconfigure/commit/b7b222534f7259ca457ea354d92c5708f895202e.patch;name=patch"
+SRC_URI[patch.md5sum] = "0607963ca3f940362c9e78b5f8019cb9"
+SRC_URI[patch.sha256sum] = "e132ed52fe35c287658700857f7d9439793ff2be7f9fa9a19731024152ccaf29"
 
 DEPENDS = "roscpp std-msgs roslib"
 RDEPENDS_${PN} = "roslib"
-- 
GitLab