diff --git a/README.af_yocto b/README.af_yocto
index 0d50cee29d31c68bba7983a2dc790e4f9fc28d32..f042f9f9462dc7196c1a8323c733ff90234ede17 100644
--- a/README.af_yocto
+++ b/README.af_yocto
@@ -11,7 +11,7 @@ INSTALLATION and USE:
     bitbake core-image-bmw
   builds our specifically configured linux image.
   
-  With `runqemu qemux86-64 core-image-bmw` the linux image runs within a virtual machine.
+  With `runqemu qemux86-64 qemuparams="-m 2048" core-image-bmw` the linux image runs within a virtual machine with 2048 MB of memory.
   We assume that this is running on and compiled for an x86-64 architecture. For other architectures, some settings must be adjusted.
   
   Extract ros_server.tar.gz somewhere, adjust pathes in fuerte-ros-base.rosinstall to the location where it has been extracted to.
@@ -52,7 +52,9 @@ RESOLVED ISSUES for M1:
     RESOLVED by patching distutils class--will be committed to yocto.
   - recipe for log4cxx requires another patch.
     RESOLVED by providing patch 0003 in recipe
-
+  - Compilation with make fails in the virtual machine because of insufficient memory during compilation.
+    RESOLVED by increasing memory.
+  
 OPEN ISSUES for M1:
 
   - Yocto: python-setuptools requires some python-modules at run-time.
@@ -60,5 +62,4 @@ OPEN ISSUES for M1:
     SHOULD BE RESOLVED by creating an appropriate patch for python-setuptools and contributing to openembedded-core
   - rospkg modules are not found when runnning python.
     TEMPORARILY RESOLVED by installing natively in the virtual machine
-    SOLUTION UNCLEAR. Maybe we need rospkg-dev?
-  - Compilation with make fails in the virtual machine because of insufficient memory during compilation.
+    SOLUTION UNCLEAR. Cannot be solved by adding rospkg-dev.
diff --git a/install.sh b/install.sh
index 8723ac6c44101001b1683ecd5af07fea2bf603e7..084e01063d743785a5271d97f3306520786d54bf 100644
--- a/install.sh
+++ b/install.sh
@@ -10,8 +10,40 @@ rosinstall --catkin ~/ros fuerte-ros-base.rosinstall
 git clone ssh://lukas@192.168.7.1//home/lukas/ros_server/rospkg
 cd ~/rospkg
 python setup.py install
+# apply patch
+cd ~/ros/ros_comm
+patch -p1 << EOF
+diff -cr ros_comm/tools/rosbag/src/recorder.cpp ros_comm.patched/tools/rosbag/src/recorder.cpp
+*** ros_comm/tools/rosbag/src/recorder.cpp	2012-12-06 14:12:06.773910947 +0100
+--- ros_comm.patched/tools/rosbag/src/recorder.cpp	2012-12-06 14:14:49.145917680 +0100
+***************
+*** 436,442 ****
+                  break;
+              }
+              boost::xtime xt;
+!             boost::xtime_get(&xt, boost::TIME_UTC);
+              xt.nsec += 250000000;
+              queue_condition_.timed_wait(lock, xt);
+              if (checkDuration(ros::Time::now()))
+--- 436,442 ----
+                  break;
+              }
+              boost::xtime xt;
+!             boost::xtime_get(&xt, boost::TIME_UTC_);
+              xt.nsec += 250000000;
+              queue_condition_.timed_wait(lock, xt);
+              if (checkDuration(ros::Time::now()))
+EOF
 # cmake invocation
 cd ~/ros
 mkdir build
 cd build
-cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
\ No newline at end of file
+cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
+# compile and install
+make
+make install
+# add own name to hosts
+echo -e '127.0.0.1\tqemux86-64.localdomain\t\tqemux86-64' >> /etc/hosts
+# start roscore
+. /opt/ros/fuerte/setup.sh
+roscore