From e5c6b214920df097be87136530e4c0c6c68284c8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Mon, 22 Jul 2013 13:12:41 +0200
Subject: [PATCH] removing now obsolete files for previous on-target
 compilation

---
 PREVIOUS_USES                                |  58 -----------
 fetch-ros-fuerte.sh                          |  11 --
 install-fuerte.sh                            | 102 -------------------
 install-groovy.sh                            |  46 ---------
 mk_srcarchive.sh                             |   5 -
 recipes-core/images/core-image-ros-fuerte.bb |  27 -----
 recipes-core/images/core-image-ros-groovy.bb |  33 ------
 7 files changed, 282 deletions(-)
 delete mode 100644 PREVIOUS_USES
 delete mode 100644 fetch-ros-fuerte.sh
 delete mode 100644 install-fuerte.sh
 delete mode 100644 install-groovy.sh
 delete mode 100644 mk_srcarchive.sh
 delete mode 100644 recipes-core/images/core-image-ros-fuerte.bb
 delete mode 100644 recipes-core/images/core-image-ros-groovy.bb

diff --git a/PREVIOUS_USES b/PREVIOUS_USES
deleted file mode 100644
index 1ba6a65..0000000
--- a/PREVIOUS_USES
+++ /dev/null
@@ -1,58 +0,0 @@
-
-PREVIOUS USE CASES
-
-INSTALLATION:
-
-  The repository only contains a layer for ROS that builds on top of the existing OpenEmbedded Core layer.
-  You can download the yocto poky-danny-8.0 archive, but then you should update the distutils.bbclass,
-  and maybe also the url of libarchive.
-  To install, unpack http://downloads.yoctoproject.org/releases/yocto/yocto-1.3/poky-danny-8.0.tar.bz2 into a directory <dir>.
-  
-  In the directory of the layers, clone this repository into the subdirectory meta-ros. 
-  Add the meta-ros directory to your local bblayers.conf file.
-
-
-USE for native compilation of ROS-fuerte on the qemu VM:
-  The commands
-    source oe-init-build-env
-    bitbake core-image-ros-fuerte
-  builds our specifically configured linux image.
-  
-  With `runqemu qemux86 qemuparams="-m 2048" core-image-ros-fuerte` the linux image runs within a virtual machine with 2048 MB of memory.
-  We assumed that this is running on and compiled for an x86 architecture. For other architectures, some settings must be adjusted.
-  
-  On the host system, run fetch-ros-fuerte.sh in a fresh directory, e.g. ~/ros-repos/.
-  It clones all ros repositories locally.
-  After starting the virtual machine, copy the installation script from the host system to the home directory with scp.
-  
-    scp lukas@192.168.7.1:/<location of repository>/install-fuerte.sh .
-
-  Adjust configuration in install-fuerte.sh and then run
-
-    sh ./install-fuerte.sh
-  
-  The installation script installs ros and starts roscore.
-
-
-USE for native compilation of ROS-groovy on the qemu VM:
-  The commands
-    source oe-init-build-env
-    bitbake core-image-ros-groovy
-  builds our specifically configured linux image.
-  
-  With `runqemu qemux86 qemuparams="-m 2048" core-image-ros-groovy` the linux image runs within a virtual machine with 2048 MB of memory.
-  We assumed that this is running on and compiled for an x86 architecture. For other architectures, some settings must be adjusted.
-  
-  On the host system, run mk_srcarchive.sh in some clean temporary directory.
-  It copies all ros sources from their URLs and puts them into one src.tar.gz archive.
-  After starting the virtual machine, copy the installation script from the host system to the home directory with scp.
-  
-    scp lukas@192.168.7.1:/<location of repository>/install-groovy.sh .
-
-  Adjust configuration in install-groovy.sh and then run
-
-    sh ./install-groovy.sh
-  
-  The installation script installs ros and starts roscore.
-
-
diff --git a/fetch-ros-fuerte.sh b/fetch-ros-fuerte.sh
deleted file mode 100644
index 15f2c54..0000000
--- a/fetch-ros-fuerte.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-git clone git://github.com/wg-debs/catkin-release.git
-git clone git://github.com/wg-debs/common_msgs-release.git
-git clone git://github.com/wg-debs/gencpp-release.git
-git clone git://github.com/wg-debs/genlisp-release.git
-git clone git://github.com/wg-debs/genmsg-release.git
-git clone git://github.com/wg-debs/genpy-release.git
-git clone git://github.com/wg-debs/ros-release.git
-git clone git://github.com/wg-debs/ros_comm-release.git
-git clone git://github.com/wg-debs/roscpp_core-release.git
-git clone git://github.com/wg-debs/rospack-release.git
-git clone git://github.com/wg-debs/std_msgs-release.git
\ No newline at end of file
diff --git a/install-fuerte.sh b/install-fuerte.sh
deleted file mode 100644
index 0d9fea5..0000000
--- a/install-fuerte.sh
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/bash
-## Installation script that should run in the virtual machine
-# copy it into the virtual machine with:
-# scp <user>@192.168.7.1:/<location of install.sh> .
-# and run it:
-# sh ./install-fuerte.sh
-#
-# local setting (must be adjusted)
-USERNAME="lukas"
-REPOS_PATH="home/lukas/ros-repos"
-HOST_IP="192.168.7.1"
-# This script does the following steps:
-# create ssh login without password
-#
-ssh-keygen -t rsa
-cat .ssh/id_rsa.pub | ssh $USERNAME@$HOST_IP 'cat >> .ssh/authorized_keys'
-# create prepared rosinstall file
-URL="ssh://$USERNAME@$HOST_IP/$REPOS_PATH"
-cat > fuerte-ros-base.rosinstall << EOF
-- git:
-    local-name: catkin
-    uri: $URL/catkin-release
-    version: debian/ros-fuerte-catkin_0.4.4_lucid
-- git:
-    local-name: common_msgs
-    uri: $URL/common_msgs-release
-    version: debian/ros-fuerte-common-msgs_1.8.7_lucid
-- git:
-    local-name: gencpp
-    uri: $URL/gencpp-release
-    version: debian/ros-fuerte-gencpp_0.3.4_lucid
-- git:
-    local-name: genlisp
-    uri: $URL/genlisp-release
-    version: debian/ros-fuerte-genlisp_0.3.3_lucid
-- git:
-    local-name: genmsg
-    uri: $URL/genmsg-release
-    version: debian/ros-fuerte-genmsg_0.3.10_lucid
-- git:
-    local-name: genpy
-    uri: $URL/genpy-release
-    version: debian/ros-fuerte-genpy_0.3.7_lucid
-- git:
-    local-name: ros
-    uri: $URL/ros-release
-    version: debian/ros-fuerte-ros_1.8.9_lucid
-- git:
-    local-name: ros_comm
-    uri: $URL/ros_comm-release
-    version: debian/ros-fuerte-ros-comm_1.8.12_lucid
-- git:
-    local-name: roscpp_core
-    uri: $URL/roscpp_core-release
-    version: debian/ros-fuerte-roscpp-core_0.2.5_lucid
-- git:
-    local-name: rospack
-    uri: $URL/rospack-release
-    version: debian/ros-fuerte-rospack_2.0.13_lucid
-- git:
-    local-name: std_msgs
-    uri: $URL/std_msgs-release
-    version: debian/ros-fuerte-std-msgs_0.4.8_lucid
-EOF
-# run rosinstall
-mkdir ~/ros
-rosinstall --catkin ~/ros fuerte-ros-base.rosinstall
-# apply patch
-cd ~/ros/ros_comm
-patch -p1 << EOF
-diff -cr ros_comm/tools/rosbag/src/recorder.cpp ros_comm.patched/tools/rosbag/src/recorder.cpp
-*** ros_comm/tools/rosbag/src/recorder.cpp	2012-12-06 14:12:06.773910947 +0100
---- ros_comm.patched/tools/rosbag/src/recorder.cpp	2012-12-06 14:14:49.145917680 +0100
-***************
-*** 436,442 ****
-                  break;
-              }
-              boost::xtime xt;
-!             boost::xtime_get(&xt, boost::TIME_UTC);
-              xt.nsec += 250000000;
-              queue_condition_.timed_wait(lock, xt);
-              if (checkDuration(ros::Time::now()))
---- 436,442 ----
-                  break;
-              }
-              boost::xtime xt;
-!             boost::xtime_get(&xt, boost::TIME_UTC_);
-              xt.nsec += 250000000;
-              queue_condition_.timed_wait(lock, xt);
-              if (checkDuration(ros::Time::now()))
-EOF
-# cmake invocation
-cd ~/ros
-mkdir build
-cd build
-cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF
-# compile and install
-make
-make install
-# start roscore
-. /opt/ros/fuerte/setup.sh
-roscore
diff --git a/install-groovy.sh b/install-groovy.sh
deleted file mode 100644
index 5e142d5..0000000
--- a/install-groovy.sh
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/bash
-## Installation script that should run in the virtual machine
-# copy it into the virtual machine with:
-# scp <user>@192.168.7.1:/<location of install.sh> .
-# and run it:
-# sh ./install-groovy.sh
-#
-# local setting (must be adjusted)
-USERNAME="lukas"
-HOST_IP="192.168.7.1"
-SRC_DIRECTORY="/home/lukas/ros_catkin_ws"
-# This script does the following steps:
-# copy source archive
-scp $USERNAME@$HOST_IP:$SRC_DIRECTORY/src.tar.gz .
-mkdir ros_catkin_ws
-cd ros_catkin_ws
-# extract
-tar -xzf ../src.tar.gz
-# patch catkin
-patch -p1 << EOF
-*** A/src/catkin/cmake/python.cmake	2013-01-04 14:22:33.223884756 +0100
---- B/src/catkin/cmake/python.cmake	2013-01-04 14:28:01.971898385 +0100
-***************
-*** 6,12 ****
-  set(PYTHON_VERSION_XDOTY ${PYTHON_VERSION_XDOTY} CACHE STRING "Python version")
-  
-  #This should be resolved automatically one day...
-! option(SETUPTOOLS_DEB_LAYOUT "ON for debian style python packages layout" ON)
-  
-  if(APPLE OR MSVC)
-    set(SETUPTOOLS_DEB_LAYOUT OFF)
---- 6,12 ----
-  set(PYTHON_VERSION_XDOTY ${PYTHON_VERSION_XDOTY} CACHE STRING "Python version")
-  
-  #This should be resolved automatically one day...
-! option(SETUPTOOLS_DEB_LAYOUT "ON for debian style python packages layout" OFF)
-  
-  if(APPLE OR MSVC)
-    set(SETUPTOOLS_DEB_LAYOUT OFF)
-EOF
-# compile, make and install
-./src/catkin/bin/catkin_make_isolated --install
-# start roscore
-. install_isolated/setup.sh
-roscore
-
diff --git a/mk_srcarchive.sh b/mk_srcarchive.sh
deleted file mode 100644
index 9db790c..0000000
--- a/mk_srcarchive.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-wget -O ros_comm http://packages.ros.org/web/rosinstall/generate/raw/groovy/ros_comm
-mkdir -p archives
-grep -e "- tar: {local-name: .*, uri: '.*'," ros_comm | sed "s#- tar: {local-name: \(.*\), uri: '\(.*\)',#wget -O archives/\1.tar.gz \2 \&\& mkdir -p src/\1 \&\& tar --strip-components=1 -xzf archives/\1.tar.gz -C src/\1/ #" | sh
-tar -czf src.tar.gz src
-
diff --git a/recipes-core/images/core-image-ros-fuerte.bb b/recipes-core/images/core-image-ros-fuerte.bb
deleted file mode 100644
index 8ff31b7..0000000
--- a/recipes-core/images/core-image-ros-fuerte.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "A small image just capable of allowing a device to boot."
-
-IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "CLOSED"
-
-inherit core-image
-
-IMAGE_ROOTFS_EXTRA_SPACE = "524288"
-
-IMAGE_FEATURES += "tools-sdk"
-
-# add own name to hosts
-augment_hosts_setting_file () {
-	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
-}
-
-# remove not needed ipkg informations
-# create a custom hosts file
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
-
-IMAGE_INSTALL += "packagegroup-core-ssh-openssh git cmake \
-  boost boost-dev log4cxx log4cxx-dev libbz2-dev \
-  python-modules python-empy python-pyyaml python-nose \
-  python-setuptools python-rospkg python-rosinstall"
diff --git a/recipes-core/images/core-image-ros-groovy.bb b/recipes-core/images/core-image-ros-groovy.bb
deleted file mode 100644
index addbb36..0000000
--- a/recipes-core/images/core-image-ros-groovy.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-DESCRIPTION = "A small image just capable of allowing a device to boot."
-
-IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "CLOSED"
-
-inherit core-image
-
-IMAGE_ROOTFS_EXTRA_SPACE = "524288"
-
-IMAGE_FEATURES += "tools-sdk"
-
-# add own name to hosts
-augment_hosts_setting_file () {
-	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
-}
-
-# remove not needed ipkg informations
-# create a custom hosts file
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
-
-# currently install all python-modules, but we only need a subset.
-# also adding python-misc to obtain the ast module. We should check if this ast file should better
-# be a python module in the openembedded core repository.
-IMAGE_INSTALL += "packagegroup-core-ssh-openssh cmake \
-  python-modules python-misc python-empy python-setuptools \
-  boost boost-dev python-dev libtinyxml libtinyxml-dev \
-  log4cxx log4cxx-dev libbz2-dev \
-  python-argparse python-rosdep python-wstool \
-"
-
-- 
GitLab