diff --git a/recipes-devtools/log4cxx/log4cxx/log4cxx010.patch b/recipes-devtools/log4cxx/log4cxx/log4cxx010.patch
deleted file mode 100644
index 17d2c9d78088e121a861ba7f0a7d7129e2908af1..0000000000000000000000000000000000000000
--- a/recipes-devtools/log4cxx/log4cxx/log4cxx010.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- apache-log4cxx-0.10.0.orig//src/examples/cpp/console.cpp	2008-04-01 00:34:52.000000000 +0200
-+++ apache-log4cxx-0.10.0//src/examples/cpp/console.cpp	2010-05-04 23:52:38.270096842 +0200
-@@ -23,6 +23,8 @@
- #include <iostream>
- #include <locale.h>
- 
-+#include <cstring>
-+
- using namespace log4cxx;
- using namespace log4cxx::helpers;
- 
---- apache-log4cxx-0.10.0.orig//src/main/cpp/inputstreamreader.cpp	2008-04-01 00:34:09.000000000 +0200
-+++ apache-log4cxx-0.10.0//src/main/cpp/inputstreamreader.cpp	2010-05-04 23:45:21.583105063 +0200
-@@ -21,6 +21,8 @@
- #include <log4cxx/helpers/pool.h>
- #include <log4cxx/helpers/bytebuffer.h>
- 
-+#include <cstring>
-+
- using namespace log4cxx;
- using namespace log4cxx::helpers;
- 
---- apache-log4cxx-0.10.0.orig//src/main/cpp/socketoutputstream.cpp	2008-04-01 00:34:09.000000000 +0200
-+++ apache-log4cxx-0.10.0//src/main/cpp/socketoutputstream.cpp	2010-05-04 23:49:22.838093204 +0200
-@@ -20,6 +20,8 @@
- #include <log4cxx/helpers/socket.h>
- #include <log4cxx/helpers/bytebuffer.h>
- 
-+#include <cstring>
-+
- using namespace log4cxx;
- using namespace log4cxx::helpers;
- 
diff --git a/recipes-devtools/log4cxx/log4cxx/log4cxx097.patch b/recipes-devtools/log4cxx/log4cxx/log4cxx097.patch
deleted file mode 100644
index 86b6effdb0f2a3ee32214cf136602427b7fd2482..0000000000000000000000000000000000000000
--- a/recipes-devtools/log4cxx/log4cxx/log4cxx097.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- log4cxx-0.9.7/src/socketoutputstream.cpp~	2009-05-21 10:06:47.000000000 +0100
-+++ log4cxx-0.9.7/src/socketoutputstream.cpp	2009-05-21 10:06:47.000000000 +0100
-@@ -13,7 +13,8 @@
-  * See the License for the specific language governing permissions and
-  * limitations under the License.
-  */
-- 
-+
-+#include <string.h> 
- #include <log4cxx/helpers/socketoutputstream.h>
- #include <log4cxx/helpers/socket.h>
- #include <log4cxx/helpers/loglog.h>
-
---- log4cxx-0.9.7/src/stringtokenizer.cpp~	2009-05-21 10:11:19.000000000 +0100
-+++ log4cxx-0.9.7/src/stringtokenizer.cpp	2009-05-21 10:11:20.000000000 +0100
-@@ -13,7 +13,8 @@
-  * See the License for the specific language governing permissions and
-  * limitations under the License.
-  */
-- 
-+
-+#include <string.h> 
- #include <log4cxx/helpers/stringtokenizer.h>
- 
- using namespace log4cxx;
-
---- log4cxx-0.9.7/src/timezone.cpp~	2009-05-21 10:14:27.000000000 +0100
-+++ log4cxx-0.9.7/src/timezone.cpp	2009-05-21 10:14:27.000000000 +0100
-@@ -13,7 +13,8 @@
-  * See the License for the specific language governing permissions and
-  * limitations under the License.
-  */
-- 
-+
-+#include <string.h>
- #include <log4cxx/helpers/timezone.h>
- #include <locale>
- 
---- log4cxx-0.9.7/src/xmlsocketappender.cpp~	2009-05-21 10:16:24.000000000 +0100
-+++ log4cxx-0.9.7/src/xmlsocketappender.cpp	2009-05-21 10:16:25.000000000 +0100
-@@ -14,6 +14,7 @@
-  * limitations under the License.
-  */
- 
-+#include <string.h>
- #include <log4cxx/net/xmlsocketappender.h>
- #include <log4cxx/helpers/loglog.h>
- #include <log4cxx/helpers/socketoutputstream.h>
diff --git a/recipes-devtools/log4cxx/log4cxx_0.9.7.bb b/recipes-devtools/log4cxx/log4cxx_0.9.7.bb
deleted file mode 100644
index a9337d3fa667fca44b2c8899b1d71b55d0d745a3..0000000000000000000000000000000000000000
--- a/recipes-devtools/log4cxx/log4cxx_0.9.7.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Apache logging framework for C++ library"
-SECTION = "libs"
-DEPENDS = "apr apr-util expat gdbm"
-LICENSE = "Apache License, Version 2.0"
-HOMEPAGE = "http://logging.apache.org/log4cxx/"
-# PV = "0.10.0"
-PR = "r1"
-
-SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/log4cxx-0.9.7.tar.gz \
-          file://log4cxx097.patch"
-
-#build this:
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit autotools pkgconfig
-
-SRC_URI[md5sum] = "fd09abc90b8c0c8af1d5146a75590792"
-SRC_URI[sha256sum] = "5b41b2fc267595bdb0fa4cd1152309413bc70e6d9196293113ebb82751eb7ec6"
diff --git a/recipes-devtools/log4cxx/log4cxx_svn.bb b/recipes-devtools/log4cxx/log4cxx_svn.bb
deleted file mode 100644
index d49fb03c23dc76baf12de800e1778ea610b693d6..0000000000000000000000000000000000000000
--- a/recipes-devtools/log4cxx/log4cxx_svn.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DESCRIPTION = "Apache logging framework for C++ library"
-SECTION = "libs"
-DEPENDS = "apr apr-util expat gdbm"
-LICENSE = "Apache License Version 2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-HOMEPAGE = "http://logging.apache.org/log4cxx/"
-
-SRCREV = "${AUTOREV}"
-PV = "0.0+svnr${SRCPV}"
-PR = "r0"
-
-SRC_URI = "svn://svn.apache.org/repos/asf/logging/log4cxx/;protocol=http;module=trunk"
-
-S = "${WORKDIR}/trunk"
-
-inherit autotools pkgconfig
-
-SRC_URI[md5sum] = "b30ffb8da3665178e68940ff7a61084c"
-SRC_URI[sha256sum] = "0de0396220a9566a580166e66b39674cb40efd2176f52ad2c65486c99c920c8c"