Skip to content
Snippets Groups Projects
Commit debf5e4c authored by Lukas Bulwahn's avatar Lukas Bulwahn
Browse files

navigation: updating to 1.11.6

The patches provided upstream are part of 1.11.6 and are removed.
parent 4fdfe352
No related branches found
No related tags found
No related merge requests found
From 72fbc995dd302f356b891fb93e9d0cdc6416cdb8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 13 Oct 2013 14:11:47 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
voxel_grid/CMakeLists.txt | 12 +++++++-----
voxel_grid/package.xml | 2 +-
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/voxel_grid/CMakeLists.txt b/voxel_grid/CMakeLists.txt
index d8e0f54..767dd2e 100644
--- a/voxel_grid/CMakeLists.txt
+++ b/voxel_grid/CMakeLists.txt
@@ -35,8 +35,10 @@ install(DIRECTORY include/${PROJECT_NAME}/
PATTERN ".svn" EXCLUDE
)
-catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
-target_link_libraries(voxel_grid_tests
- voxel_grid
- ${catkin_LIBRARIES}
- )
+if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(voxel_grid_tests test/voxel_grid_tests.cpp)
+ target_link_libraries(voxel_grid_tests
+ voxel_grid
+ ${catkin_LIBRARIES}
+ )
+endif()
diff --git a/voxel_grid/package.xml b/voxel_grid/package.xml
index 8a4ec86..459bcb3 100644
--- a/voxel_grid/package.xml
+++ b/voxel_grid/package.xml
@@ -12,7 +12,7 @@
<license>BSD</license>
<url>http://wiki.ros.org/voxel_grid</url>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>roscpp</build_depend>
--
1.8.1.2
...@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc ...@@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767cc
DEPENDS = "roscpp" DEPENDS = "roscpp"
require navigation.inc require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment