diff --git a/recipes-devtools/python/python-rosdep_0.11.5.bb b/recipes-devtools/python/python-rosdep_0.11.5.bb
index 3ed088c0030159d53e202f2eb5ced62e6df2de7b..adf7ae0f1446d7ac598d9371fb08398573eae117 100644
--- a/recipes-devtools/python/python-rosdep_0.11.5.bb
+++ b/recipes-devtools/python/python-rosdep_0.11.5.bb
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "46e072074270a1ea25411829814f4bdc1f34b358c950e9b8a7b75b4a40
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml python-netclient"
+RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml python-netclient python-rosdistro"
 
 inherit setuptools
 
diff --git a/recipes-devtools/python/python-rosdistro_0.4.7.bb b/recipes-devtools/python/python-rosdistro_0.4.7.bb
new file mode 100644
index 0000000000000000000000000000000000000000..68b77a503a717efa074243560f8a3cd7e7d0c6f2
--- /dev/null
+++ b/recipes-devtools/python/python-rosdistro_0.4.7.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "ROS package library"
+SECTION = "devel/python"
+LICENSE = "BSD & MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=48623a4c0f1b1f65fae1dedd990a7f54"
+SRCNAME = "rosdistro"
+
+SRC_URI = "http://download.ros.org/downloads/rosdistro/rosdistro-${PV}.tar.gz"
+SRC_URI[md5sum] = "a699690fab755fd1b92b2ac04933e227"
+SRC_URI[sha256sum] = "f44757336bcee4089f6f6d570248e7c4e09eebfe5238d6ae60d8bd35361eedc4"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} += "python-pyyaml"
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"