diff --git a/recipes-ros/packagegroups/packagegroup-ros-world.bb b/recipes-ros/packagegroups/packagegroup-ros-world.bb
new file mode 100644
index 0000000000000000000000000000000000000000..7f9da5720ff82dcab18d755e667f5663fdc08336
--- /dev/null
+++ b/recipes-ros/packagegroups/packagegroup-ros-world.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "ros-world package group"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+    packagegroup-ros-comm \
+    actionlib \
+    bond \
+    bondcpp \
+    bondpy \
+    smclib \
+    chatter-msgs \
+    chatter-receiver \
+    chatter-sender \
+    class-loader \
+    actionlib-msgs \
+    diagnostic-msgs \
+    geometry-msgs \
+    nav-msgs \
+    sensor-msgs \
+    shape-msgs \
+    stereo-msgs \
+    trajectory-msgs \
+    visualization-msgs \
+    nodelet-tutorial-math \
+    pluginlib-tutorials \
+    console-bridge \
+    dynamic-reconfigure \
+    angles \
+    tf2-msgs \
+    tf2-py \
+    tf2-ros \
+    tf2 \
+    tf \
+    image-transport \
+    nodelet-topic-tools \
+    nodelet \
+    pluginlib \
+    roscpp-tutorials \
+    rospy-tutorials \
+    "