From c65507d6020893fe8ce0ab8d36f781512a4d622f Mon Sep 17 00:00:00 2001
From: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
Date: Thu, 30 May 2013 20:46:30 +0200
Subject: [PATCH] genpy: Correct patch to setup python binary path

This closes #69 and #80 with the following error:
*** No rule to make target `/usr/lib/genpy/genmsg_py.py', needed by
`devel/lib/python2.7/site-packages/std_msgs/msg/_Bool.py'.  Stop.

Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
---
 ...make.em-use-find_program-for-GENxxx_PY_BIN.patch | 13 +++++++------
 recipes-ros/genpy/genpy_0.4.10.bb                   |  2 +-
 2 files changed, 8 insertions(+), 7 deletions(-)

diff --git a/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch b/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch
index cf37058..eb87087 100644
--- a/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch
+++ b/recipes-ros/genpy/genpy/0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch
@@ -1,7 +1,7 @@
 diff -Naur a/cmake/genpy-extras.cmake.em b/cmake/genpy-extras.cmake.em
---- a/cmake/genpy-extras.cmake.em	2012-12-22 03:39:57.000000000 +0100
-+++ b/cmake/genpy-extras.cmake.em	2013-05-22 10:46:08.000000000 +0200
-@@ -1,11 +1,16 @@
+--- a/cmake/genpy-extras.cmake.em	2013-05-30 12:31:39.000000000 +0200
++++ b/cmake/genpy-extras.cmake.em	2013-05-30 12:43:02.000000000 +0200
+@@ -1,13 +1,15 @@
  @[if DEVELSPACE]@
  # bin dir variables in develspace
  set(GENPY_BIN_DIR @(CMAKE_CURRENT_SOURCE_DIR)/scripts)
@@ -14,7 +14,8 @@ diff -Naur a/cmake/genpy-extras.cmake.em b/cmake/genpy-extras.cmake.em
  
 +find_program(GENMSG_PY_BIN genmsg_py.py PATHS ${GENPY_BIN_DIR} NO_DEFAULT_PATH CATKIN_FIND_ROOT_PATH_MODE)
 +find_program(GENSRV_PY_BIN gensrv_py.py PATHS ${GENPY_BIN_DIR} NO_DEFAULT_PATH CATKIN_FIND_ROOT_PATH_MODE)
-+
- set(GENMSG_PY_BIN ${GENPY_BIN_DIR}/genmsg_py.py)
- set(GENSRV_PY_BIN ${GENPY_BIN_DIR}/gensrv_py.py)
+-set(GENMSG_PY_BIN ${GENPY_BIN_DIR}/genmsg_py.py)
+-set(GENSRV_PY_BIN ${GENPY_BIN_DIR}/gensrv_py.py)
  
+ # Generate .msg->.h for py
+ # The generated .h files should be added ALL_GEN_OUTPUT_FILES_py
diff --git a/recipes-ros/genpy/genpy_0.4.10.bb b/recipes-ros/genpy/genpy_0.4.10.bb
index f3f84fa..2082ec8 100644
--- a/recipes-ros/genpy/genpy_0.4.10.bb
+++ b/recipes-ros/genpy/genpy_0.4.10.bb
@@ -7,7 +7,7 @@ DEPENDS = "genmsg-native"
 RDEPENDS_${PN} = "python-math genmsg python-shell"
 RDEPENDS_${PN}_class-native = ""
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "https://github.com/ros/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
            file://0001-genpy-extras.cmake.em-use-find_program-for-GENxxx_PY_BIN.patch"
-- 
GitLab