diff --git a/classes/catkin.bbclass b/classes/catkin.bbclass
index 6ab1e99294526ffacb171423c31d2befa11b3002..a9af7c55c691fcbebd574cd00ac407575dab723b 100644
--- a/classes/catkin.bbclass
+++ b/classes/catkin.bbclass
@@ -41,7 +41,6 @@ FILES_${PN} += "\
 
 FILES_${PN}-dev += "\
     ${datadir}/${ROS_BPN}/cmake \
-    ${datadir}/${ROS_BPN}/package.xml \
     ${datadir}/${ROS_BPN}/*.template \
     "
 
diff --git a/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb b/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
new file mode 100644
index 0000000000000000000000000000000000000000..52f9dbbead8411b56ff89d5592909e6a5e79dd42
--- /dev/null
+++ b/recipes-core/images/core-image-ros-groovy-qemux86-running-roscore.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A small image just capable of starting roscore."
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# add own name to hosts
+# this is a simplistic setup for the qemu virtual machine with x86 architecture,
+# and not a general solution.
+augment_hosts_setting_file () {
+	echo '127.0.0.1\tqemux86.localdomain\t\tqemux86' >> ${IMAGE_ROOTFS}/etc/hosts
+}
+
+# remove not needed ipkg informations
+# create a custom hosts file
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; augment_hosts_setting_file ; "
+
+IMAGE_INSTALL += "packagegroup-core-ssh-openssh \
+  roslaunch \
+"
diff --git a/recipes-core/images/core-image-ros-groovy-running-roscore.bb b/recipes-core/images/core-image-ros-groovy-running-roscore.bb
deleted file mode 100644
index d65e4a7c69c6068c661bf56e2cc800b3716fd153..0000000000000000000000000000000000000000
--- a/recipes-core/images/core-image-ros-groovy-running-roscore.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "A small image just capable of starting roscore."
-
-IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL}"
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-inherit core-image
-
-IMAGE_ROOTFS_SIZE = "8192"
-
-# remove not needed ipkg informations
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "
-
-IMAGE_INSTALL += "packagegroup-core-ssh-openssh \
-  roslaunch \
-"
diff --git a/recipes-ros/ros-comm/roslaunch_1.9.41.bb b/recipes-ros/ros-comm/roslaunch_1.9.41.bb
index 2edfc9a9c62bde40d022842da0ee8d0acc8f130f..4bbb883055e9b14edeec75fa524d6a1ab7043758 100644
--- a/recipes-ros/ros-comm/roslaunch_1.9.41.bb
+++ b/recipes-ros/ros-comm/roslaunch_1.9.41.bb
@@ -4,6 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
 RDEPENDS_${PN} = "\
+  coreutils \
   python-textutils \
   python-logging \
   python-threading \
@@ -16,6 +17,7 @@ RDEPENDS_${PN} = "\
   rosgraph-msgs \
     genpy \
     std-msgs \
+  rosout \
 "
 
 require ros-comm.inc