From bf9664c62b65ea3187ac8c5c93a7dda1b3f4136b Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 3 Aug 2013 10:27:11 +0200
Subject: [PATCH] rospack: improving runtime dependencies (resolves #116)

This commit includes further changes to build rospack-native.
---
 recipes-devtools/python/python-native_2.7.3.bbappend | 2 +-
 recipes-devtools/python/python-rosdep_0.10.11.bb     | 7 +++----
 recipes-ros/rospack/rospack_2.1.21.bb                | 1 +
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/recipes-devtools/python/python-native_2.7.3.bbappend b/recipes-devtools/python/python-native_2.7.3.bbappend
index 90bc835..e742099 100644
--- a/recipes-devtools/python/python-native_2.7.3.bbappend
+++ b/recipes-devtools/python/python-native_2.7.3.bbappend
@@ -1 +1 @@
-RPROVIDES += "python-xml-native"
+RPROVIDES += "python-datetime-native python-netclient-native python-subprocess-native python-xml-native"
diff --git a/recipes-devtools/python/python-rosdep_0.10.11.bb b/recipes-devtools/python/python-rosdep_0.10.11.bb
index 64004a8..993ce4d 100644
--- a/recipes-devtools/python/python-rosdep_0.10.11.bb
+++ b/recipes-devtools/python/python-rosdep_0.10.11.bb
@@ -10,9 +10,8 @@ SRC_URI[sha256sum] = "c3e741db57b7230c8ac2cceca837b98181b4fa6d1488819e615366a858
 
 S = "${WORKDIR}/${SRCNAME}-${PV}"
 
-# install_requires=['catkin_pkg', 'rospkg', 'PyYAML >= 3.1'],
-# setup_requires=['nose >= 1.0'],
-
-RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml"
+RDEPENDS_${PN} += "python-catkin-pkg python-rospkg python-pyyaml python-netclient"
 
 inherit setuptools
+
+BBCLASSEXTEND += "native"
diff --git a/recipes-ros/rospack/rospack_2.1.21.bb b/recipes-ros/rospack/rospack_2.1.21.bb
index b172acb..3610377 100644
--- a/recipes-ros/rospack/rospack_2.1.21.bb
+++ b/recipes-ros/rospack/rospack_2.1.21.bb
@@ -4,6 +4,7 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 DEPENDS = "boost python-rospkg-native libtinyxml"
+RDEPENDS_${PN} = "python-rosdep python-subprocess"
 
 SRC_URI = "https://github.com/ros/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz"
 SRC_URI[md5sum] = "0bb1d12a115b7902d5b1f8546d63cdf8"
-- 
GitLab