From bd33c6f90682a7fd5e4d954445a31ff3b97df42a Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Mon, 10 Jun 2013 09:19:00 +0200
Subject: [PATCH] common-msgs: initial commit of all common messages

---
 recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb     | 8 ++++++++
 recipes-ros/common-msgs/common-msgs.inc              | 9 +++++++++
 recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb    | 7 +++++++
 recipes-ros/common-msgs/geometry-msgs_1.9.16.bb      | 7 +++++++
 recipes-ros/common-msgs/nav-msgs_1.9.16.bb           | 8 ++++++++
 recipes-ros/common-msgs/sensor-msgs_1.9.16.bb        | 9 +++++++++
 recipes-ros/common-msgs/shape-msgs_1.9.16.bb         | 8 ++++++++
 recipes-ros/common-msgs/stereo-msgs_1.9.16.bb        | 9 +++++++++
 recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb    | 6 ++++++
 recipes-ros/common-msgs/visualization-msgs_1.9.16.bb | 9 +++++++++
 10 files changed, 80 insertions(+)
 create mode 100644 recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/common-msgs.inc
 create mode 100644 recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/geometry-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/nav-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/sensor-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/shape-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/stereo-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb
 create mode 100644 recipes-ros/common-msgs/visualization-msgs_1.9.16.bb

diff --git a/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb b/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb
new file mode 100644
index 0000000..f42de87
--- /dev/null
+++ b/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "actionlib_msgs defines the common messages to interact with an \
+action server and an action client."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
diff --git a/recipes-ros/common-msgs/common-msgs.inc b/recipes-ros/common-msgs/common-msgs.inc
new file mode 100644
index 0000000..27b60a7
--- /dev/null
+++ b/recipes-ros/common-msgs/common-msgs.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/ros/common_msgs/archive/${PV}.tar.gz;downloadfilename=common_msgs-${PV}.tar.gz"
+SRC_URI[md5sum] = "84fb70d6ba4c796903bb4b95b551e19a"
+SRC_URI[sha256sum] = "a4a02bce606c3468dcc93abdc49fc855f0d81c90a56f24594f8fa691f9a6b776"
+
+inherit catkin
+
+S = "${WORKDIR}/common_msgs-${PV}/${ROS_BPN}"
+
+DEPENDS = "cpp-common roscpp-serialization message-generation-native message-runtime-native std-msgs"
diff --git a/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb b/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb
new file mode 100644
index 0000000..919ac0c
--- /dev/null
+++ b/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "\This package holds the diagnostic messages which provide the \
+standardized interface for the diagnostic and runtime monitoring systems in ROS."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb b/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb
new file mode 100644
index 0000000..3db4efb
--- /dev/null
+++ b/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "geometry_msgs provides messages for common geometric primitives \
+such as points, vectors, and poses."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/nav-msgs_1.9.16.bb b/recipes-ros/common-msgs/nav-msgs_1.9.16.bb
new file mode 100644
index 0000000..8d76ba3
--- /dev/null
+++ b/recipes-ros/common-msgs/nav-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "nav_msgs defines the common messages used to interact with the navigation stack."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "actionlib-msgs geometry-msgs"
diff --git a/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb b/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb
new file mode 100644
index 0000000..8690899
--- /dev/null
+++ b/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "This package defines messages for commonly used sensors, including \
+cameras and scanning laser rangefinders."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"
diff --git a/recipes-ros/common-msgs/shape-msgs_1.9.16.bb b/recipes-ros/common-msgs/shape-msgs_1.9.16.bb
new file mode 100644
index 0000000..a37676f
--- /dev/null
+++ b/recipes-ros/common-msgs/shape-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "shape_msgs"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"
diff --git a/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb b/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb
new file mode 100644
index 0000000..fb64ca3
--- /dev/null
+++ b/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "stereo_msgs contains messages specific to stereo processing, \
+such as disparity images."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "sensor-msgs"
diff --git a/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb b/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb
new file mode 100644
index 0000000..57f2229
--- /dev/null
+++ b/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "trajectory_msgs"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb b/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb
new file mode 100644
index 0000000..d05f185
--- /dev/null
+++ b/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "visualization_msgs is a set of messages used by higher level \
+packages, such as rviz, that deal in visualization-specific data."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"
-- 
GitLab