diff --git a/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb b/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..f42de8783e1c80cea941b78aa45f7d62372e68bb
--- /dev/null
+++ b/recipes-ros/common-msgs/actionlib-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "actionlib_msgs defines the common messages to interact with an \
+action server and an action client."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
diff --git a/recipes-ros/common-msgs/common-msgs.inc b/recipes-ros/common-msgs/common-msgs.inc
new file mode 100644
index 0000000000000000000000000000000000000000..27b60a71f851418a26c3381a6f319dbd670beffa
--- /dev/null
+++ b/recipes-ros/common-msgs/common-msgs.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/ros/common_msgs/archive/${PV}.tar.gz;downloadfilename=common_msgs-${PV}.tar.gz"
+SRC_URI[md5sum] = "84fb70d6ba4c796903bb4b95b551e19a"
+SRC_URI[sha256sum] = "a4a02bce606c3468dcc93abdc49fc855f0d81c90a56f24594f8fa691f9a6b776"
+
+inherit catkin
+
+S = "${WORKDIR}/common_msgs-${PV}/${ROS_BPN}"
+
+DEPENDS = "cpp-common roscpp-serialization message-generation-native message-runtime-native std-msgs"
diff --git a/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb b/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..919ac0c0e01f32f8fdb8525ee291701b95caf381
--- /dev/null
+++ b/recipes-ros/common-msgs/diagnostic-msgs_1.9.16.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "\This package holds the diagnostic messages which provide the \
+standardized interface for the diagnostic and runtime monitoring systems in ROS."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb b/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..3db4efb3b7fd4af4df53ff941391101ab7d420c5
--- /dev/null
+++ b/recipes-ros/common-msgs/geometry-msgs_1.9.16.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "geometry_msgs provides messages for common geometric primitives \
+such as points, vectors, and poses."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/nav-msgs_1.9.16.bb b/recipes-ros/common-msgs/nav-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..8d76ba371262b8f8954f0290ec6fd449778dcc90
--- /dev/null
+++ b/recipes-ros/common-msgs/nav-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "nav_msgs defines the common messages used to interact with the navigation stack."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "actionlib-msgs geometry-msgs"
diff --git a/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb b/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..8690899aba3114300fe7dfdfde4018a4c7191022
--- /dev/null
+++ b/recipes-ros/common-msgs/sensor-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "This package defines messages for commonly used sensors, including \
+cameras and scanning laser rangefinders."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"
diff --git a/recipes-ros/common-msgs/shape-msgs_1.9.16.bb b/recipes-ros/common-msgs/shape-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..a37676f3b3fab1f1935724da5bebe3b6da2c6c3a
--- /dev/null
+++ b/recipes-ros/common-msgs/shape-msgs_1.9.16.bb
@@ -0,0 +1,8 @@
+DESCRIPTION = "shape_msgs"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"
diff --git a/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb b/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..fb64ca3db495fb2404e9fb52faec6cd33e50e46d
--- /dev/null
+++ b/recipes-ros/common-msgs/stereo-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "stereo_msgs contains messages specific to stereo processing, \
+such as disparity images."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "sensor-msgs"
diff --git a/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb b/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..57f222982db5e66e5d0f6a08a931bf7a03668a21
--- /dev/null
+++ b/recipes-ros/common-msgs/trajectory-msgs_1.9.16.bb
@@ -0,0 +1,6 @@
+DESCRIPTION = "trajectory_msgs"
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
diff --git a/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb b/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb
new file mode 100644
index 0000000000000000000000000000000000000000..d05f1856676a38527c96633613d03675333167d5
--- /dev/null
+++ b/recipes-ros/common-msgs/visualization-msgs_1.9.16.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "visualization_msgs is a set of messages used by higher level \
+packages, such as rviz, that deal in visualization-specific data."
+SECTION = "devel"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
+
+require common-msgs.inc
+
+DEPENDS += "geometry-msgs"