diff --git a/recipes-ros/chatter/chatter-msgs_git.bb b/recipes-ros/chatter/chatter-msgs_0.1.0.bb
similarity index 62%
rename from recipes-ros/chatter/chatter-msgs_git.bb
rename to recipes-ros/chatter/chatter-msgs_0.1.0.bb
index 6a9941bb1bdcce26817bcae422848d75999061ce..85d9a3cbb7e2597e10ff35fd722141bf5e35b57a 100644
--- a/recipes-ros/chatter/chatter-msgs_git.bb
+++ b/recipes-ros/chatter/chatter-msgs_0.1.0.bb
@@ -5,11 +5,4 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
 
 DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
 
-SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
-
-SRCREV = "${AUTOREV}"
-PV = "1.0.0+gitr${SRCPV}"
-
-S = "${WORKDIR}/git/chatter_msgs"
-
-inherit catkin
+require chatter.inc
diff --git a/recipes-ros/chatter/chatter-receiver_git.bb b/recipes-ros/chatter/chatter-receiver_0.1.0.bb
similarity index 57%
rename from recipes-ros/chatter/chatter-receiver_git.bb
rename to recipes-ros/chatter/chatter-receiver_0.1.0.bb
index 5169aa1c05b77c1f34bbb53b161f13e6cfabbda6..860420bd6a4681041b1991af483edcc8fb8b0a4f 100644
--- a/recipes-ros/chatter/chatter-receiver_git.bb
+++ b/recipes-ros/chatter/chatter-receiver_0.1.0.bb
@@ -5,11 +5,4 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
 
 DEPENDS = "chatter-msgs roscpp"
 
-SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
-
-SRCREV = "${AUTOREV}"
-PV = "1.0.0+gitr${SRCPV}"
-
-S = "${WORKDIR}/git/chatter_receiver"
-
-inherit catkin
+require chatter.inc
diff --git a/recipes-ros/chatter/chatter-sender_git.bb b/recipes-ros/chatter/chatter-sender_0.1.0.bb
similarity index 63%
rename from recipes-ros/chatter/chatter-sender_git.bb
rename to recipes-ros/chatter/chatter-sender_0.1.0.bb
index d7fad359be7a08c15a8a23524b9a6f383dc5442b..f8ae9db12de0724327759f293efe1abf636e37bd 100644
--- a/recipes-ros/chatter/chatter-sender_git.bb
+++ b/recipes-ros/chatter/chatter-sender_0.1.0.bb
@@ -5,12 +5,6 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
 
 DEPENDS = "chatter-msgs roscpp"
 
-SRC_URI = "git://github.com/bmwcarit/ros_chatter.git"
-SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
-
-SRCREV = "${AUTOREV}"
-PV = "1.0.0+gitr${SRCPV}"
+require chatter.inc
 
-S = "${WORKDIR}/git/chatter_sender"
-
-inherit catkin
+SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
diff --git a/recipes-ros/chatter/chatter.inc b/recipes-ros/chatter/chatter.inc
new file mode 100644
index 0000000000000000000000000000000000000000..28387a3f473f47540070fdaff1cbe511d335a744
--- /dev/null
+++ b/recipes-ros/chatter/chatter.inc
@@ -0,0 +1,9 @@
+SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
+SRC_URI[md5sum] = "c26fdc13d96d1b65d0c1e03b41572550"
+SRC_URI[sha256sum] = "b18f8a08fe8bdc4d7a89ee9ab15892348c25d508dad1bed87e795805506f315f"
+
+S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
+
+inherit catkin
+
+ROS_SPN = "ros_chatter"
diff --git a/recipes-ros/cmake-modules/cmake-modules_0.1.0.bb b/recipes-ros/cmake-modules/cmake-modules_0.2.0.bb
similarity index 82%
rename from recipes-ros/cmake-modules/cmake-modules_0.1.0.bb
rename to recipes-ros/cmake-modules/cmake-modules_0.2.0.bb
index 6fafc7c464530aba85c48498213812bb809e3959..94182622ba0846fbd137c631a81141a3f926162d 100644
--- a/recipes-ros/cmake-modules/cmake-modules_0.1.0.bb
+++ b/recipes-ros/cmake-modules/cmake-modules_0.2.0.bb
@@ -5,8 +5,8 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
 
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "988ce2ea80d375eebe36984c39b948d4"
-SRC_URI[sha256sum] = "5ba9d987fad3ee781ca1b85af7cc07567b8f955346b4beb2c0b5140cf10b2a16"
+SRC_URI[md5sum] = "8e24844c6c06043b596291be926f9141"
+SRC_URI[sha256sum] = "d10ec20fb5997a84513044abb2597ab090ddd4a6cd551b4fd277b2ee4649afcf"
 
 SRC_URI += "file://0001-Fix-the-path-added-to-CMAKE_MODULE_PATH.patch;striplevel=1;name=patch"
 SRC_URI[patch.md5sum] = "eba3a7eda081516f2113d6db70e881df"
diff --git a/recipes-ros/octomap/octomap.inc b/recipes-ros/octomap/octomap.inc
index fcfc74f55cef5317a70493b6494b2b5afe530e3e..b3a696b11889fb2a5909d72168701af55a13aea3 100644
--- a/recipes-ros/octomap/octomap.inc
+++ b/recipes-ros/octomap/octomap.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/OctoMap/${ROS_SPN}/archive/v${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "b4ea2f354e286c48263543dac42cf555"
-SRC_URI[sha256sum] = "c68b75913ea5ebeb5459eaf2114801477aeaa2a584b018b8816f8a510150e76e"
+SRC_URI[md5sum] = "c53b4a57bd5dd3bb0c6da98be06bfb44"
+SRC_URI[sha256sum] = "897d8dc8859cc1a43d1b505382dc2afcecd7310880282ef777d90498751b1d1b"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/octomap/octomap_1.6.1.bb b/recipes-ros/octomap/octomap_1.6.2.bb
similarity index 100%
rename from recipes-ros/octomap/octomap_1.6.1.bb
rename to recipes-ros/octomap/octomap_1.6.2.bb
diff --git a/recipes-ros/robot-model/collada-parser_1.10.17.bb b/recipes-ros/robot-model/collada-parser_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/collada-parser_1.10.17.bb
rename to recipes-ros/robot-model/collada-parser_1.10.18.bb
diff --git a/recipes-ros/robot-model/collada-urdf_1.10.17.bb b/recipes-ros/robot-model/collada-urdf_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/collada-urdf_1.10.17.bb
rename to recipes-ros/robot-model/collada-urdf_1.10.18.bb
diff --git a/recipes-ros/robot-model/joint-state-publisher_1.10.17.bb b/recipes-ros/robot-model/joint-state-publisher_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/joint-state-publisher_1.10.17.bb
rename to recipes-ros/robot-model/joint-state-publisher_1.10.18.bb
diff --git a/recipes-ros/robot-model/kdl-parser_1.10.17.bb b/recipes-ros/robot-model/kdl-parser_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/kdl-parser_1.10.17.bb
rename to recipes-ros/robot-model/kdl-parser_1.10.18.bb
diff --git a/recipes-ros/robot-model/resource-retriever_1.10.17.bb b/recipes-ros/robot-model/resource-retriever_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/resource-retriever_1.10.17.bb
rename to recipes-ros/robot-model/resource-retriever_1.10.18.bb
diff --git a/recipes-ros/robot-model/robot-model.inc b/recipes-ros/robot-model/robot-model.inc
index 6df421bcce43660ece2f7d8ec19c81e767b33eaa..0138a2888c7ff1862ca90b7b3c0f8673f835ec31 100644
--- a/recipes-ros/robot-model/robot-model.inc
+++ b/recipes-ros/robot-model/robot-model.inc
@@ -1,6 +1,6 @@
 SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
-SRC_URI[md5sum] = "77c87b3045771a9875f51000fe075559"
-SRC_URI[sha256sum] = "cb6cf4beb4429bc9a5d6502a1865c5dae447a40c09f8188a0253e931e66e5f78"
+SRC_URI[md5sum] = "a2852ce1e1b3a7805f0a0836b8942811"
+SRC_URI[sha256sum] = "908dee4ff9031a0f954f98f8c5b646c24efd86ec352887df4882b1b6e067c5b6"
 
 S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
 
diff --git a/recipes-ros/robot-model/urdf-parser-plugin_1.10.17.bb b/recipes-ros/robot-model/urdf-parser-plugin_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/urdf-parser-plugin_1.10.17.bb
rename to recipes-ros/robot-model/urdf-parser-plugin_1.10.18.bb
diff --git a/recipes-ros/robot-model/urdf_1.10.17.bb b/recipes-ros/robot-model/urdf_1.10.18.bb
similarity index 100%
rename from recipes-ros/robot-model/urdf_1.10.17.bb
rename to recipes-ros/robot-model/urdf_1.10.18.bb