diff --git a/recipes-devtools/python/python-netifaces_0.8.bb b/recipes-devtools/python/python-netifaces_0.8.bb
new file mode 100644
index 0000000000000000000000000000000000000000..f15ba977628bd71c2740a071a97c32ff7ff17afd
--- /dev/null
+++ b/recipes-devtools/python/python-netifaces_0.8.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Portable network interface information for Python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8376078ca8314aaec5a58b802edf3c15"
+SRCNAME = "netifaces"
+
+SRC_URI = "http://alastairs-place.net/projects/netifaces/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "e57e5983f4c286fac5f8068fbfc5c873"
+SRC_URI[sha256sum] = "53a711038db3d6e5cf7129d6f751185fd052f830f12f271fbfe17bd2671ab1ec"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
diff --git a/recipes-ros/ros-comm/rosgraph_1.9.47.bb b/recipes-ros/ros-comm/rosgraph_1.9.47.bb
index 11e744f30ff5e00fcfe767582d3e9949d9a1b8e5..3c8c3227bbbaf360e1ca6c7bf91c131af171844f 100644
--- a/recipes-ros/ros-comm/rosgraph_1.9.47.bb
+++ b/recipes-ros/ros-comm/rosgraph_1.9.47.bb
@@ -4,7 +4,7 @@ SECTION = "devel"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
 
-RDEPENDS_${PN} = "python-xmlrpc python-threading python-rospkg rospy"
+RDEPENDS_${PN} = "python-xmlrpc python-threading python-rospkg rospy python-netifaces"
 
 require ros-comm.inc
 
diff --git a/recipes-ros/ros-comm/roslaunch_1.9.47.bb b/recipes-ros/ros-comm/roslaunch_1.9.47.bb
index 4bbb883055e9b14edeec75fa524d6a1ab7043758..762b0f5033b561e31805ea60bb0d993ac6cca2ab 100644
--- a/recipes-ros/ros-comm/roslaunch_1.9.47.bb
+++ b/recipes-ros/ros-comm/roslaunch_1.9.47.bb
@@ -18,6 +18,7 @@ RDEPENDS_${PN} = "\
     genpy \
     std-msgs \
   rosout \
+  rosparam \
 "
 
 require ros-comm.inc